aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-libs')
-rw-r--r--net-libs/usockets/files/usockets-Makefile.patch17
-rw-r--r--net-libs/usockets/metadata.xml18
-rw-r--r--net-libs/usockets/usockets-0.4.1-r1.ebuild (renamed from net-libs/usockets/usockets-0.4.1.ebuild)20
-rw-r--r--net-libs/usockets/usockets-9999.ebuild20
4 files changed, 34 insertions, 41 deletions
diff --git a/net-libs/usockets/files/usockets-Makefile.patch b/net-libs/usockets/files/usockets-Makefile.patch
index a51f8b16b..5be09eeee 100644
--- a/net-libs/usockets/files/usockets-Makefile.patch
+++ b/net-libs/usockets/files/usockets-Makefile.patch
@@ -1,5 +1,5 @@
diff --git a/Makefile b/Makefile
-index fa6e2ff..529ed74 100644
+index fa6e2ff..ca2603f 100644
--- a/Makefile
+++ b/Makefile
@@ -1,3 +1,14 @@
@@ -17,28 +17,21 @@ index fa6e2ff..529ed74 100644
# WITH_OPENSSL=1 enables OpenSSL 1.1+ support
ifeq ($(WITH_OPENSSL),1)
override CFLAGS += -DLIBUS_USE_OPENSSL
-@@ -33,13 +44,33 @@ ifeq ($(WITH_ASAN),1)
+@@ -33,13 +44,27 @@ ifeq ($(WITH_ASAN),1)
endif
override CFLAGS += -std=c11 -Isrc
-override LDFLAGS += uSockets.a
-# By default we build the uSockets.a static library
--default:
-+static:
+ default:
rm -f *.o
- $(CC) $(CFLAGS) -flto -O3 -c src/*.c src/eventing/*.c src/crypto/*.c
- $(AR) rvs uSockets.a *.o
-+ $(CC) $(CFLAGS) -c src/*.c src/eventing/*.c src/crypto/*.c
-+ $(AR) rvs libusockets.a *.o
-+
-+dynamic:
-+ rm -f *.o
+ $(CC) -fPIC -c src/*.c src/eventing/*.c src/crypto/*.c $(CFLAGS)
++ $(AR) rvs libusockets.a *.o
+ $(CC) -shared -fPIC -Wl,-soname,$(LIBTARGET) $(CFLAGS) -o $(LIBTARGET) *.o $(LDFLAGS)
+
-+default: static dynamic
-+
+install:
+ # install the folders needed (making sure that the exist)
+ install -d "$(DESTDIR)$(libdir)" \
@@ -56,7 +49,7 @@ index fa6e2ff..529ed74 100644
# Builds all examples
.PHONY: examples
-@@ -52,4 +83,5 @@ swift_examples:
+@@ -52,4 +77,5 @@ swift_examples:
clean:
rm -f *.o
rm -f *.a
diff --git a/net-libs/usockets/metadata.xml b/net-libs/usockets/metadata.xml
index 73dd5769c..a24f33aee 100644
--- a/net-libs/usockets/metadata.xml
+++ b/net-libs/usockets/metadata.xml
@@ -1,11 +1,15 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
- <maintainer type="person">
- <email>gentoo@aisha.cc</email>
- <name>Aisha Tammy</name>
- </maintainer>
- <use>
- <flag name="libuv">Enable bindings to use the libuv dispatcher</flag>
- </use>
+ <maintainer type="person">
+ <email>gentoo@aisha.cc</email>
+ <name>Aisha Tammy</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
+ <use>
+ <flag name="libuv">Enable bindings to use the libuv dispatcher</flag>
+ </use>
</pkgmetadata>
diff --git a/net-libs/usockets/usockets-0.4.1.ebuild b/net-libs/usockets/usockets-0.4.1-r1.ebuild
index 0b4a1f0a5..07f682856 100644
--- a/net-libs/usockets/usockets-0.4.1.ebuild
+++ b/net-libs/usockets/usockets-0.4.1-r1.ebuild
@@ -27,7 +27,6 @@ DEPEND="ssl? (
)
libuv? ( dev-libs/libuv[static-libs?] )
"
-BDEPEND="${DEPEND}"
RDEPEND="${DEPEND}"
PATCHES=(
@@ -36,19 +35,18 @@ PATCHES=(
src_compile() {
# the Makefile uses environment variables
- emake -j1 \
- LIBusockets_VERSION=${PV} \
- WITH_OPENSSL=$(usex ssl 1 0) \
- WITH_LIBUV=$(usex libuv 1 0) \
- default
+ emake LIBusockets_VERSION=${PV} \
+ WITH_OPENSSL=$(usex ssl 1 0) \
+ WITH_LIBUV=$(usex libuv 1 0) \
+ default
}
src_install() {
- emake -j1 \
- libdir="/usr/$(get_libdir)" \
- prefix="/usr" DESTDIR="${D}" \
- LIBusockets_VERSION=${PV} \
- install
+ emake libdir="/usr/$(get_libdir)" \
+ prefix="/usr" \
+ DESTDIR="${D}" \
+ LIBusockets_VERSION=${PV} \
+ install
einstalldocs
if ! use static-libs; then
rm "${D}/usr/$(get_libdir)/libusockets.a" || die
diff --git a/net-libs/usockets/usockets-9999.ebuild b/net-libs/usockets/usockets-9999.ebuild
index 0b4a1f0a5..07f682856 100644
--- a/net-libs/usockets/usockets-9999.ebuild
+++ b/net-libs/usockets/usockets-9999.ebuild
@@ -27,7 +27,6 @@ DEPEND="ssl? (
)
libuv? ( dev-libs/libuv[static-libs?] )
"
-BDEPEND="${DEPEND}"
RDEPEND="${DEPEND}"
PATCHES=(
@@ -36,19 +35,18 @@ PATCHES=(
src_compile() {
# the Makefile uses environment variables
- emake -j1 \
- LIBusockets_VERSION=${PV} \
- WITH_OPENSSL=$(usex ssl 1 0) \
- WITH_LIBUV=$(usex libuv 1 0) \
- default
+ emake LIBusockets_VERSION=${PV} \
+ WITH_OPENSSL=$(usex ssl 1 0) \
+ WITH_LIBUV=$(usex libuv 1 0) \
+ default
}
src_install() {
- emake -j1 \
- libdir="/usr/$(get_libdir)" \
- prefix="/usr" DESTDIR="${D}" \
- LIBusockets_VERSION=${PV} \
- install
+ emake libdir="/usr/$(get_libdir)" \
+ prefix="/usr" \
+ DESTDIR="${D}" \
+ LIBusockets_VERSION=${PV} \
+ install
einstalldocs
if ! use static-libs; then
rm "${D}/usr/$(get_libdir)/libusockets.a" || die