aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-misc')
-rw-r--r--net-misc/rpki-client/Manifest1
-rw-r--r--net-misc/rpki-client/files/rpki-client-6.7-update.patch25
-rw-r--r--net-misc/rpki-client/rpki-client-6.7_p0.ebuild68
3 files changed, 94 insertions, 0 deletions
diff --git a/net-misc/rpki-client/Manifest b/net-misc/rpki-client/Manifest
index afc9431a2..dbc651310 100644
--- a/net-misc/rpki-client/Manifest
+++ b/net-misc/rpki-client/Manifest
@@ -1,2 +1,3 @@
DIST rpki-client-0.3.0.tar.gz 81004 BLAKE2B 1831ed0aab4f4112391ba2c40c7b335f5284c4fe13d2e0e59e5996c909368285073018a3d9b431f88fdc347a8281d2fc4613de68badcab011061e7274d3df2bf SHA512 92f62b3137a3848aa3cf27b5b303b1ce097da961dcb684b8bad9fa224690f2f233658bd3c73e48d60d3c7df965173a1c935b0497a61084fe0986dce4feb4bd70
DIST rpki-client-6.6_p2.tar.gz 42840 BLAKE2B f5075376925cad57893a27c463c6727362e108cbccb348785ca4940fbaa8262286342ecb6f5fa59a0615009bc16571b15218483822c827528ecc19e1963c9e6b SHA512 5acdabef9b0373fb2fe47a2b9cb2638809ac1260b273c1566e3dbd34287c3703dd7979a7ba98b7d5b305664add6f2d5af4564ad2315033406e5e835f1051951f
+DIST rpki-client-6.7_p0.tar.gz 44454 BLAKE2B 2336f3a8f4a0cb53a9c6f4df6dbd269ff1e8bcb11b61d4c283c3153e563054efb163339ec7852f45e12cc7e9544522d7dabc62d0f79b5a6951014e47980caad9 SHA512 018e237a4075779850f18bdc69c49dac03d8bb2d377dbd680f1faa307057647ea3188acb6b78766e6563dd48afadd5eaea419413c41a018882d1a8b147bb6630
diff --git a/net-misc/rpki-client/files/rpki-client-6.7-update.patch b/net-misc/rpki-client/files/rpki-client-6.7-update.patch
new file mode 100644
index 000000000..e1296300c
--- /dev/null
+++ b/net-misc/rpki-client/files/rpki-client-6.7-update.patch
@@ -0,0 +1,25 @@
+--- a/update.sh 2020-05-19 20:27:54.816143493 +0200
++++ b/update.sh 2020-05-19 20:28:03.700182804 +0200
+@@ -4,22 +4,6 @@
+ openbsd_branch=`cat OPENBSD_BRANCH`
+ openbgpd_version=`cat VERSION`
+
+-# pull in latest upstream code
+-echo "pulling upstream openbsd source"
+-if [ ! -d openbsd ]; then
+- if [ -z "${RPKICLIENT_GIT}" ]; then
+- git clone https://github.com/rpki-client/rpki-client-openbsd.git openbsd
+- else
+- git clone "${RPKICLIENT_GIT}/openbsd"
+- fi
+-fi
+-if [ -d openbsd/.git ]; then
+- (cd openbsd/src
+- git fetch
+- git checkout "${openbsd_branch}"
+- git pull --rebase)
+-fi
+-
+ # setup source paths
+ dir=`pwd`
+ patches="${dir}/patches"
diff --git a/net-misc/rpki-client/rpki-client-6.7_p0.ebuild b/net-misc/rpki-client/rpki-client-6.7_p0.ebuild
new file mode 100644
index 000000000..b9a0673ba
--- /dev/null
+++ b/net-misc/rpki-client/rpki-client-6.7_p0.ebuild
@@ -0,0 +1,68 @@
+# Copyright 2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools git-r3
+
+MY_PN="${PN}-portable"
+MY_PV="${PV/_p/p}"
+MY_P="${MY_PN}-${MY_PV}"
+
+DESCRIPTION="Portability shim for OpenBSD's rpki-client"
+HOMEPAGE="https://rpki-client.org/"
+SRC_URI="https://github.com/${PN}/${MY_PN}/archive/${MY_PV}.tar.gz -> ${P}.tar.gz"
+EGIT_REPO_URI="https://github.com/${PN}/${PN}-openbsd.git"
+
+LICENSE="ISC"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="
+ acct-group/_rpki-client
+ acct-user/_rpki-client
+"
+RDEPEND="${DEPEND}"
+BDEPEND=""
+
+PATCHES=(
+ "${FILESDIR}/${PN}-${PV%_*}-update.patch"
+)
+
+S="${WORKDIR}/${MY_P}"
+
+src_unpack() {
+ default
+
+ EGIT_BRANCH=$(cat "${S}"/OPENBSD_BRANCH)
+ EGIT_CHECKOUT_DIR="${S}/openbsd"
+ git-r3_fetch
+ git-r3_checkout
+}
+
+src_prepare() {
+ default
+
+ cd "${S}"
+ ./autogen.sh
+
+ eautoreconf
+}
+
+src_configure() {
+ local myeconfargs=(
+ --with-rsync=rsync
+ --with-base-dir="/var/cache/${PN}"
+ --with-output-dir="/var/db/${PN}"
+ )
+ econf "${myeconfargs[@]}"
+}
+
+src_install() {
+ emake DESTDIR="${D}" BINDIR="/usr/bin" MANDIR="/usr/share/man" install
+ insinto /etc/rpki
+ doins *.tal
+ keepdir "/var/db/${PN}/"
+ fowners -R _rpki-client "/var/db/${PN}/"
+}