aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-cluster')
-rw-r--r--sys-cluster/shuffile/Manifest1
-rw-r--r--sys-cluster/shuffile/metadata.xml13
-rw-r--r--sys-cluster/shuffile/shuffile-0.0.3.ebuild39
3 files changed, 53 insertions, 0 deletions
diff --git a/sys-cluster/shuffile/Manifest b/sys-cluster/shuffile/Manifest
new file mode 100644
index 000000000..999e3b0bb
--- /dev/null
+++ b/sys-cluster/shuffile/Manifest
@@ -0,0 +1 @@
+DIST shuffile-0.0.3.tar.gz 20069 BLAKE2B cb40b12334e7ec2f70140d6d2cb11f77cdb72d381dc5ecf4b335c4324f0e6c777113546b91edf290767c6daa5d0e7641b4849cad42230688a799e1a4359f4dfb SHA512 e5ca8b7ab1542fda0c84d92bba527911846cdd95cbe86d4aa0075abacffc369485ad7187bc7e0ee2edcd69ccbc4ef2abcd0de75be497c0cdc3d6177563067875
diff --git a/sys-cluster/shuffile/metadata.xml b/sys-cluster/shuffile/metadata.xml
new file mode 100644
index 000000000..11f798ae7
--- /dev/null
+++ b/sys-cluster/shuffile/metadata.xml
@@ -0,0 +1,13 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>lssndrbarbieri@gmail.com</email>
+ <name>Alessandro Barbieri</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">ECP-VeloC/shuffile</remote-id>
+ </upstream>
+ <longdescription lang="en">This module lets one associate a set of files with a process name. Currently, the name is implied to be the rank within MPI_COMM_WORLD. In the event that a set of distributed processes are moved, for example when restarting an MPI job, functions will migrate files from their original locations to the new locations where the processes are running.
+ </longdescription>
+</pkgmetadata>
diff --git a/sys-cluster/shuffile/shuffile-0.0.3.ebuild b/sys-cluster/shuffile/shuffile-0.0.3.ebuild
new file mode 100644
index 000000000..5054b99cc
--- /dev/null
+++ b/sys-cluster/shuffile/shuffile-0.0.3.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="7"
+
+inherit cmake-utils
+
+DESCRIPTION="SHUFFILE Shuffle files between processes"
+HOMEPAGE="https://github.com/ECP-VeloC/shuffile"
+SRC_URI="https://github.com/ECP-VeloC/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="mpi test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ mpi? ( virtual/mpi )
+ sys-libs/zlib
+ >=sys-cluster/KVTree-1.0.2
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ >=dev-util/cmake-2.8
+"
+src_prepare() {
+ #do not build static library
+ sed -i '/shuffile-static/d' src/CMakeLists.txt || die
+ default
+ cmake-utils_src_prepare
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DMPI="$(usex mpi "" OFF)"
+ )
+ cmake-utils_src_configure
+}