aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'www-client/badwolf/badwolf-0.1.1.ebuild')
-rw-r--r--www-client/badwolf/badwolf-0.1.1.ebuild53
1 files changed, 53 insertions, 0 deletions
diff --git a/www-client/badwolf/badwolf-0.1.1.ebuild b/www-client/badwolf/badwolf-0.1.1.ebuild
new file mode 100644
index 000000000..a8093a216
--- /dev/null
+++ b/www-client/badwolf/badwolf-0.1.1.ebuild
@@ -0,0 +1,53 @@
+# Copyright 2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit savedconfig
+
+if [[ "${PV}" == "9999" ]]
+then
+ EGIT_REPO_URI="https://hacktivis.me/git/badwolf.git"
+ EGIT_MIN_CLONE_TYPE="single+tags"
+ inherit git-r3
+else
+ MY_P="${PN}-$(ver_rs 3 - 4 .)"
+ SRC_URI="https://hacktivis.me/releases/${MY_P}.tar.gz"
+ KEYWORDS="~amd64"
+ S="${WORKDIR}/${MY_P}"
+fi
+
+DESCRIPTION="Minimalist and privacy-oriented WebKitGTK+ browser"
+HOMEPAGE="https://hacktivis.me/project/badwolf"
+LICENSE="BSD"
+SLOT="0"
+
+DOCS=("README.md" "KnowledgeBase.md")
+
+DEPEND="
+ x11-libs/gtk+:3
+ net-libs/webkit-gtk
+"
+
+src_configure() {
+ restore_config config.h
+ default
+}
+
+src_compile() {
+ emake \
+ CC="${CC:-cc}" \
+ CFLAGS="${CFLAGS:--02 -Wall -Wextra}" \
+ LDFLAGS="${LDFLAGS}" \
+ PREFIX="/usr"
+}
+
+src_install() {
+ emake \
+ DESTDIR="${D}" \
+ PREFIX="/usr" \
+ install
+
+ save_config config.h
+ einstalldocs
+}