aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'www-client')
-rw-r--r--www-client/torbrowser-launcher/Manifest1
-rw-r--r--www-client/torbrowser-launcher/torbrowser-launcher-0.3.2.ebuild53
2 files changed, 0 insertions, 54 deletions
diff --git a/www-client/torbrowser-launcher/Manifest b/www-client/torbrowser-launcher/Manifest
index f757cedbd..1a9da1946 100644
--- a/www-client/torbrowser-launcher/Manifest
+++ b/www-client/torbrowser-launcher/Manifest
@@ -1,2 +1 @@
-DIST torbrowser-launcher-0.3.2.tar.gz 227363 BLAKE2B b3e35f546ef84aec02a3b75068b08a6d60f9f41f6194d1bf25862c48780f77d72e4443e594add04c5a0d44cf01bcfc8c04d6d7d67c767c2cc75cc8b4a9c42f9c SHA512 26c5517723c730591ea5c4b81e30728e9db7323afcafc99d17a178d4300bad3df8731ffb063cc53fe189a3b5e2872395c913b9eea6595acac7f31ff4a1c5f105
DIST torbrowser-launcher-0.3.3.tar.gz 187239 BLAKE2B 8792e5474efe32124b401287bfbe01caef40381a35bb09062903da09c51f246b6092da2a3ffb84531c8f2be1bb45079263b8e46c98c5efa370abc6200289ac99 SHA512 129bcc3006d1cda92ab521c5106cacccf934b964b737f28bd89de6872f061b9e039678ca34b8ed30f348a0a47c3d87661b103f48e19a7edfae72a69512220fe6
diff --git a/www-client/torbrowser-launcher/torbrowser-launcher-0.3.2.ebuild b/www-client/torbrowser-launcher/torbrowser-launcher-0.3.2.ebuild
deleted file mode 100644
index a5c71f21d..000000000
--- a/www-client/torbrowser-launcher/torbrowser-launcher-0.3.2.ebuild
+++ /dev/null
@@ -1,53 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-DISTUTILS_USE_SETUPTOOLS=no
-PYTHON_COMPAT=( python3_{7..9} )
-
-inherit distutils-r1 xdg
-
-DESCRIPTION="A program to download, updated, and run the Tor Browser Bundle"
-HOMEPAGE="https://github.com/micahflee/torbrowser-launcher"
-
-if [[ "${PV}" == *9999* ]]; then
- inherit git-r3
- EGIT_REPO_URI="https://github.com/micahflee/${PN}.git"
-else
- SRC_URI="https://github.com/micahflee/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
- KEYWORDS="~amd64"
-fi
-
-RESTRICT="test"
-LICENSE="MIT"
-SLOT="0"
-IUSE="apparmor"
-
-RDEPEND="
- app-crypt/gpgme[python,${PYTHON_USEDEP}]
- dev-python/PyQt5[${PYTHON_USEDEP},widgets]
- dev-python/PySocks[${PYTHON_USEDEP}]
- dev-python/requests[${PYTHON_USEDEP}]
- apparmor? ( sys-libs/libapparmor )
-"
-
-PATCHES=(
- "${FILESDIR}/${PN}-distro.patch"
-)
-
-python_install_all() {
- distutils-r1_python_install_all
-
- # delete apparmor profiles
- if ! use apparmor; then
- rm -r "${D}/etc/apparmor.d" || die "Failed to remove apparmor profiles"
- rmdir "${D}/etc" || die "Failed to remove empty directory"
- fi
-}
-
-pkg_postinst() {
- xdg_pkg_postinst
-
- elog "For updating over system TOR install net-vpn/tor and dev-python/txsocksx"
-}