aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authororbea <orbea@riseup.net>2023-05-31 07:56:30 -0700
committerorbea <orbea@riseup.net>2023-05-31 07:56:30 -0700
commit8691c69e34eef56b4f6085cb82895a37dd88c8da (patch)
treecd18b7f82205f8495bd8019dbf0708d5b30d2a08
parentapp-crypt/tpm2-tss: sync ::gentoo (diff)
downloadlibressl-8691c69e34eef56b4f6085cb82895a37dd88c8da.tar.gz
libressl-8691c69e34eef56b4f6085cb82895a37dd88c8da.tar.bz2
libressl-8691c69e34eef56b4f6085cb82895a37dd88c8da.zip
dev-lang/python: sync ::gentoo
Signed-off-by: orbea <orbea@riseup.net>
-rw-r--r--dev-lang/python/python-3.10.11.ebuild3
-rw-r--r--dev-lang/python/python-3.11.3.ebuild3
-rw-r--r--dev-lang/python/python-3.9.16_p3-r1.ebuild3
3 files changed, 6 insertions, 3 deletions
diff --git a/dev-lang/python/python-3.10.11.ebuild b/dev-lang/python/python-3.10.11.ebuild
index 47f947a..440d270 100644
--- a/dev-lang/python/python-3.10.11.ebuild
+++ b/dev-lang/python/python-3.10.11.ebuild
@@ -30,7 +30,7 @@ LICENSE="PSF-2"
SLOT="${PYVER}"
KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~loong ~m68k ~mips ppc ppc64 ~riscv ~s390 sparc x86"
IUSE="
- bluetooth build +ensurepip examples gdbm hardened libedit lto
+ bluetooth build debug +ensurepip examples gdbm hardened libedit lto
+ncurses pgo +readline +sqlite +ssl test tk valgrind +xml
"
RESTRICT="!test? ( test )"
@@ -233,6 +233,7 @@ src_configure() {
--with-system-ffi
--with-wheel-pkg-dir="${EPREFIX}"/usr/lib/python/ensurepip
+ $(use_with debug assertions)
$(use_with lto)
$(use_enable pgo optimizations)
$(use_with readline readline "$(usex libedit editline readline)")
diff --git a/dev-lang/python/python-3.11.3.ebuild b/dev-lang/python/python-3.11.3.ebuild
index d23dff4..7617d3c 100644
--- a/dev-lang/python/python-3.11.3.ebuild
+++ b/dev-lang/python/python-3.11.3.ebuild
@@ -30,7 +30,7 @@ LICENSE="PSF-2"
SLOT="${PYVER}"
KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~loong ~m68k ~mips ppc ppc64 ~riscv ~s390 sparc x86"
IUSE="
- bluetooth build +ensurepip examples gdbm hardened libedit lto
+ bluetooth build debug +ensurepip examples gdbm hardened libedit lto
+ncurses pgo +readline +sqlite +ssl test tk valgrind
"
RESTRICT="!test? ( test )"
@@ -225,6 +225,7 @@ src_configure() {
--with-pkg-config=yes
--with-wheel-pkg-dir="${EPREFIX}"/usr/lib/python/ensurepip
+ $(use_with debug assertions)
$(use_with lto)
$(use_enable pgo optimizations)
$(use_with readline readline "$(usex libedit editline readline)")
diff --git a/dev-lang/python/python-3.9.16_p3-r1.ebuild b/dev-lang/python/python-3.9.16_p3-r1.ebuild
index 24afd52..e094996 100644
--- a/dev-lang/python/python-3.9.16_p3-r1.ebuild
+++ b/dev-lang/python/python-3.9.16_p3-r1.ebuild
@@ -30,7 +30,7 @@ LICENSE="PSF-2"
SLOT="${PYVER}"
KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~loong ~m68k ~mips ppc ppc64 ~riscv ~s390 sparc x86"
IUSE="
- bluetooth build +ensurepip examples gdbm hardened lto +ncurses pgo
+ bluetooth build debug +ensurepip examples gdbm hardened lto +ncurses pgo
+readline +sqlite +ssl test tk valgrind +xml
"
RESTRICT="!test? ( test )"
@@ -225,6 +225,7 @@ src_configure() {
--with-system-ffi
--with-wheel-pkg-dir="${EPREFIX}"/usr/lib/python/ensurepip
+ $(use_with debug assertions)
$(use_with lto)
$(use_enable pgo optimizations)
$(use_with valgrind)