aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorcnd <cynede@gentoo.org>2019-10-24 08:05:55 +0400
committerGitHub <noreply@github.com>2019-10-24 08:05:55 +0400
commit23c9e85a7f6a36090fee64e7b839ba4c27c97601 (patch)
tree7f150c6c29bee05b83c4f07527606abc07e5b788
parentMerge pull request #452 from sielicki/dev-lang/rust-std-bin (diff)
parentdev-lang/rust: allow llvm 8 or 9 for the live ebuild with system-llvm (diff)
downloadrust-23c9e85a7f6a36090fee64e7b839ba4c27c97601.tar.gz
rust-23c9e85a7f6a36090fee64e7b839ba4c27c97601.tar.bz2
rust-23c9e85a7f6a36090fee64e7b839ba4c27c97601.zip
Merge pull request #453 from stefson/rust-9999-fix-llvm
dev-lang/rust: allow llvm 8 or 9 for the live ebuild with system-llvm
-rw-r--r--dev-lang/rust/rust-9999.ebuild4
1 files changed, 4 insertions, 0 deletions
diff --git a/dev-lang/rust/rust-9999.ebuild b/dev-lang/rust/rust-9999.ebuild
index 15f831c..238b918 100644
--- a/dev-lang/rust/rust-9999.ebuild
+++ b/dev-lang/rust/rust-9999.ebuild
@@ -42,6 +42,10 @@ IUSE="clippy cpu_flags_x86_sse2 debug doc libressl rls rustfmt system-llvm wasm
# 3. Specify LLVM_MAX_SLOT, e.g. 8.
LLVM_DEPEND="
|| (
+ sys-devel/llvm:9[llvm_targets_WebAssembly?]
+ wasm? ( >=sys-devel/lld-9 )
+ )
+ (
sys-devel/llvm:8[llvm_targets_WebAssembly?]
wasm? ( >=sys-devel/lld-8 )
)