aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-lang/rust/Manifest5
-rw-r--r--dev-lang/rust/rust-1.46.0-r666.ebuild289
-rw-r--r--virtual/rust/metadata.xml8
-rw-r--r--virtual/rust/rust-1.46.0-r666.ebuild17
4 files changed, 0 insertions, 319 deletions
diff --git a/dev-lang/rust/Manifest b/dev-lang/rust/Manifest
deleted file mode 100644
index a4547f6..0000000
--- a/dev-lang/rust/Manifest
+++ /dev/null
@@ -1,5 +0,0 @@
-DIST rust-1.45.1-aarch64-unknown-linux-gnu.tar.xz 110598096 SHA256 fae1dffd2f75d6a3bdca872b1080ac3f651f698e41b1ae8b389db82dc913465e SHA512 fd64aaa3d8137d62c838f0ef554ff159c84263a4734556c0e4ef911d3f87921f846d70d76983fe8ebe9679477915255ceea69c8a9769797893827d5d67e97b0b WHIRLPOOL 828d3a02311a3d9d9ff3c14e0ec9d0985a435aac22d0135ec4df1516d621c89574cb154b86c51ac3c503ca028a0e6c9a5eb849da531eaaaa25a2bd8fdf4301d2
-DIST rust-1.45.1-armv7-unknown-linux-gnueabihf.tar.xz 116371752 SHA256 25b5f5addb8869210af9bc90d00af94a06865b86c0945fbd7b4fb65922768608 SHA512 6dec92d112c0bbbe0434162d10df630505ba179b99fb51800140204fb2e52215d387162d97dadd3aff2324c81a4bbc944e45f4d39e55bf85e244d741e556a391 WHIRLPOOL 8f656830487ba44588681f084ce4532e92caa15e306b349aaab1ea59ac3cf3739f14b8e6a25a3e88cc76ecd6f885a68e319eca82d5a8ac6bccb7d2ca794f8685
-DIST rust-1.45.1-i686-unknown-linux-gnu.tar.xz 131991636 SHA256 24b11f969b261948e9a22eb653776c50650b351743ff51576a7b6728160941dd SHA512 80f3bb328666766e177587c11cac4fb0db515ea16fc0462a29816a8474669f49c69461d2939919833337f3a95fbd1da09a55307f3f1936220bc2065f760a2345 WHIRLPOOL 6d561f59f589e027337336edec4e685d2b3846b09fe24015f5163f68223425b229e856cd70ba2ef55cc3aa52589239bf23375fe387d91e9fab4b61f93b2fdfcd
-DIST rust-1.45.1-x86_64-unknown-linux-gnu.tar.xz 117764080 SHA256 6e5c709919dbb429681e969ddc39d7cb473b365f49f73e4ebcff8f01833231ac SHA512 13ee5ff7cae29440e32fb140404ff01414d66f0ea8d79777fb1586541de1ee6ef8e12f9249c35374501460a2352f7d0f6035b5bdc2f0daa91d772a157657ec0b WHIRLPOOL 77a5d12f6babd79f0a796a78506e44adc43df9744f6575df510ea9a12652d6686fd6626cc17e922ce8821e851c38b55fd9ad456fde4fd72d880829571ebd6aa6
-DIST rustc-1.46.0-src.tar.xz 101868452 SHA256 865dae1290a205f16ded8818c6a0254cc32862985fc250a602a70285b7d92b82 SHA512 099857f1d295043587a4e2a65ef3e6a90e12c8b6958e98535a1656c113c553f9a9b621aba8a19cf21bd8d2c79d27cbfa4b8e6fabbcb3cbfee23b545be7b450b4 WHIRLPOOL 4b744e718beaa47ae6b0a7ed4ee60ff8715a1ae4f4944a4e02e09a9afb75b7a6c7e92bdb663a9f1b6c3c291db069e1ad81b6e4ed82af5bbf136061d33878269c
diff --git a/dev-lang/rust/rust-1.46.0-r666.ebuild b/dev-lang/rust/rust-1.46.0-r666.ebuild
deleted file mode 100644
index 092d1fa..0000000
--- a/dev-lang/rust/rust-1.46.0-r666.ebuild
+++ /dev/null
@@ -1,289 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-PYTHON_COMPAT=( python2_7 python3_{5,6,7,8} pypy )
-
-inherit multiprocessing multilib-build python-any-r1 toolchain-funcs versionator
-
-ABI_VER="$(get_version_component_range 1-2)"
-SLOT="dev/${ABI_VER}"
-MY_P="rustc-${PV}"
-SRC="${MY_P}-src.tar.xz"
-KEYWORDS="~amd64 ~arm64 ~x86"
-
-CHOST_amd64=x86_64-unknown-linux-gnu
-CHOST_x86=i686-unknown-linux-gnu
-CHOST_arm64=aarch64-unknown-linux-gnu
-CHOST_arm=armv7-unknown-linux-gnueabihf
-
-RUST_STAGE0_VERSION="1.$(($(get_version_component_range 2) - 1)).1"
-RUST_STAGE0_amd64="rust-${RUST_STAGE0_VERSION}-${CHOST_amd64}"
-RUST_STAGE0_x86="rust-${RUST_STAGE0_VERSION}-${CHOST_x86}"
-RUST_STAGE0_arm64="rust-${RUST_STAGE0_VERSION}-${CHOST_arm64}"
-RUST_STAGE0_armv7="rust-${RUST_STAGE0_VERSION}-${CHOST_arm}"
-
-CARGO_DEPEND_VERSION="0.$(($(get_version_component_range 2))).1"
-
-DESCRIPTION="Systems programming language from Mozilla"
-HOMEPAGE="https://www.rust-lang.org/"
-
-SRC_URI="https://static.rust-lang.org/dist/${SRC} -> rustc-${PV}-src.tar.xz
- amd64? ( https://static.rust-lang.org/dist/${RUST_STAGE0_amd64}.tar.xz )
- x86? ( https://static.rust-lang.org/dist/${RUST_STAGE0_x86}.tar.xz )
- arm64? ( https://static.rust-lang.org/dist/${RUST_STAGE0_arm64}.tar.xz )
- arm? ( https://static.rust-lang.org/dist/${RUST_STAGE0_armv7}.tar.xz )
-"
-
-ALL_LLVM_TARGETS=( AArch64 AMDGPU ARM BPF Hexagon Lanai Mips MSP430
- NVPTX PowerPC Sparc SystemZ X86 XCore )
-ALL_LLVM_TARGETS=( "${ALL_LLVM_TARGETS[@]/#/llvm_targets_}" )
-LLVM_TARGET_USEDEPS=${ALL_LLVM_TARGETS[@]/%/?}
-
-LICENSE="|| ( MIT Apache-2.0 ) BSD-1 BSD-2 BSD-4 UoI-NCSA"
-
-IUSE="clippy debug doc libressl rls rustfmt thumbv7neon wasm ${ALL_LLVM_TARGETS[*]}"
-
-RDEPEND=">=app-eselect/eselect-rust-20190311
- sys-libs/zlib
- !libressl? ( dev-libs/openssl:0= )
- libressl? ( dev-libs/libressl:0= )
- net-libs/libssh2
- net-libs/http-parser
- net-misc/curl[ssl]
- "
-DEPEND="${RDEPEND}
- ${PYTHON_DEPS}
- || (
- >=sys-devel/gcc-4.7
- >=sys-devel/clang-3.5
- )
- !dev-util/cargo
- rustfmt? ( !dev-util/rustfmt )
- dev-util/cmake
-"
-PDEPEND=""
-
-REQUIRED_USE="|| ( ${ALL_LLVM_TARGETS[*]} )"
-
-S="${WORKDIR}/${MY_P}-src"
-
-toml_usex() {
- usex "$1" true false
-}
-
-src_prepare() {
- local rust_stage0_root="${WORKDIR}"/rust-stage0
-
- local rust_stage0_name="RUST_STAGE0_${ARCH}"
- local rust_stage0="${!rust_stage0_name}"
-
- "${WORKDIR}/${rust_stage0}"/install.sh --disable-ldconfig --destdir="${rust_stage0_root}" --prefix=/ || die
-
- default
-}
-
-src_configure() {
- local rust_target="" rust_targets="" rust_target_name arch_cflags
-
- # Collect rust target names to compile standard libs for all ABIs.
- for v in $(multilib_get_enabled_abi_pairs); do
- rust_target_name="CHOST_${v##*.}"
- rust_targets="${rust_targets},\"${!rust_target_name}\""
- done
- if use wasm; then
- rust_targets="${rust_targets},\"wasm32-unknown-unknown\""
- fi
- if use arm && use thumbv7neon; then
- rust_targets="${rust_targets},\"thumbv7neon-unknown-linux-gnueabihf\""
- fi
-
- rust_targets="${rust_targets#,}"
-
- local extended="true" tools="\"cargo\","
- if use clippy; then
- tools="\"clippy\",$tools"
- fi
- if use rls; then
- tools="\"rls\",\"analysis\",\"src\",$tools"
- fi
- if use rustfmt; then
- tools="\"rustfmt\",$tools"
- fi
-
- local rust_stage0_root="${WORKDIR}"/rust-stage0
-
- rust_target_name="CHOST_${ARCH}"
- rust_target="${!rust_target_name}"
-
- cat <<- EOF > "${S}"/config.toml
- [llvm]
- optimize = $(toml_usex !debug)
- release-debuginfo = $(toml_usex debug)
- assertions = $(toml_usex debug)
- targets = "${LLVM_TARGETS// /;}"
- experimental-targets = ""
- [build]
- build = "${rust_target}"
- host = ["${rust_target}"]
- target = [${rust_targets}]
- cargo = "${rust_stage0_root}/bin/cargo"
- rustc = "${rust_stage0_root}/bin/rustc"
- docs = $(toml_usex doc)
- submodules = false
- python = "${EPYTHON}"
- locked-deps = true
- vendor = true
- extended = ${extended}
- tools = [${tools}]
- verbose = 2
- [install]
- prefix = "${EPREFIX}/usr"
- libdir = "$(get_libdir)"
- docdir = "share/doc/${P}"
- mandir = "share/${P}/man"
- [rust]
- optimize = $(toml_usex !debug)
- debug = $(toml_usex debug)
- debug-assertions = $(toml_usex debug)
- default-linker = "$(tc-getCC)"
- rpath = false
- lld = $(toml_usex wasm)
- EOF
-
- for v in $(multilib_get_enabled_abi_pairs); do
- rust_target=$(get_abi_CHOST ${v##*.})
- arch_cflags="$(get_abi_CFLAGS ${v##*.})"
-
- cat <<- EOF >> "${S}"/config.env
- CFLAGS_${rust_target}=${arch_cflags}
- EOF
-
- cat <<- EOF >> "${S}"/config.toml
- [target.${rust_target}]
- cc = "$(tc-getBUILD_CC)"
- cxx = "$(tc-getBUILD_CXX)"
- linker = "$(tc-getCC)"
- ar = "$(tc-getAR)"
- EOF
- done
-
- if use wasm; then
- cat <<- EOF >> "${S}"/config.toml
- [target.wasm32-unknown-unknown]
- linker = "lld"
- EOF
- fi
-
- if use arm && use thumbv7neon; then
- cat <<- EOF >> "${S}"/config.toml
- [target.thumbv7neon-unknown-linux-gnueabihf]
- cc = "$(tc-getBUILD_CC)"
- cxx = "$(tc-getBUILD_CXX)"
- linker = "$(tc-getCC)"
- ar = "$(tc-getAR)"
- EOF
- fi
-}
-
-src_compile() {
- env $(cat "${S}"/config.env)\
- ./x.py build --config="${S}"/config.toml -j$(makeopts_jobs) \
- --exclude src/tools/miri || die # https://github.com/rust-lang/rust/issues/52305
-}
-
-src_install() {
- local rust_target abi_libdir
-
- env DESTDIR="${D}" ./x.py install || die
-
- mv "${D}/usr/bin/rustc" "${D}/usr/bin/rustc-${PV}" || die
- mv "${D}/usr/bin/rustdoc" "${D}/usr/bin/rustdoc-${PV}" || die
- mv "${D}/usr/bin/rust-gdb" "${D}/usr/bin/rust-gdb-${PV}" || die
- mv "${D}/usr/bin/rust-lldb" "${D}/usr/bin/rust-lldb-${PV}" || die
- mv "${D}/usr/bin/cargo" "${D}/usr/bin/cargo-${PV}" || die
- if use clippy; then
- mv "${D}/usr/bin/clippy-driver" "${D}/usr/bin/clippy-driver-${PV}" || die
- mv "${D}/usr/bin/cargo-clippy" "${D}/usr/bin/cargo-clippy-${PV}" || die
- fi
- if use rls; then
- mv "${D}/usr/bin/rls" "${D}/usr/bin/rls-${PV}" || die
- fi
- if use rustfmt; then
- mv "${D}/usr/bin/rustfmt" "${D}/usr/bin/rustfmt-${PV}" || die
- mv "${D}/usr/bin/cargo-fmt" "${D}/usr/bin/cargo-fmt-${PV}" || die
- fi
-
- # Copy shared library versions of standard libraries for all targets
- # into the system's abi-dependent lib directories because the rust
- # installer only does so for the native ABI.
- for v in $(multilib_get_enabled_abi_pairs); do
- if [ ${v##*.} = ${DEFAULT_ABI} ]; then
- continue
- fi
- abi_libdir=$(get_abi_LIBDIR ${v##*.})
- rust_target=$(get_abi_CHOST ${v##*.})
- mkdir -p "${D}/usr/${abi_libdir}"
- cp "${D}/usr/$(get_libdir)/rustlib/${rust_target}/lib"/*.so \
- "${D}/usr/${abi_libdir}" || die
- done
-
- dodoc COPYRIGHT
-
- # FIXME:
- # Really not sure if that env is needed, specailly LDPATH
- cat <<-EOF > "${T}"/50${P}
- LDPATH="/usr/$(get_libdir)/${P}"
- MANPATH="/usr/share/${P}/man"
- EOF
- doenvd "${T}"/50${P}
-
- cat <<-EOF > "${T}/provider-${P}"
- /usr/bin/rustdoc
- /usr/bin/rust-gdb
- /usr/bin/rust-lldb
- EOF
- echo /usr/bin/cargo >> "${T}/provider-${P}"
- if use clippy; then
- echo /usr/bin/clippy-driver >> "${T}/provider-${P}"
- echo /usr/bin/cargo-clippy >> "${T}/provider-${P}"
- fi
- if use rls; then
- echo /usr/bin/rls >> "${T}/provider-${P}"
- fi
- if use rustfmt; then
- echo /usr/bin/rustfmt >> "${T}/provider-${P}"
- echo /usr/bin/cargo-fmt >> "${T}/provider-${P}"
- fi
- dodir /etc/env.d/rust
- insinto /etc/env.d/rust
- doins "${T}/provider-${P}"
-}
-
-pkg_postinst() {
- eselect rust update --if-unset
-
- elog "Rust installs a helper script for calling GDB and LLDB,"
- elog "for your convenience it is installed under /usr/bin/rust-{gdb,lldb}-${PV}."
-
- ewarn "cargo is now installed from dev-lang/rust{,-bin} instead of dev-util/cargo."
- ewarn "This might have resulted in a dangling symlink for /usr/bin/cargo on some"
- ewarn "systems. This can be resolved by calling 'sudo eselect rust set ${P}'."
-
- if has_version app-editors/emacs || has_version app-editors/emacs-vcs; then
- elog "install app-emacs/rust-mode to get emacs support for rust."
- fi
-
- if has_version app-editors/gvim || has_version app-editors/vim; then
- elog "install app-vim/rust-vim to get vim support for rust."
- fi
-
- if has_version 'app-shells/zsh'; then
- elog "install app-shells/rust-zshcomp to get zsh completion for rust."
- fi
-}
-
-pkg_postrm() {
- eselect rust unset --if-invalid
-}
diff --git a/virtual/rust/metadata.xml b/virtual/rust/metadata.xml
deleted file mode 100644
index 85cf4eb..0000000
--- a/virtual/rust/metadata.xml
+++ /dev/null
@@ -1,8 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
-<pkgmetadata>
- <maintainer type="project">
- <email>rust@gentoo.org</email>
- <name>Rust Project</name>
- </maintainer>
-</pkgmetadata>
diff --git a/virtual/rust/rust-1.46.0-r666.ebuild b/virtual/rust/rust-1.46.0-r666.ebuild
deleted file mode 100644
index 63b7dbb..0000000
--- a/virtual/rust/rust-1.46.0-r666.ebuild
+++ /dev/null
@@ -1,17 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-inherit multilib-build
-
-DESCRIPTION="Virtual for Rust language compiler"
-HOMEPAGE=""
-SRC_URI=""
-
-LICENSE=""
-SLOT="0"
-KEYWORDS="~amd64 ~arm64 ~x86"
-
-BDEPEND=""
-RDEPEND="|| ( =dev-lang/rust-${PVR}*[${MULTILIB_USEDEP}] =dev-lang/rust-bin-${PV}*[${MULTILIB_USEDEP}] )"