summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorOliver Freyermuth <o.freyermuth@googlemail.com>2020-04-19 17:42:35 +0200
committerGuilherme Amadio <amadio@gentoo.org>2020-05-20 14:37:26 +0200
commit5d089e2315b4f8020ca0698ffdeb97dd4f404704 (patch)
treee15f6a63504a0f94be7d787c9ea07b3ebb8cefc4
parentsci-physics/vgm: Adapt SRC_URI and drop *-linux keywords (diff)
downloadgentoo-5d089e2315b4f8020ca0698ffdeb97dd4f404704.tar.gz
gentoo-5d089e2315b4f8020ca0698ffdeb97dd4f404704.tar.bz2
gentoo-5d089e2315b4f8020ca0698ffdeb97dd4f404704.zip
sci-physics/vgm: Bump to version 4.8
This adds c++11,c++14,c++17 flags and requires >=sci-physics/root-6.14 which also implements these switches. Package-Manager: Portage-2.3.99, Repoman-2.3.22 Signed-off-by: Oliver Freyermuth <o.freyermuth@googlemail.com> Signed-off-by: Guilherme Amadio <amadio@gentoo.org>
-rw-r--r--sci-physics/vgm/Manifest1
-rw-r--r--sci-physics/vgm/metadata.xml3
-rw-r--r--sci-physics/vgm/vgm-4.5.ebuild2
-rw-r--r--sci-physics/vgm/vgm-4.8.ebuild82
-rw-r--r--sci-physics/vgm/vgm-9999.ebuild10
5 files changed, 93 insertions, 5 deletions
diff --git a/sci-physics/vgm/Manifest b/sci-physics/vgm/Manifest
index 4f6a20815ad1..6e9c7ee47e1e 100644
--- a/sci-physics/vgm/Manifest
+++ b/sci-physics/vgm/Manifest
@@ -1 +1,2 @@
DIST vgm-4.5.tar.gz 3474063 BLAKE2B 70c4fe0bd5eb9bc94607553ad30ffb625e66ef4e6f8a965b1289c1c7ad6f71d7eba035d2825ba8cd94705a0c223aa56408d3285748b068045eee3a29f556e3b2 SHA512 541fde12e12cc51ba065900788dbceb8e5b9a4e4615a4e4e0bbd2ba199b8a203b6927dbe23ead7bc183bd61f6b641e3e954fe7b78451c2d423d3a2b737f00572
+DIST vgm-4.8.tar.gz 3661965 BLAKE2B 29f878fb6716e261c27d60b2c9081d66313591a053d80f78501973f131aff88bbcee743ff9767836883dcb28d3ce5aeee3759a5890d7c8811a6a61503417284f SHA512 8b7cabc5796649c4014ccbdf1c6d209d2e7c2b4b06258716a72cadd997a9f6f51c4f9cb5870fd10abfd1ee133766876523c84441a69c7242bc2002687ca0ce58
diff --git a/sci-physics/vgm/metadata.xml b/sci-physics/vgm/metadata.xml
index cd1e3ea3587f..444b00550969 100644
--- a/sci-physics/vgm/metadata.xml
+++ b/sci-physics/vgm/metadata.xml
@@ -15,6 +15,9 @@
abstraction layer between the Geant4 and ROOT software.
</longdescription>
<use>
+ <flag name="c++11">Build using the C++11 standard</flag>
+ <flag name="c++14">Build using the C++14 standard</flag>
+ <flag name="c++17">Build using the C++17 standard</flag>
<flag name="geant4">Enable interaction with Geant4(<pkg>sci-physics/geant</pkg>:4)</flag>
<flag name="root">Enable interaction with ROOT (<pkg>sci-physics/root</pkg>)</flag>
</use>
diff --git a/sci-physics/vgm/vgm-4.5.ebuild b/sci-physics/vgm/vgm-4.5.ebuild
index df15b5bdb7d1..6d8a518fd73f 100644
--- a/sci-physics/vgm/vgm-4.5.ebuild
+++ b/sci-physics/vgm/vgm-4.5.ebuild
@@ -25,7 +25,7 @@ IUSE="doc examples +geant4 +root test"
# sci-physics/root[c++11] required to match sci-physics/geant
RDEPEND="
sci-physics/clhep:=
- root? ( sci-physics/root:=[c++11] )
+ root? ( >=sci-physics/root-6.14:=[c++11] )
geant4? ( >=sci-physics/geant-4.10.03 )"
DEPEND="${RDEPEND}
doc? ( app-doc/doxygen[dot] )
diff --git a/sci-physics/vgm/vgm-4.8.ebuild b/sci-physics/vgm/vgm-4.8.ebuild
new file mode 100644
index 000000000000..5fba573e3f61
--- /dev/null
+++ b/sci-physics/vgm/vgm-4.8.ebuild
@@ -0,0 +1,82 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit cmake
+
+if [[ ${PV} == *9999* ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/vmc-project/${PN}.git"
+ KEYWORDS=""
+else
+ MY_PV=$(ver_rs 1- -)
+ SRC_URI="https://github.com/vmc-project/${PN}/archive/v${MY_PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+ S="${WORKDIR}/${PN}-${MY_PV}"
+fi
+
+DESCRIPTION="Virtual Geometry Model for High Energy Physics Experiments"
+HOMEPAGE="http://ivana.home.cern.ch/ivana/VGM.html"
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE="+c++11 c++14 c++17 doc examples +geant4 +root test"
+
+REQUIRED_USE="^^ ( c++11 c++14 c++17 )"
+
+RDEPEND="
+ sci-physics/clhep:=
+ geant4? ( >=sci-physics/geant-4.10.6[c++11?,c++14?,c++17?] )
+ root? ( >=sci-physics/root-6.14:=[c++11?,c++14?,c++17?] )"
+DEPEND="${RDEPEND}
+ doc? ( app-doc/doxygen[dot] )
+ test? ( sci-physics/geant-vmc[g4root] )"
+RESTRICT="
+ !geant4? ( test )
+ !root? ( test )
+ !test? ( test )"
+
+DOCS=(
+ doc/README
+ doc/todo.txt
+ doc/VGMhistory.txt
+ doc/VGM.html
+ doc/VGMversions.html
+)
+
+src_configure() {
+ local mycmakeargs=(
+ -DCLHEP_DIR="${EPREFIX}/usr"
+ -DWITH_EXAMPLES="$(usex examples)"
+ -DINSTALL_EXAMPLES="$(usex examples)"
+ -DWITH_GEANT4="$(usex geant4)"
+ -DWITH_ROOT="$(usex root)"
+ -DWITH_TEST="$(usex test)"
+ )
+ if use test && use root && use geant4; then
+ mycmakeargs+=( -DWITH_G4ROOT=yes )
+ else
+ mycmakeargs+=( -DWITH_G4ROOT=no )
+ fi
+ cmake_src_configure
+}
+
+src_compile() {
+ cmake_src_compile
+ if use doc; then
+ cd packages
+ doxygen || die
+ fi
+}
+
+src_test() {
+ cd "${BUILD_DIR}"/test || die
+ ./test_suite.sh || die
+}
+
+src_install() {
+ cmake_src_install
+ use doc && local HTML_DOCS=( doc/html/. )
+ einstalldocs
+}
diff --git a/sci-physics/vgm/vgm-9999.ebuild b/sci-physics/vgm/vgm-9999.ebuild
index a6a93af9078e..5fba573e3f61 100644
--- a/sci-physics/vgm/vgm-9999.ebuild
+++ b/sci-physics/vgm/vgm-9999.ebuild
@@ -8,6 +8,7 @@ inherit cmake
if [[ ${PV} == *9999* ]]; then
inherit git-r3
EGIT_REPO_URI="https://github.com/vmc-project/${PN}.git"
+ KEYWORDS=""
else
MY_PV=$(ver_rs 1- -)
SRC_URI="https://github.com/vmc-project/${PN}/archive/v${MY_PV}.tar.gz -> ${P}.tar.gz"
@@ -20,13 +21,14 @@ HOMEPAGE="http://ivana.home.cern.ch/ivana/VGM.html"
LICENSE="GPL-2"
SLOT="0"
-IUSE="doc examples +geant4 +root test"
+IUSE="+c++11 c++14 c++17 doc examples +geant4 +root test"
+
+REQUIRED_USE="^^ ( c++11 c++14 c++17 )"
-# sci-physics/root[c++11] required to match sci-physics/geant
RDEPEND="
sci-physics/clhep:=
- root? ( sci-physics/root:=[c++11] )
- geant4? ( >=sci-physics/geant-4.10.03 )"
+ geant4? ( >=sci-physics/geant-4.10.6[c++11?,c++14?,c++17?] )
+ root? ( >=sci-physics/root-6.14:=[c++11?,c++14?,c++17?] )"
DEPEND="${RDEPEND}
doc? ( app-doc/doxygen[dot] )
test? ( sci-physics/geant-vmc[g4root] )"