summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2016-05-27 07:59:21 +0200
committerHans de Graaff <graaff@gentoo.org>2016-05-27 07:59:21 +0200
commit94d4410203db282ca1b4aa0d527927729aec761f (patch)
tree324dace7011343acedd01f14b608478a1dfb06dd
parentdev-ruby/aws-sdk: add 2.2.37 (diff)
downloadgentoo-94d4410203db282ca1b4aa0d527927729aec761f.tar.gz
gentoo-94d4410203db282ca1b4aa0d527927729aec761f.tar.bz2
gentoo-94d4410203db282ca1b4aa0d527927729aec761f.zip
dev-ruby/celluloid-io: add 0.17.3
Package-Manager: portage-2.2.28
-rw-r--r--dev-ruby/celluloid-io/Manifest1
-rw-r--r--dev-ruby/celluloid-io/celluloid-io-0.17.3.ebuild41
2 files changed, 42 insertions, 0 deletions
diff --git a/dev-ruby/celluloid-io/Manifest b/dev-ruby/celluloid-io/Manifest
index bffd275c0ae1..663978f7dc23 100644
--- a/dev-ruby/celluloid-io/Manifest
+++ b/dev-ruby/celluloid-io/Manifest
@@ -1 +1,2 @@
DIST celluloid-io-0.16.2.gem 53248 SHA256 dde6646f220d5de23defca047d6f9963456e156d5dedccfdd4bb28d5cc053dd0 SHA512 6e37fbf99cc57aab13f63da68318fcab5d70b0c48da154da22a5fc12ac9a17d015d5784af9c02679d0f5c72fed6a693ec459cb455f10aa75b83e5e0dce913f71 WHIRLPOOL 6d4247f12cd5d69275c7d6c340a483264b3fec0e38351968c08b864de1fa70524473e797da8a618a7b5c4f60d2a6e227aecd74ac2a04ff0f23d64ab203edd570
+DIST celluloid-io-0.17.3.gem 57856 SHA256 248c9a3f91612eaea6b1625f4742e92e93d24129ce1d7eb8ee6c277894bc2cbb SHA512 8b1552549c5aad59bf3789518ea2fa6833a4d3b7213cf70d941face215382a68b3d9d2d57e76b2bd7c478fe0e2690b19984d210b806bf1f67f159fd2bdf6b8ac WHIRLPOOL f76bee638035b5126648b96673af784b8b78e1d0381fd82bda074f2f6d901cce212ec0ea5aacb10899c5cdcf8a298cb3af2cc3bcfa7d06ecd844cbd7a0b63a7a
diff --git a/dev-ruby/celluloid-io/celluloid-io-0.17.3.ebuild b/dev-ruby/celluloid-io/celluloid-io-0.17.3.ebuild
new file mode 100644
index 000000000000..38e1784e2419
--- /dev/null
+++ b/dev-ruby/celluloid-io/celluloid-io-0.17.3.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+USE_RUBY="ruby20 ruby21"
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec3"
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_EXTRADOC="CHANGES.md README.md"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Evented IO for Celluloid actors"
+HOMEPAGE="https://github.com/celluloid/celluloid-io"
+IUSE=""
+SLOT="0"
+
+LICENSE="MIT"
+KEYWORDS="~amd64 ~arm ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+
+ruby_add_rdepend ">=dev-ruby/celluloid-0.17.3
+ >=dev-ruby/nio4r-1.2.1
+ >=dev-ruby/timers-4.1.1"
+
+ruby_add_bdepend " test? (
+ dev-ruby/dotenv
+ dev-ruby/nenv
+ )"
+
+all_ruby_prepare() {
+ sed -i -e '/[Bb]undler/ s:^:#:' -e '/[Cc]overalls/ s:^:#:' \
+ -e '2irequire "pathname"; require "fileutils"' spec/spec_helper.rb || die
+
+ # Avoid DNS tests. They either assume localhost is 127.0.0.1 or
+ # require network access.
+ rm spec/celluloid/io/dns_resolver_spec.rb || die
+
+ # Make sure test logs end up in the right place
+ sed -i -e 's:log/test.log:'${T}'/test.log:' .env-dev || die
+}