summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrice Clement <monsieurp@gentoo.org>2017-08-20 22:13:50 +0200
committerPatrice Clement <monsieurp@gentoo.org>2017-08-20 22:14:49 +0200
commit95d245ea21f53ec72207a5e73f307c1460f0cea0 (patch)
tree710bb7dbbb3cf13f0bd6e9cd480c4f25d652d937
parentnet-firewall/shorewall: Maintainer stabilization under ALLARCHES policy (diff)
downloadgentoo-95d245ea21f53ec72207a5e73f307c1460f0cea0.tar.gz
gentoo-95d245ea21f53ec72207a5e73f307c1460f0cea0.tar.bz2
gentoo-95d245ea21f53ec72207a5e73f307c1460f0cea0.zip
app-vim/vimpython: port to python-single-r1.
Gentoo-Bug: https://bugs.gentoo.org/615910 Package-Manager: Portage-2.3.6, Repoman-2.3.1
-rw-r--r--app-vim/vimpython/vimpython-1.13-r2.ebuild18
1 files changed, 18 insertions, 0 deletions
diff --git a/app-vim/vimpython/vimpython-1.13-r2.ebuild b/app-vim/vimpython/vimpython-1.13-r2.ebuild
new file mode 100644
index 000000000000..3f5071ff2c8b
--- /dev/null
+++ b/app-vim/vimpython/vimpython-1.13-r2.ebuild
@@ -0,0 +1,18 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} )
+
+inherit vim-plugin python-single-r1
+
+DESCRIPTION="vim plugin: A set of menus/shortcuts to work with Python files"
+HOMEPAGE="http://www.vim.org/scripts/script.php?script_id=30"
+LICENSE="vim"
+KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~sparc ~x86"
+
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+DEPEND="app-arch/unzip"
+RDEPEND="${PYTHON_DEPS}"