summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2023-02-24 11:29:40 +0000
committerSam James <sam@gentoo.org>2023-02-24 12:03:14 +0000
commitb5cdcee031d40668c0331fae2518aaa82c8e5e1e (patch)
tree4166a2fe7998e9c4193bfb824a6f7f1131808bc8
parentapp-portage/gs-elpa: Fix warning from distutils-r1 (diff)
downloadgentoo-b5cdcee031d40668c0331fae2518aaa82c8e5e1e.tar.gz
gentoo-b5cdcee031d40668c0331fae2518aaa82c8e5e1e.tar.bz2
gentoo-b5cdcee031d40668c0331fae2518aaa82c8e5e1e.zip
app-text/libpaper: add 2.0.10
Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r--app-text/libpaper/Manifest1
-rw-r--r--app-text/libpaper/libpaper-2.0.10.ebuild24
2 files changed, 25 insertions, 0 deletions
diff --git a/app-text/libpaper/Manifest b/app-text/libpaper/Manifest
index ff58d90d2d9f..0a97eec02845 100644
--- a/app-text/libpaper/Manifest
+++ b/app-text/libpaper/Manifest
@@ -1,3 +1,4 @@
+DIST libpaper-2.0.10.tar.gz 1304460 BLAKE2B 89c0ab7348cff01e278a64fe984f51102146c38699d1036ae265343cc7174a2954974770384e625582669217f57992ed28dd1755867e2f7d00b7e423323f500c SHA512 629d357b4946aca324ca95024dbfd5d49a9e7110b6163eac72482c010c4cb84b50a50b5b119399090a49eaef58329bf3c497d3d871b7c9e46ae5c8e71364c2ce
DIST libpaper-2.0.4.tar.gz 1286975 BLAKE2B 2751422ca3176d1f47d98c74d948d986e6dcff15acbac126535f526312900650e25fa0a4d68ceebc5d718f5135be22a9f9407d690dc5d5e22eab9dc55b040fc8 SHA512 d603a807c8fdc57b704cdfdc90bedf05c54c8a7b67e8cf52f26298c22a6cee5291fcadc6e67d28b00cf9d68f4890a394e56c8e91f0b97c8edfac4662fe4dc8f0
DIST libpaper-2.0.8.tar.gz 1304248 BLAKE2B d42b239b5e6d79fccc42508ab55e3d0a7b7f688c288aae7a75286332cd13d563e6164289195e7b67ef1216d5b4d4127a75dffe4bbe97080e093f89b64f48a57b SHA512 06318779cee2d1cf9bea090a5956f90bf8cccc0d753eb7c931615c0dcb321e012ea870a20613b84e7f4350ab608237a2d21d5170c119d8908c86a94e0cba1d1f
DIST libpaper-2.0.9.tar.gz 1290212 BLAKE2B a1b54af2463c97d90b902fc31ae92347e47ff25d589712ab1f86cc46ccda0751b69733c37ab95bf4abbdad11639b133d812cf46760a04a5aff0ba8749e9a6bf6 SHA512 79d2f6d2b0c88f6edbfb1bbd9be43461cffaa05bfda67bc31b3b29c8f4988125cb7dbd2e982ac5b3b19315b6fea5757efc5c6f45a26b2e34d1569b050673788a
diff --git a/app-text/libpaper/libpaper-2.0.10.ebuild b/app-text/libpaper/libpaper-2.0.10.ebuild
new file mode 100644
index 000000000000..d77438c2f590
--- /dev/null
+++ b/app-text/libpaper/libpaper-2.0.10.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="Library for handling paper characteristics"
+HOMEPAGE="https://github.com/rrthomas/libpaper"
+SRC_URI="https://github.com/rrthomas/libpaper/releases/download/v${PV}/${P}.tar.gz"
+
+# See README.
+# paperspecs is public-domain
+LICENSE="LGPL-2.1+ GPL-3+ public-domain"
+SLOT="0/$(ver_cut 1)"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-cygwin ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+
+src_configure() {
+ econf --enable-relocatable
+}
+
+src_install() {
+ default
+
+ find "${ED}" -type f -name '*.la' -delete || die
+}