summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2018-04-22 21:38:21 +0200
committerPacho Ramos <pacho@gentoo.org>2018-04-22 21:40:10 +0200
commitbfb878d44181f9bf70126274019303da1dd702a7 (patch)
tree677cc5e0fd6ab3b7b84262a6642cc8d12c17233d /games-arcade/nottetris2
parentRevert "games-arcade/notpacman: Simplify ebuild" (diff)
downloadgentoo-bfb878d44181f9bf70126274019303da1dd702a7.tar.gz
gentoo-bfb878d44181f9bf70126274019303da1dd702a7.tar.bz2
gentoo-bfb878d44181f9bf70126274019303da1dd702a7.zip
games-arcade/nottetris2: Stop using games.eclass
Package-Manager: Portage-2.3.31, Repoman-2.3.9
Diffstat (limited to 'games-arcade/nottetris2')
-rw-r--r--games-arcade/nottetris2/nottetris2-1-r1.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/games-arcade/nottetris2/nottetris2-1-r1.ebuild b/games-arcade/nottetris2/nottetris2-1-r1.ebuild
new file mode 100644
index 000000000000..47c906bb7ce3
--- /dev/null
+++ b/games-arcade/nottetris2/nottetris2-1-r1.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit eutils
+
+DESCRIPTION="The spiritual successor of the classic Tetris mixed with physics"
+HOMEPAGE="http://stabyourself.net/nottetris2/"
+SRC_URI="http://stabyourself.net/dl.php?file=nottetris2/nottetris2-linux.zip -> ${P}.zip"
+
+LICENSE="CC-BY-NC-SA-3.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+LVSLOT="0.7"
+RDEPEND=">=games-engines/love-0.7.2:${LVSLOT}
+ media-libs/devil[png]
+"
+DEPEND="app-arch/unzip"
+
+S="${WORKDIR}"
+
+src_install() {
+ local dir=/usr/share/love/${PN}
+
+ exeinto "${dir}"
+ newexe "Not Tetris 2.love" ${PN}.love
+
+ newdoc "Not Readme.txt" README
+
+ make_wrapper ${PN} "love-${LVSLOT} ${PN}.love" "${dir}"
+ make_desktop_entry ${PN}
+}