summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--app-crypt/pesign/Manifest1
-rw-r--r--app-crypt/pesign/files/destdir.patch10
-rw-r--r--app-crypt/pesign/pesign-0.108.ebuild55
3 files changed, 0 insertions, 66 deletions
diff --git a/app-crypt/pesign/Manifest b/app-crypt/pesign/Manifest
index 1af642830c50..51dcd1c94d69 100644
--- a/app-crypt/pesign/Manifest
+++ b/app-crypt/pesign/Manifest
@@ -1,2 +1 @@
-DIST pesign-0.108.tar.gz 96838 BLAKE2B ae17d48af15f031ef982d915c61c9c0b647c3a01beb106e9f0dbdcc9c47f2a56b211fd2c23dc0e1131c52b4a12034227bfeeddb0ecb9531201b7762374d8b787 SHA512 f72fb9c3e843341300b68e06bb153690734f6e506cdd9f0d9362c760ff48194ed1ed29e0b58a5050e7331069ad47a9902cc9e34bf616667baf84208f2b69a918
DIST pesign-0.112.tar.gz 107632 BLAKE2B 737b75aec7efa9f41dbdb509405dede914cd5aa563572f0d2ede96a321f4a669170c696c7bd93bad1a5c1a6f2c65715b66317544fa6fc55d6b7f85436d778e8a SHA512 9a0cd266f973fbd7bbbd23939d0be3c34dbccd9ab20941bf967ca1b18aa5bf5d2c41cdef0799399e09e7b0fc59a0b34bc660afb6da292eb1c127db2893362018
diff --git a/app-crypt/pesign/files/destdir.patch b/app-crypt/pesign/files/destdir.patch
deleted file mode 100644
index 70332410a3c8..000000000000
--- a/app-crypt/pesign/files/destdir.patch
+++ /dev/null
@@ -1,10 +0,0 @@
-diff --git a/Make.defaults b/Make.defaults
-index 864f98b..e2c967b 100644
---- a/Make.defaults
-+++ b/Make.defaults
-@@ -1,4 +1,4 @@
--INSTALLROOT:= /
-+INSTALLROOT:= $(DESTDIR)
- PREFIX := /usr
-
- HOSTARCH = $(shell uname -m | sed s,i[3456789]86,ia32,)
diff --git a/app-crypt/pesign/pesign-0.108.ebuild b/app-crypt/pesign/pesign-0.108.ebuild
deleted file mode 100644
index 6413ee2491d5..000000000000
--- a/app-crypt/pesign/pesign-0.108.ebuild
+++ /dev/null
@@ -1,55 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-inherit eutils multilib
-
-DESCRIPTION="Tools for manipulating signed PE-COFF binaries"
-HOMEPAGE="https://github.com/vathpela/pesign"
-SRC_URI="https://github.com/vathpela/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="libressl"
-
-RDEPEND="
- dev-libs/nspr
- dev-libs/nss
- dev-libs/popt
- !libressl? ( dev-libs/openssl:0= )
- libressl? ( dev-libs/libressl:0= )
- sys-apps/util-linux
-"
-DEPEND="${RDEPEND}
- sys-apps/help2man
- sys-boot/gnu-efi
- virtual/pkgconfig
-"
-
-src_prepare() {
- epatch "${FILESDIR}"/destdir.patch
-}
-
-src_install() {
- default
-
- # remove some files that don't make sense for Gentoo installs
- rm -rf "${ED}/etc/" "${ED}/usr/share/doc/pesign/" || die
-
- # create .so symlink
- ln -s libdpe.so "${ED}/usr/$(get_libdir)/libdpe.so.0"
-}
-#
-#src_prepare() {
-# local iarch
-# case ${ARCH} in
-# ia64) iarch=ia64 ;;
-# x86) iarch=ia32 ;;
-# amd64) iarch=x86_64 ;;
-# *) die "unsupported architecture: ${ARCH}" ;;
-# esac
-# sed -i "/^EFI_ARCH=/s:=.*:=${iarch}:" configure || die
-# sed -i 's/-m64$/& -march=x86-64/' tests/Makefile.in || die
-#}