summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--app-cdr/cdrdao/cdrdao-1.2.3-r1.ebuild59
-rw-r--r--app-cdr/cdrdao/cdrdao-1.2.3-r2.ebuild68
-rw-r--r--app-cdr/cdrdao/cdrdao-1.2.3-r3.ebuild65
-rw-r--r--app-cdr/cdrdao/metadata.xml3
4 files changed, 0 insertions, 195 deletions
diff --git a/app-cdr/cdrdao/cdrdao-1.2.3-r1.ebuild b/app-cdr/cdrdao/cdrdao-1.2.3-r1.ebuild
deleted file mode 100644
index 836672f12732..000000000000
--- a/app-cdr/cdrdao/cdrdao-1.2.3-r1.ebuild
+++ /dev/null
@@ -1,59 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=4
-inherit eutils
-
-DESCRIPTION="Burn CDs in disk-at-once mode -- with optional GUI frontend"
-HOMEPAGE="http://cdrdao.sourceforge.net/"
-if [[ ${PV/*_rc*} ]]
-then
- SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2"
-else
- SRC_URI="http://www.poolshark.org/src/${P/_}.tar.bz2"
-fi
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="alpha amd64 arm hppa ia64 ppc ppc64 sh sparc x86 ~x86-fbsd"
-IUSE="gcdmaster encode mad vorbis"
-
-RDEPEND="virtual/cdrtools
- encode? ( >=media-sound/lame-3.99 )
- gcdmaster? (
- dev-libs/libsigc++:2
- >=dev-cpp/gtkmm-2.4:2.4
- >=dev-cpp/libgnomeuimm-2.6:2.6
- media-libs/libao
- )
- mad? (
- media-libs/libmad
- media-libs/libao
- )
- vorbis? (
- media-libs/libvorbis
- media-libs/libao
- )
- !app-cdr/cue2toc
- !dev-util/pccts"
-DEPEND="${RDEPEND}
- virtual/pkgconfig"
-
-S=${WORKDIR}/${P/_}
-
-src_prepare() {
- epatch "${FILESDIR}"/${P}-glibc212.patch
-}
-
-src_configure() {
- econf \
- $(use_with gcdmaster xdao) \
- $(use_with vorbis ogg-support) \
- $(use_with mad mp3-support) \
- $(use_with encode lame)
-}
-
-src_install() {
- emake DESTDIR="${D}" install
- dodoc AUTHORS ChangeLog CREDITS NEWS README{,.PlexDAE}
-}
diff --git a/app-cdr/cdrdao/cdrdao-1.2.3-r2.ebuild b/app-cdr/cdrdao/cdrdao-1.2.3-r2.ebuild
deleted file mode 100644
index b3f48258331e..000000000000
--- a/app-cdr/cdrdao/cdrdao-1.2.3-r2.ebuild
+++ /dev/null
@@ -1,68 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-inherit eutils flag-o-matic toolchain-funcs
-
-DESCRIPTION="Burn CDs in disk-at-once mode -- with optional GUI frontend"
-HOMEPAGE="http://cdrdao.sourceforge.net/"
-if [[ ${PV/*_rc*} ]]
-then
- SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2"
-else
- SRC_URI="http://www.poolshark.org/src/${P/_}.tar.bz2"
-fi
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~alpha amd64 arm hppa ~ia64 ~ppc ppc64 ~sh ~sparc x86 ~x86-fbsd"
-IUSE="gcdmaster encode mad vorbis"
-
-RDEPEND="virtual/cdrtools
- encode? ( >=media-sound/lame-3.99 )
- gcdmaster? (
- >=dev-libs/libsigc++-2.6:2
- >=dev-cpp/gtkmm-2.4:2.4
- >=dev-cpp/libgnomeuimm-2.6:2.6
- media-libs/libao
- )
- mad? (
- media-libs/libmad
- media-libs/libao
- )
- vorbis? (
- media-libs/libvorbis
- media-libs/libao
- )
- !app-cdr/cue2toc
- !dev-util/pccts"
-DEPEND="${RDEPEND}
- virtual/pkgconfig"
-
-S=${WORKDIR}/${P/_}
-
-src_prepare() {
- epatch "${FILESDIR}"/${P}-glibc212.patch
- epatch "${FILESDIR}"/${P}-unsigned-char.patch #569344
-}
-
-src_configure() {
- # Make sure we use a sane default `ar`.
- tc-export AR
-
- # Fix building with latest libsigc++
- append-cxxflags -std=c++11
- find -name '*.h' -exec sed -i '/sigc++\/object.h/d' {} + || die
-
- econf \
- $(use_with gcdmaster xdao) \
- $(use_with vorbis ogg-support) \
- $(use_with mad mp3-support) \
- $(use_with encode lame)
-}
-
-src_install() {
- default
- dodoc AUTHORS ChangeLog CREDITS NEWS README{,.PlexDAE}
-}
diff --git a/app-cdr/cdrdao/cdrdao-1.2.3-r3.ebuild b/app-cdr/cdrdao/cdrdao-1.2.3-r3.ebuild
deleted file mode 100644
index 4cd70db0b683..000000000000
--- a/app-cdr/cdrdao/cdrdao-1.2.3-r3.ebuild
+++ /dev/null
@@ -1,65 +0,0 @@
-# Copyright 1999-2016 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-inherit autotools flag-o-matic
-
-DESCRIPTION="Burn CDs in disk-at-once mode -- with optional GUI frontend"
-HOMEPAGE="http://cdrdao.sourceforge.net/"
-if [[ ${PV/*_rc*} ]]
-then
- SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2"
-else
- SRC_URI="http://www.poolshark.org/src/${P/_}.tar.bz2"
-fi
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sh ~sparc ~x86 ~x86-fbsd"
-IUSE="gcdmaster encode mad vorbis"
-
-RDEPEND="virtual/cdrtools
- encode? ( >=media-sound/lame-3.99 )
- gcdmaster? (
- >=dev-libs/libsigc++-2.6:2
- >=dev-cpp/gtkmm-2.4:2.4
- >=dev-cpp/libgnomeuimm-2.6:2.6
- media-libs/libao
- )
- mad? (
- media-libs/libmad
- media-libs/libao
- )
- vorbis? (
- media-libs/libvorbis
- media-libs/libao
- )
- !app-cdr/cue2toc
- !dev-util/pccts"
-DEPEND="${RDEPEND}
- virtual/pkgconfig"
-PATCHES=(
- "${FILESDIR}/${P}-glibc212.patch"
- "${FILESDIR}/${P}-unsigned-char.patch"
- "${FILESDIR}/${P}-ax_pthread.patch"
- "${FILESDIR}/${P}-wformat-security.patch"
-)
-S=${WORKDIR}/${P/_}
-
-src_prepare() {
- default
- eautoreconf
-}
-
-src_configure() {
- # Fix building with latest libsigc++
- append-cxxflags -std=c++11
- find -name '*.h' -exec sed -i '/sigc++\/object.h/d' {} + || die
-
- econf \
- $(use_with gcdmaster xdao) \
- $(use_with vorbis ogg-support) \
- $(use_with mad mp3-support) \
- $(use_with encode lame)
-}
diff --git a/app-cdr/cdrdao/metadata.xml b/app-cdr/cdrdao/metadata.xml
index 0981f4cab9a5..d31754f982bc 100644
--- a/app-cdr/cdrdao/metadata.xml
+++ b/app-cdr/cdrdao/metadata.xml
@@ -13,9 +13,6 @@
CD command line recording, ripping and copying tool. Especially ISOs- and
bin/cue-files are handled very well.
</longdescription>
- <use>
- <flag name="gcdmaster">Enable building of gcdmaster application</flag>
- </use>
<upstream>
<remote-id type="sourceforge">cdrdao</remote-id>
</upstream>