summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-haskell/listlike/files/listlike-4.2.1-QC-2.8.2.patch12
-rw-r--r--dev-haskell/listlike/listlike-4.2.1.ebuild4
2 files changed, 16 insertions, 0 deletions
diff --git a/dev-haskell/listlike/files/listlike-4.2.1-QC-2.8.2.patch b/dev-haskell/listlike/files/listlike-4.2.1-QC-2.8.2.patch
new file mode 100644
index 000000000000..1615c29047e2
--- /dev/null
+++ b/dev-haskell/listlike/files/listlike-4.2.1-QC-2.8.2.patch
@@ -0,0 +1,12 @@
+diff --git a/testsrc/TestInfrastructure.hs b/testsrc/TestInfrastructure.hs
+index f4d574e..d427495 100644
+--- a/testsrc/TestInfrastructure.hs
++++ b/testsrc/TestInfrastructure.hs
+@@ -76,2 +76,3 @@ instance (CoArbitrary i) => CoArbitrary (FM.FMList i) where
+
++#if ! MIN_VERSION_QuickCheck(2,8,2)
+ instance (Arbitrary i) => Arbitrary (S.Seq i) where
+@@ -85,2 +86,3 @@ instance (CoArbitrary i) => CoArbitrary (S.Seq i) where
+ coarbitrary l = coarbitrary (LL.toList l)
++#endif
+
diff --git a/dev-haskell/listlike/listlike-4.2.1.ebuild b/dev-haskell/listlike/listlike-4.2.1.ebuild
index a872109efa0e..964cec348725 100644
--- a/dev-haskell/listlike/listlike-4.2.1.ebuild
+++ b/dev-haskell/listlike/listlike-4.2.1.ebuild
@@ -35,3 +35,7 @@ DEPEND="${RDEPEND}
"
S="${WORKDIR}/${MY_P}"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-QC-2.8.2.patch
+}