summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-cpp/ETL/ETL-0.04.15-r1.ebuild23
1 files changed, 23 insertions, 0 deletions
diff --git a/dev-cpp/ETL/ETL-0.04.15-r1.ebuild b/dev-cpp/ETL/ETL-0.04.15-r1.ebuild
new file mode 100644
index 000000000000..98488ac2a7b2
--- /dev/null
+++ b/dev-cpp/ETL/ETL-0.04.15-r1.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools
+
+DESCRIPTION="Multi-platform class and template library"
+HOMEPAGE="https://www.synfig.org"
+SRC_URI="mirror://sourceforge/synfig/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+src_prepare() {
+ default
+ sed -i -e 's/CXXFLAGS="`echo $CXXFLAGS | sed s:-g::` $debug_flags"//' \
+ -e 's/CFLAGS="`echo $CFLAGS | sed s:-g::` $debug_flags"//' \
+ m4/subs.m4 || die
+
+ eautoreconf
+}