summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--media-gfx/exiv2/Manifest1
-rw-r--r--media-gfx/exiv2/exiv2-0.27.3_rc1.ebuild103
2 files changed, 104 insertions, 0 deletions
diff --git a/media-gfx/exiv2/Manifest b/media-gfx/exiv2/Manifest
index 7f1104c26aaa..99cb5ff7f89d 100644
--- a/media-gfx/exiv2/Manifest
+++ b/media-gfx/exiv2/Manifest
@@ -1 +1,2 @@
DIST exiv2-0.27.2-Source.tar.gz 27591236 BLAKE2B bd10d71356e4c8a465b71f8ceac07fbf2fd6cfb287cb22774568ad35eb38200be504e297224920af50a15ab4e9da98384ff4da7c33713f5346b33738380698b0 SHA512 39eb7d920dce18b275ac66f4766c7c73f7c72ee10e3e1e43d84c611b24f48ce20a70eac6d53948914e93242a25b8b52cc4bc760ee611ddcd77481306c1f9e721
+DIST exiv2-0.27.3_rc1.tar.gz 27577726 BLAKE2B bb78b33419bf94e49a437e4d4b3820a9d178550cdcf4ebca52a3feab68e7d1a31881412edfff64ab80036b4912de2e1df57130ffdc308c3b585e378438580fb0 SHA512 1650f20c8572516c92fbb2af4ee18ce6dc9aa07db8c6ebf7e3bec3e7a02e1a13b1b60da88a11eba864bb805ce4d78c8acd4a0264fb842ab39dcfa6983b314328
diff --git a/media-gfx/exiv2/exiv2-0.27.3_rc1.ebuild b/media-gfx/exiv2/exiv2-0.27.3_rc1.ebuild
new file mode 100644
index 000000000000..c7b63dfb0158
--- /dev/null
+++ b/media-gfx/exiv2/exiv2-0.27.3_rc1.ebuild
@@ -0,0 +1,103 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+if [[ ${PV} = *9999 ]]; then
+ EGIT_REPO_URI="https://github.com/Exiv2/exiv2.git"
+ inherit git-r3
+else
+ MY_PV="${PV/_/-}"
+ SRC_URI="https://github.com/Exiv2/exiv2/archive/v${MY_PV^^}.tar.gz -> ${P}.tar.gz"
+# KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~x64-solaris ~x86-solaris"
+fi
+
+CMAKE_ECLASS=cmake
+PYTHON_COMPAT=( python3_{6,7,8} )
+inherit cmake-multilib python-any-r1
+
+DESCRIPTION="EXIF, IPTC and XMP metadata C++ library and command line utility"
+HOMEPAGE="https://www.exiv2.org/"
+
+LICENSE="GPL-2"
+SLOT="0/27"
+IUSE="doc examples nls +png webready +xmp"
+
+BDEPEND="
+ doc? (
+ ${PYTHON_DEPS}
+ app-doc/doxygen
+ dev-libs/libxslt
+ media-gfx/graphviz
+ virtual/pkgconfig
+ )
+ nls? ( sys-devel/gettext )
+"
+DEPEND="
+ >=virtual/libiconv-0-r1[${MULTILIB_USEDEP}]
+ nls? ( >=virtual/libintl-0-r1[${MULTILIB_USEDEP}] )
+ png? ( sys-libs/zlib[${MULTILIB_USEDEP}] )
+ webready? (
+ >net-libs/libssh-0.9.1[${MULTILIB_USEDEP}]
+ net-misc/curl[${MULTILIB_USEDEP}]
+ )
+ xmp? ( dev-libs/expat[${MULTILIB_USEDEP}] )
+"
+RDEPEND="${DEPEND}"
+
+DOCS=( README.md doc/ChangeLog doc/cmd.txt )
+
+S="${WORKDIR}/${PN}-${MY_PV^^}"
+
+pkg_setup() {
+ use doc && python-any-r1_pkg_setup
+}
+
+src_prepare() {
+ # FIXME @upstream:
+ einfo "Converting doc/cmd.txt to UTF-8"
+ iconv -f LATIN1 -t UTF-8 doc/cmd.txt > doc/cmd.txt.tmp || die
+ mv -f doc/cmd.txt.tmp doc/cmd.txt || die
+
+ cmake_src_prepare
+
+ sed -e "/^include.*compilerFlags/s/^/#DONT /" -i CMakeLists.txt || die
+}
+
+multilib_src_configure() {
+ local mycmakeargs=(
+ -DEXIV2_BUILD_SAMPLES=NO
+ -DEXIV2_BUILD_PO=$(usex nls)
+ -DEXIV2_ENABLE_NLS=$(usex nls)
+ -DEXIV2_ENABLE_PNG=$(usex png)
+ -DEXIV2_ENABLE_CURL=$(usex webready)
+ -DEXIV2_ENABLE_SSH=$(usex webready)
+ -DEXIV2_ENABLE_WEBREADY=$(usex webready)
+ -DEXIV2_ENABLE_XMP=$(usex xmp)
+ $(multilib_is_native_abi || echo -DEXIV2_BUILD_EXIV2_COMMAND=NO)
+ $(multilib_is_native_abi && echo -DEXIV2_BUILD_DOC=$(usex doc))
+ -DCMAKE_INSTALL_DOCDIR="${EPREFIX}"/usr/share/doc/${PF}/html
+ )
+
+ cmake_src_configure
+}
+
+multilib_src_compile() {
+ cmake_src_compile
+
+ if multilib_is_native_abi; then
+ use doc && eninja doc
+ fi
+}
+
+multilib_src_install_all() {
+ use xmp && DOCS+=( doc/{COPYING-XMPSDK,README-XMP,cmdxmp.txt} )
+
+ einstalldocs
+ find "${D}" -name '*.la' -delete || die
+
+ if use examples; then
+ docinto examples
+ dodoc samples/*.cpp
+ fi
+}