summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-apps/debianutils/debianutils-4.8.6.1.ebuild')
-rw-r--r--sys-apps/debianutils/debianutils-4.8.6.1.ebuild41
1 files changed, 41 insertions, 0 deletions
diff --git a/sys-apps/debianutils/debianutils-4.8.6.1.ebuild b/sys-apps/debianutils/debianutils-4.8.6.1.ebuild
new file mode 100644
index 000000000000..3d28df99ad7a
--- /dev/null
+++ b/sys-apps/debianutils/debianutils-4.8.6.1.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit flag-o-matic
+
+DESCRIPTION="A selection of tools from Debian"
+HOMEPAGE="https://packages.qa.debian.org/d/debianutils.html"
+SRC_URI="mirror://debian/pool/main/d/${PN}/${PN}_${PV}.tar.xz"
+
+LICENSE="BSD GPL-2 SMAIL"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~x86-linux"
+IUSE="+installkernel static"
+
+S="${WORKDIR}/${PN}"
+
+PATCHES=( "${FILESDIR}"/${PN}-3.4.2-no-bs-namespace.patch )
+
+src_configure() {
+ use static && append-ldflags -static
+ default
+}
+
+src_install() {
+ into /
+ dobin tempfile run-parts
+ if use installkernel ; then
+ dosbin installkernel
+ fi
+
+ into /usr
+ dosbin savelog
+
+ doman tempfile.1 run-parts.8 savelog.8
+ use installkernel && doman installkernel.8
+ cd debian || die
+ dodoc changelog control
+ keepdir /etc/kernel/postinst.d
+}