summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-devel/binutils-apple/binutils-apple-4.3-r2.ebuild')
-rw-r--r--sys-devel/binutils-apple/binutils-apple-4.3-r2.ebuild11
1 files changed, 5 insertions, 6 deletions
diff --git a/sys-devel/binutils-apple/binutils-apple-4.3-r2.ebuild b/sys-devel/binutils-apple/binutils-apple-4.3-r2.ebuild
index f959d52dadb7..b3cf69bdae49 100644
--- a/sys-devel/binutils-apple/binutils-apple-4.3-r2.ebuild
+++ b/sys-devel/binutils-apple/binutils-apple-4.3-r2.ebuild
@@ -213,8 +213,8 @@ compile_ld64() {
einfo "building ${LD64}"
cd "${S}"/${LD64}/src
emake \
- LTO=${ENABLE_LTO} \
- || die "emake failed for ld64"
+ LTO=${ENABLE_LTO}
+
use test && emake build_test
}
@@ -232,15 +232,14 @@ compile_cctools() {
RC_ProjectSourceVersion=${CCTOOLS_VERSION} \
RC_CFLAGS="${CFLAGS}" \
OFLAG="${CCTOOLS_OFLAG}" \
- -j1 \
- || die "emake failed for the cctools"
+ -j1
+
cd "${S}"/${CCTOOLS}/as
emake \
BUILD_OBSOLETE_ARCH= \
RC_ProjectSourceVersion=${CCTOOLS_VERSION} \
RC_CFLAGS="-DASLIBEXECDIR=\"\\\"${EPREFIX}${LIBPATH}/\\\"\" ${CFLAGS}" \
- OFLAG="${CCTOOLS_OFLAG}" \
- || die "emake failed for as"
+ OFLAG="${CCTOOLS_OFLAG}"
}
src_compile() {