summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-devel/binutils-apple/binutils-apple-5.1-r1.ebuild')
-rw-r--r--sys-devel/binutils-apple/binutils-apple-5.1-r1.ebuild11
1 files changed, 5 insertions, 6 deletions
diff --git a/sys-devel/binutils-apple/binutils-apple-5.1-r1.ebuild b/sys-devel/binutils-apple/binutils-apple-5.1-r1.ebuild
index e2bead82b9e7..73ec964cbefc 100644
--- a/sys-devel/binutils-apple/binutils-apple-5.1-r1.ebuild
+++ b/sys-devel/binutils-apple/binutils-apple-5.1-r1.ebuild
@@ -253,8 +253,8 @@ compile_ld64() {
einfo "building ${LD64}"
cd "${S}"/${LD64}/src
emake \
- LTO=${ENABLE_LTO} \
- || die "emake failed for ld64"
+ LTO=${ENABLE_LTO}
+
use test && emake build_test
}
@@ -278,16 +278,15 @@ compile_cctools() {
OFLAG="${CCTOOLS_OFLAG}" \
CXXLIB="${CXXLIB}" \
DSYMUTIL=": disabled: dsymutil" \
- -j1 \
- || die "emake failed for the cctools"
+ -j1
+
cd "${S}"/${CCTOOLS}/as
emake \
BUILD_OBSOLETE_ARCH= \
RC_ProjectSourceVersion=${CCTOOLS_VERSION} \
RC_CFLAGS="-DASLIBEXECDIR=\"\\\"${EPREFIX}${LIBPATH}/\\\"\" ${CFLAGS}" \
OFLAG="${CCTOOLS_OFLAG}" \
- DSYMUTIL=": disabled: dsymutil" \
- || die "emake failed for as"
+ DSYMUTIL=": disabled: dsymutil"
}
src_compile() {