aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHorodniceanu Andrei <a.horodniceanu@protonmail.com>2022-08-14 14:39:39 +0300
committerHorodniceanu Andrei <a.horodniceanu@protonmail.com>2022-08-14 14:41:41 +0300
commitbeae9775d4a49f0dbe72b15c5b0b17d48bcdedf1 (patch)
treea77a262632c08b31bb16e6a6c697de51e7247ab2
parentfixed KEYWORDS on ldc2-1.29 (diff)
downloaddlang-beae9775d4a49f0dbe72b15c5b0b17d48bcdedf1.tar.gz
dlang-beae9775d4a49f0dbe72b15c5b0b17d48bcdedf1.tar.bz2
dlang-beae9775d4a49f0dbe72b15c5b0b17d48bcdedf1.zip
dev-util/dub version bump
Also added man pages support. Signed-off-by: Horodniceanu Andrei <a.horodniceanu@protonmail.com>
-rw-r--r--dev-util/dub/Manifest2
-rw-r--r--dev-util/dub/dub-1.29.0.ebuild (renamed from dev-util/dub/dub-1.25.0.ebuild)15
-rw-r--r--dev-util/dub/files/dub-1.29.0-gdc-dmd-pathfix.patch (renamed from dev-util/dub/files/dub-1.25.0-gdc-dmd-pathfix.patch)0
3 files changed, 13 insertions, 4 deletions
diff --git a/dev-util/dub/Manifest b/dev-util/dub/Manifest
index b53e909..4c543e0 100644
--- a/dev-util/dub/Manifest
+++ b/dev-util/dub/Manifest
@@ -1 +1 @@
-DIST dub-1.25.0.tar.gz 1303972 BLAKE2B 64579b3150904b3e2ce76aa0dd5930f8d861afa7bb4ab0a2cf7b5796161adb61c0f510f07bea2b82bc23f64fd1f614c9222cec12c3254e0d18b510f4fa39aff1 SHA512 9694d79933283c79ef9e272a52f141f49097d65d2e203b78443da2b6e10ed249fe4ce4614f8357d11fb1de0bddfd56ea8cd2dd2b243ec25231ee1f7db5538d8c
+DIST dub-1.29.0.tar.gz 1321720 BLAKE2B c24f55cb4d356538a22eda86b8abec0d0ccdb3ede6bc1e49424ba8350d0ac95b2c3b9307c6eaa9b9547be6a040548824ea32a019aac62287f8410c9beec07bd2 SHA512 f851ceccb7aa1ee00560c64fca2cf4239f0b260c7c2eee5c3688a555f7f37ff7bc4894cbc944ec0cf3a5b1cb1cf33d6d1e9cf23b24b42e098ccb3f432354a97c
diff --git a/dev-util/dub/dub-1.25.0.ebuild b/dev-util/dub/dub-1.29.0.ebuild
index e60575b..29c03c0 100644
--- a/dev-util/dub/dub-1.25.0.ebuild
+++ b/dev-util/dub/dub-1.29.0.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -8,14 +8,15 @@ HOMEPAGE="https://code.dlang.org/"
LICENSE="MIT"
SLOT="0"
-KEYWORDS="amd64 ~arm x86"
+KEYWORDS="~amd64 ~arm ~x86"
IUSE="debug"
GITHUB_URI="https://codeload.github.com/dlang"
SRC_URI="${GITHUB_URI}/${PN}/tar.gz/v${PV} -> ${PN}-${PV}.tar.gz"
PATCHES="${FILESDIR}/${P}-gdc-dmd-pathfix.patch"
-DLANG_VERSION_RANGE="2.081-"
+# Upstream recommends the latest version available
+DLANG_VERSION_RANGE="2.083-"
DLANG_PACKAGE_TYPE="single"
inherit dlang
@@ -26,6 +27,9 @@ RDEPEND="${DEPEND}"
d_src_compile() {
local imports=source versions="DubApplication DubUseCurl" libs="curl z"
dlang_compile_bin bin/dub $(<build-files.txt)
+
+ # Generate man pages
+ bin/dub scripts/man/gen_man.d || die "Could not generate man pages."
}
d_src_test() {
@@ -36,4 +40,9 @@ d_src_test() {
d_src_install() {
dobin bin/dub
dodoc README.md
+
+ # All the files in the directory below, with the exception of gen_man.d and README, are man pages.
+ # To keep the ebuild simple, we will just glob on the files that end in .1 since there are currently
+ # no man pages in a different section.
+ doman scripts/man/*.1
}
diff --git a/dev-util/dub/files/dub-1.25.0-gdc-dmd-pathfix.patch b/dev-util/dub/files/dub-1.29.0-gdc-dmd-pathfix.patch
index 497ef50..497ef50 100644
--- a/dev-util/dub/files/dub-1.25.0-gdc-dmd-pathfix.patch
+++ b/dev-util/dub/files/dub-1.29.0-gdc-dmd-pathfix.patch