aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarco Leise <marco.leise@gmx.de>2019-10-11 03:35:15 +0200
committerMarco Leise <marco.leise@gmx.de>2019-10-11 03:35:15 +0200
commite4a5d38ba3a5d28412fe6e7e90b0a2637d56f4ab (patch)
tree33716be96b97092c3216ed6ebcc789b3541afd08
parentstabilization sweep (diff)
downloaddlang-e4a5d38ba3a5d28412fe6e7e90b0a2637d56f4ab.tar.gz
dlang-e4a5d38ba3a5d28412fe6e7e90b0a2637d56f4ab.tar.bz2
dlang-e4a5d38ba3a5d28412fe6e7e90b0a2637d56f4ab.zip
onedrive-2.3.10
-rw-r--r--net-misc/onedrive/Manifest1
-rw-r--r--net-misc/onedrive/onedrive-2.3.10.ebuild70
2 files changed, 71 insertions, 0 deletions
diff --git a/net-misc/onedrive/Manifest b/net-misc/onedrive/Manifest
index e7194cc..0842cf9 100644
--- a/net-misc/onedrive/Manifest
+++ b/net-misc/onedrive/Manifest
@@ -1 +1,2 @@
+DIST onedrive-2.3.10.tar.gz 656374 BLAKE2B fad1b26de532c0033544fb9ea1eda5c2bd3c9bbbe84db59f02f3f5484b604f8510e8807466403861ac060a56679425400e36d1d31f2030e55149400676079997 SHA512 94fe4c963e71c2e4c8f295eaa3242e4177320b21531d38faa74558a045c0c8e544a35d8b31da3549f94af46f68ab0738a0b60c4bf0ddff051d836fd514c5cd32
DIST onedrive-2.3.9.tar.gz 652696 BLAKE2B 995f1d013b1680fb1c55b4416b846683619e2cc7140ef6f5e50d7ef1a488fbd97573d6d79088460fa2baffce7bae4b49eb988f3680a4d6126743bdfa2765381e SHA512 1031539d2a4a0b6d25d8ab7b0f18f3ec8ea235be675530f271a09a0519a661573d86c0ac73d6759e6d13985b9f627cd417ea0c4013ef27408d1414e0fa825272
diff --git a/net-misc/onedrive/onedrive-2.3.10.ebuild b/net-misc/onedrive/onedrive-2.3.10.ebuild
new file mode 100644
index 0000000..0c5102a
--- /dev/null
+++ b/net-misc/onedrive/onedrive-2.3.10.ebuild
@@ -0,0 +1,70 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="Free Client for OneDrive on Linux"
+HOMEPAGE="https://github.com/abraunegg/onedrive"
+LICENSE="GPL-3"
+
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+RDEPEND="
+ >=dev-db/sqlite-3.7.15:3
+ net-misc/curl
+ libnotify? ( x11-libs/libnotify )
+"
+DEPEND="
+ ${RDEPEND}
+ virtual/pkgconfig
+"
+SRC_URI="https://codeload.github.com/abraunegg/onedrive/tar.gz/v${PV} -> ${P}.tar.gz"
+DLANG_VERSION_RANGE="2.082-"
+DLANG_PACKAGE_TYPE="single"
+IUSE="debug libnotify"
+
+inherit dlang systemd bash-completion-r1
+
+src_prepare() {
+ mkdir .git
+ touch .git/HEAD .git/index
+ echo "v${PV}" > version
+ default_src_prepare
+}
+
+d_src_configure() {
+ # LDC is supported without wrapper
+ if [[ "${DLANG_VENDOR}" == "LDC" ]]; then
+ export DC=${DC}
+ export DCFLAGS=${DCFLAGS}
+ else
+ export DC=${DMD}
+ export DCFLAGS=${DMDFLAGS}
+ fi
+ econf --disable-version-check --enable-completions $(use_enable debug) $(use_enable libnotify notifications) \
+ --with-zsh-completion-dir=/usr/share/zsh/site-functions --with-bash-completion-dir="$(get_bashcompdir)" \
+ --with-systemdsystemunitdir="$(systemd_get_systemunitdir)" \
+ --with-systemduserunitdir="$(systemd_get_userunitdir)"
+}
+
+src_install() {
+ emake DESTDIR="${D}" docdir=/usr/share/doc/${PF} install
+ # log directory
+ keepdir /var/log/onedrive
+ fperms 775 /var/log/onedrive
+ fowners root:users /var/log/onedrive
+ # init script
+ dobin contrib/init.d/onedrive_service.sh
+ newinitd contrib/init.d/onedrive.init onedrive
+}
+
+pkg_postinst() {
+ elog "OneDrive Free Client needs to be authorized to access your data before the"
+ elog "first use. To do so, run onedrive in a terminal for the user in question and"
+ elog "follow the steps on screen."
+ elog
+ ewarn "The 'skilion' version contains a significant number of defect's in how the"
+ ewarn "local sync state is managed. When upgrading from the 'skilion' version to this"
+ ewarn "version, it is advisable to stop any service / onedrive process from running"
+ ewarn "and then remove your configuration directory (~/.config/onedrive/)."
+}