aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarco Leise <marco.leise@gmx.de>2021-01-25 17:54:27 +0100
committerMarco Leise <marco.leise@gmx.de>2021-01-25 17:54:27 +0100
commitf10b22708bcab09dcde87c643e75756015282d76 (patch)
tree06dd597afb51e2ce3e492d59a4f0716f19330199
parentdmd-2.094.2 (diff)
downloaddlang-f10b22708bcab09dcde87c643e75756015282d76.tar.gz
dlang-f10b22708bcab09dcde87c643e75756015282d76.tar.bz2
dlang-f10b22708bcab09dcde87c643e75756015282d76.zip
dub-1.24
Signed-off-by: Marco Leise <marco.leise@gmx.de>
-rw-r--r--dev-util/dub/Manifest1
-rw-r--r--dev-util/dub/dub-1.24.0.ebuild39
-rw-r--r--dev-util/dub/files/dub-1.24.0-gdc-dmd-pathfix.patch16
3 files changed, 56 insertions, 0 deletions
diff --git a/dev-util/dub/Manifest b/dev-util/dub/Manifest
index a9e0579..2a20ba7 100644
--- a/dev-util/dub/Manifest
+++ b/dev-util/dub/Manifest
@@ -1 +1,2 @@
DIST dub-1.23.0.tar.gz 1279525 BLAKE2B 98693ec9997c8d13a649c2388f88dc6855b48db9267475c81b37ca191792bc1cef4b68aee5991479f0eb9854b7bf50675adf8f70bf39ebfe5db2333654d7643f SHA512 667d6cc57bdfd0450b2e99319f843ceb9d4c5ee37273850c4d19ae715fad5389ab23386a6c7ff5c69cf9d0e86b1c9f7d1f6b10cb6d4efc0c025101759dc0d1fa
+DIST dub-1.24.0.tar.gz 1302631 BLAKE2B eb3ed97ff643b8bafdd2448c3f5630d32417611528cec7a3f77242be35210e1b7a52b82f0058c0e894daccac35d94dcb3a4db2d1833be25cbe7acc3915f3f458 SHA512 39fdc8c1e1e8d57da4a1aeb832d2e661aa2acc2297a75e0900f9920be2dcfb84862d8893fdb9356e0c829f13dbea21ccd132e5abc2ef9c63968cc4a466edf00f
diff --git a/dev-util/dub/dub-1.24.0.ebuild b/dev-util/dub/dub-1.24.0.ebuild
new file mode 100644
index 0000000..6c03a22
--- /dev/null
+++ b/dev-util/dub/dub-1.24.0.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="Package and build management system for D"
+HOMEPAGE="https://code.dlang.org/"
+LICENSE="MIT"
+
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE="debug"
+
+GITHUB_URI="https://codeload.github.com/dlang"
+SRC_URI="${GITHUB_URI}/${PN}/tar.gz/v${PV} -> ${PN}-${PV}.tar.gz"
+PATCHES="${FILESDIR}/${P}-gdc-dmd-pathfix.patch"
+
+DLANG_VERSION_RANGE="2.081-"
+DLANG_PACKAGE_TYPE="single"
+
+inherit dlang
+
+DEPEND="net-misc/curl"
+RDEPEND="${DEPEND}"
+
+d_src_compile() {
+ local imports=source versions="DubApplication DubUseCurl" libs="curl z"
+ dlang_compile_bin bin/dub $(<build-files.txt)
+}
+
+d_src_test() {
+ echo "Test phase disabled due to multiple problems."
+ #DUB="${S}/bin/dub" test/run-unittest.sh || die "Test phase failed"
+}
+
+d_src_install() {
+ dobin bin/dub
+ dodoc README.md
+}
diff --git a/dev-util/dub/files/dub-1.24.0-gdc-dmd-pathfix.patch b/dev-util/dub/files/dub-1.24.0-gdc-dmd-pathfix.patch
new file mode 100644
index 0000000..497ef50
--- /dev/null
+++ b/dev-util/dub/files/dub-1.24.0-gdc-dmd-pathfix.patch
@@ -0,0 +1,16 @@
+diff --git a/source/dub/generators/build.d b/source/dub/generators/build.d
+--- a/source/dub/generators/build.d
++++ b/source/dub/generators/build.d
+@@ -119,10 +119,10 @@ class BuildGenerator : ProjectGenerator {
+ auto build_id = computeBuildID(config, buildsettings, settings);
+
+ // make all paths relative to shrink the command line
+- string makeRelative(string path) { return shrinkPath(NativePath(path), cwd); }
++ /+string makeRelative(string path) { return shrinkPath(NativePath(path), cwd); }
+ foreach (ref f; buildsettings.sourceFiles) f = makeRelative(f);
+ foreach (ref p; buildsettings.importPaths) p = makeRelative(p);
+- foreach (ref p; buildsettings.stringImportPaths) p = makeRelative(p);
++ foreach (ref p; buildsettings.stringImportPaths) p = makeRelative(p);+/
+
+ // perform the actual build
+ bool cached = false;