aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarco Leise <marco.leise@gmx.de>2019-12-21 19:15:04 +0100
committerMarco Leise <marco.leise@gmx.de>2019-12-23 17:50:00 +0100
commitf86b965e3acb05498cc1fc1c84dd9aecf9dfc3d5 (patch)
treed530cd527feecfb8fe7d0b1c85e731b7ac5e1641
parentdfmt-0.11.0 (diff)
downloaddlang-f86b965e3acb05498cc1fc1c84dd9aecf9dfc3d5.tar.gz
dlang-f86b965e3acb05498cc1fc1c84dd9aecf9dfc3d5.tar.bz2
dlang-f86b965e3acb05498cc1fc1c84dd9aecf9dfc3d5.zip
onedrive-2.3.12
Signed-off-by: Marco Leise <marco.leise@gmx.de>
-rw-r--r--net-misc/onedrive/Manifest1
-rw-r--r--net-misc/onedrive/onedrive-2.3.12.ebuild63
2 files changed, 64 insertions, 0 deletions
diff --git a/net-misc/onedrive/Manifest b/net-misc/onedrive/Manifest
index 3dd3a34..e0bb0f4 100644
--- a/net-misc/onedrive/Manifest
+++ b/net-misc/onedrive/Manifest
@@ -1,2 +1,3 @@
DIST onedrive-2.3.10.tar.gz 656374 BLAKE2B fad1b26de532c0033544fb9ea1eda5c2bd3c9bbbe84db59f02f3f5484b604f8510e8807466403861ac060a56679425400e36d1d31f2030e55149400676079997 SHA512 94fe4c963e71c2e4c8f295eaa3242e4177320b21531d38faa74558a045c0c8e544a35d8b31da3549f94af46f68ab0738a0b60c4bf0ddff051d836fd514c5cd32
DIST onedrive-2.3.11.tar.gz 659720 BLAKE2B 2f02f650d8f5dba629af6e7fcf770e2909d032b200f2296e1f7c130462b61e9cd6edfb5a085a9e191f5b1a7ca8f68fa3f3688820deb6ddc093491fddef4afa0d SHA512 fcaf2f107e7a72dcd9d6af7a6fe4770d9ef34cc63168e331f2bdba57133c2a2e79a436a862cae1b04fde880ecf155c4fc4d26d48f31dde5b87f7ce04f518ef25
+DIST onedrive-2.3.12.tar.gz 661491 BLAKE2B ebf4cc3455b90244b5d361849cfab6b269c42112a07a77c726cd67d6255edfca3af482a43dec079a4119c9d5a4f75304d39e8790712e8bf35c07eb975b284315 SHA512 edf7c51a2e312e30467b23c70acf4e78f563fc124f2444fd9c14f90aa528c3417372f8e0b958e519b749370d3ed248d96840c5de4569ab9838ce3ae8b73ef3e6
diff --git a/net-misc/onedrive/onedrive-2.3.12.ebuild b/net-misc/onedrive/onedrive-2.3.12.ebuild
new file mode 100644
index 0000000..31052e8
--- /dev/null
+++ b/net-misc/onedrive/onedrive-2.3.12.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="Free Client for OneDrive on Linux"
+HOMEPAGE="https://github.com/abraunegg/onedrive"
+LICENSE="GPL-3"
+
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+RDEPEND="
+ >=dev-db/sqlite-3.7.15:3
+ net-misc/curl
+ libnotify? ( x11-libs/libnotify )
+"
+DEPEND="
+ ${RDEPEND}
+ virtual/pkgconfig
+"
+SRC_URI="https://codeload.github.com/abraunegg/onedrive/tar.gz/v${PV} -> ${P}.tar.gz"
+DLANG_VERSION_RANGE="2.082-"
+DLANG_PACKAGE_TYPE="single"
+IUSE="debug libnotify"
+
+inherit dlang systemd bash-completion-r1
+
+d_src_configure() {
+ # LDC is supported without wrapper
+ if [[ "${DLANG_VENDOR}" == "LDC" ]]; then
+ export DC=${DC}
+ export DCFLAGS=${DCFLAGS}
+ else
+ export DC=${DMD}
+ export DCFLAGS=${DMDFLAGS}
+ fi
+ econf --disable-version-check --enable-completions $(use_enable debug) $(use_enable libnotify notifications) \
+ --with-zsh-completion-dir=/usr/share/zsh/site-functions --with-bash-completion-dir="$(get_bashcompdir)" \
+ --with-systemdsystemunitdir="$(systemd_get_systemunitdir)" \
+ --with-systemduserunitdir="$(systemd_get_userunitdir)"
+}
+
+src_install() {
+ emake DESTDIR="${D}" docdir=/usr/share/doc/${PF} install
+ # log directory
+ keepdir /var/log/onedrive
+ fperms 775 /var/log/onedrive
+ fowners root:users /var/log/onedrive
+ # init script
+ dobin contrib/init.d/onedrive_service.sh
+ newinitd contrib/init.d/onedrive.init onedrive
+}
+
+pkg_postinst() {
+ elog "OneDrive Free Client needs to be authorized to access your data before the"
+ elog "first use. To do so, run onedrive in a terminal for the user in question and"
+ elog "follow the steps on screen."
+ elog
+ ewarn "The 'skilion' version contains a significant number of defect's in how the"
+ ewarn "local sync state is managed. When upgrading from the 'skilion' version to this"
+ ewarn "version, it is advisable to stop any service / onedrive process from running"
+ ewarn "and then remove your configuration directory (~/.config/onedrive/)."
+}