aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-util/dfmt/Manifest2
-rw-r--r--dev-util/dfmt/dfmt-0.13.4.ebuild58
2 files changed, 60 insertions, 0 deletions
diff --git a/dev-util/dfmt/Manifest b/dev-util/dfmt/Manifest
index 8948644..f28fab2 100644
--- a/dev-util/dfmt/Manifest
+++ b/dev-util/dfmt/Manifest
@@ -1,3 +1,5 @@
DIST dfmt-0.13.2.tar.gz 91926 BLAKE2B 0d02600f10143232c62deca8f34ed239bb2e54f0390388aad184d3d78bd39aae5724d22f59d1303a9837173933dd8ca448aedeccb839fdd413ce827199202c35 SHA512 a1fb8339da4201d114bfc3748df2d1b4f42505932b1e55f74daa096cf48e91df827c677c7cc1c7df27937e45cebf571cb57551e843261915567e37cf4f3c8f29
+DIST dfmt-0.13.4.tar.gz 92846 BLAKE2B 4b16e8fc219004686315e6a478c349d0cdfc0a20b0ecc4e45a45a27774f1130c1346a78632ba44088c4b25ba1db6e4a78bec6ff33a680e17e7a30f241c274582 SHA512 997148a6234f446fbcc7eb75f8cb8b21b723131f997a84541f8486f98970d15d2330b0c0297b2fa3e834e03f6b35dce9623d59c439fdc3bf0881b72aef8b4281
DIST libdparse-1557eb079a2d5958e0a7136f942eea0922d58e8a.tar.gz 132387 BLAKE2B 180316ef25713eb723e43e13c983f2c7b8c775f7e4c984217b497505ed0f7a9b1eb351867317a1e0957dd368a71b7fe403d8a636baf8ad8240f2b39fb7bc2c69 SHA512 1dbab30db4f14d99f27672be12b63bba04534a0c69c58453441b8a654336d9a38c869a6db738442b692d4d7cfdb0f68ed0bfaaa462c58aed0bedef60ea4dfbac
+DIST libdparse-9aefc9c5e6e1495aca094d5c403f35f1052677d1.tar.gz 145180 BLAKE2B c0050cf47a2f417b7cdc67adad5c642e44dad310d7f85ea46d81e29d054fa0e489cb7a2b83ac8d4c6891530961e986d700baa0d9771046ea5a3c314d956f92f3 SHA512 f66d83e72a9de42bcd21794809f22c5b8d3fde1af136f1f55a9991e30a430e1229f5183a2a6e172e6b49ec7e1139213523be419ff1a07826910f5067e7439490
DIST stdx-allocator-ae237cabd1843774cc78aad0729c914a3dd579db.tar.gz 103650 BLAKE2B 8d03c2dc76194b18da92261c533c402b87bda1964662070d02ceacbab3dda91a834c0c8bfe45feb1d9a3d7669f96a2a1f7b9a6b7eff7ea53069480d8de8fe15e SHA512 893e5ecefac86a64b3a91f034cc9f42aabc264d111b40accf890b505ec9d077fcaac0b29fc202400448994e4ff021263beef7716798734cb9b71b6aad1aaf394
diff --git a/dev-util/dfmt/dfmt-0.13.4.ebuild b/dev-util/dfmt/dfmt-0.13.4.ebuild
new file mode 100644
index 0000000..88cbc1b
--- /dev/null
+++ b/dev-util/dfmt/dfmt-0.13.4.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="Dfmt is a formatter for D source code"
+HOMEPAGE="https://github.com/dlang-community/dfmt"
+LICENSE="Boost-1.0"
+
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+LIBDPARSE="9aefc9c5e6e1495aca094d5c403f35f1052677d1"
+ALLOCATOR="ae237cabd1843774cc78aad0729c914a3dd579db"
+SRC_URI="
+ https://github.com/dlang-community/dfmt/archive/v${PV}.tar.gz -> ${PN}-${PV}.tar.gz
+ https://github.com/dlang-community/libdparse/archive/${LIBDPARSE}.tar.gz -> libdparse-${LIBDPARSE}.tar.gz
+ https://github.com/dlang-community/stdx-allocator/archive/${ALLOCATOR}.tar.gz -> stdx-allocator-${ALLOCATOR}.tar.gz
+ "
+
+DLANG_VERSION_RANGE="2.075-"
+DLANG_PACKAGE_TYPE="single"
+
+inherit dlang bash-completion-r1
+
+src_prepare() {
+ mkdir bin || die "Failed to create 'bin' directory."
+ cat > bin/githash.txt << EOF
+v${PV}
+EOF
+ dlang_src_prepare
+}
+
+d_src_compile() {
+ local libdparse_src="../libdparse-${LIBDPARSE}/src"
+ local allocator_src="../stdx-allocator-${ALLOCATOR}/source"
+ local imports="src ${libdparse_src} ${allocator_src}"
+ local string_imports="bin"
+
+ dlang_compile_bin "bin/dfmt" "src/dfmt/main.d" "src/dfmt/config.d" "src/dfmt/editorconfig.d" \
+ "src/dfmt/ast_info.d" "src/dfmt/indentation.d" "src/dfmt/tokens.d" "src/dfmt/wrapping.d" \
+ "src/dfmt/formatter.d" "src/dfmt/globmatch_editorconfig.d" \
+ ${libdparse_src}/dparse/lexer.d ${libdparse_src}/dparse/parser.d ${libdparse_src}/dparse/ast.d \
+ ${libdparse_src}/dparse/rollback_allocator.d ${libdparse_src}/dparse/stack_buffer.d \
+ ${libdparse_src}/dparse/trivia.d ${libdparse_src}/std/experimental/lexer.d \
+ ${allocator_src}/stdx/allocator/common.d ${allocator_src}/stdx/allocator/internal.d \
+ ${allocator_src}/stdx/allocator/mallocator.d ${allocator_src}/stdx/allocator/package.d \
+ ${allocator_src}/stdx/allocator/gc_allocator.d ${allocator_src}/stdx/allocator/typed.d
+}
+
+d_src_test() {
+ cd tests && ./test.sh
+}
+
+d_src_install() {
+ dobin bin/dfmt
+ dodoc README.md LICENSE.txt
+ dobashcomp bash-completion/completions/dfmt
+}