aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuel Bernardo <samuelbernardo.mail@gmail.com>2022-09-09 14:50:49 +0100
committerSamuel Bernardo <samuelbernardo.mail@gmail.com>2022-09-09 14:50:49 +0100
commit88236bafcc117e6e1fa6bec69e5330151881279e (patch)
tree44323db08b5d62195883e0b2a940dfcdba6d7e33 /dev-util/eclipse-sdk-bin/eclipse-sdk-bin-4.24.0.ebuild
parentRemove idea-community since it is being maintained by gentoo main repo (diff)
downloadssnb-88236bafcc117e6e1fa6bec69e5330151881279e.tar.gz
ssnb-88236bafcc117e6e1fa6bec69e5330151881279e.tar.bz2
ssnb-88236bafcc117e6e1fa6bec69e5330151881279e.zip
eclipse-sdk update and ebuild old releases cleanup
Signed-off-by: Samuel Bernardo <samuelbernardo.mail@gmail.com>
Diffstat (limited to 'dev-util/eclipse-sdk-bin/eclipse-sdk-bin-4.24.0.ebuild')
-rw-r--r--dev-util/eclipse-sdk-bin/eclipse-sdk-bin-4.24.0.ebuild50
1 files changed, 50 insertions, 0 deletions
diff --git a/dev-util/eclipse-sdk-bin/eclipse-sdk-bin-4.24.0.ebuild b/dev-util/eclipse-sdk-bin/eclipse-sdk-bin-4.24.0.ebuild
new file mode 100644
index 0000000..85eca0d
--- /dev/null
+++ b/dev-util/eclipse-sdk-bin/eclipse-sdk-bin-4.24.0.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=8
+
+inherit desktop
+
+SR="R"
+RNAME="2022-06"
+
+SRC_BASE="https://www.eclipse.org/downloads/download.php?file=/technology/epp/downloads/release/${RNAME}/${SR}/eclipse-java-${RNAME}-${SR}-linux-gtk"
+
+DESCRIPTION="Eclipse SDK"
+HOMEPAGE="http://www.eclipse.org"
+SRC_URI="amd64? ( ${SRC_BASE}-x86_64.tar.gz&r=1 -> eclipse-java-${RNAME}-${SR}-linux-gtk-x86_64-${PV}.tar.gz )"
+
+LICENSE="EPL-1.0"
+SLOT="4.15"
+KEYWORDS="~x86 ~amd64"
+IUSE=""
+
+RDEPEND="
+ >=virtual/jdk-1.8
+ x11-libs/gtk+:2"
+
+S=${WORKDIR}/eclipse
+
+src_install() {
+ local dest=/opt/${PN}-${SLOT}
+
+ insinto ${dest}
+ doins -r features icon.xpm plugins artifacts.xml p2 eclipse.ini configuration dropins
+
+ exeinto ${dest}
+ doexe eclipse
+
+ docinto html
+ dodoc -r readme/*
+
+ cp "${FILESDIR}"/eclipserc-bin-${SLOT} "${T}" || die
+ cp "${FILESDIR}"/eclipse-bin-${SLOT} "${T}" || die
+ sed "s@%SLOT%@${SLOT}@" -i "${T}"/eclipse{,rc}-bin-${SLOT} || die
+
+ insinto /etc
+ newins "${T}"/eclipserc-bin-${SLOT} eclipserc-bin-${SLOT}
+
+ newbin "${T}"/eclipse-bin-${SLOT} eclipse-bin-${SLOT}
+ make_desktop_entry "eclipse-bin-${SLOT}" "Eclipse ${PV} (bin)" "${dest}/icon.xpm"
+}