summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPhilip Miess <Philip_Miess@yahoo.com>2021-06-16 19:27:40 -0400
committerPhilip Miess <Philip_Miess@yahoo.com>2021-06-16 19:27:40 -0400
commita5c4aeb554c7d6917b46dc682577aca94d33ee7b (patch)
tree090f54eb959e0a0bec7f2e808ae1e9522245f5ef
parentmove opendht to supported python versions (diff)
downloadsuperposition-a5c4aeb554c7d6917b46dc682577aca94d33ee7b.tar.gz
superposition-a5c4aeb554c7d6917b46dc682577aca94d33ee7b.tar.bz2
superposition-a5c4aeb554c7d6917b46dc682577aca94d33ee7b.zip
remove python2 0install
Signed-off-by: Philip Miess <Philip_Miess@yahoo.com>
-rw-r--r--sys-apps/0install/0install-2.3.10.ebuild55
-rw-r--r--sys-apps/0install/0install-2.3.11.ebuild55
-rw-r--r--sys-apps/0install/0install-2.3.9.ebuild55
-rw-r--r--sys-apps/0install/Manifest6
4 files changed, 0 insertions, 171 deletions
diff --git a/sys-apps/0install/0install-2.3.10.ebuild b/sys-apps/0install/0install-2.3.10.ebuild
deleted file mode 100644
index 3cdfe4b..0000000
--- a/sys-apps/0install/0install-2.3.10.ebuild
+++ /dev/null
@@ -1,55 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI="7"
-PYTHON_COMPAT=( python3_{6,7} )
-PYTHON_REQ_USE="xml(+)"
-inherit xdg-utils distutils-r1
-
-DESCRIPTION="Zeroinstall Injector allows regular users to install software themselves"
-HOMEPAGE="http://0install.net/"
-SRC_URI="https://sourceforge.net/projects/zero-install/files/${PN}/${PV}/${P}.tar.bz2"
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~ppc ~sparc ~x86"
-RDEPEND="
- $(python_gen_any_dep '
- dev-python/pygobject:3[${PYTHON_USEDEP}]
- ')
- app-crypt/gnupg
-"
-
-python_check_deps() {
- has_version "dev-python/pygobject:3[${PYTHON_USEDEP}]"
-}
-
-python_prepare_all() {
- # Change manpage install path (Bug 207495)
- sed -i 's:man/man1:share/man/man1:' setup.py || die 'Documentation path fix sed failed.'
- distutils-r1_python_prepare_all
-}
-
-python_prepare(){
-[[ ${EPYTHON} == python3_6 ]] && continue
- sed -i 's:def async:def aasync:' zeroinstall/support/async_compat.py || die 'async name sed failed.'
-}
-
-python_install_all() {
- distutils-r1_python_install_all
-
- local BASE_XDG_CONFIG="/etc/xdg/0install.net"
- local BASE_XDG_DATA="/usr/share/0install.net"
-
- insinto "${BASE_XDG_CONFIG}/injector"
- newins "${FILESDIR}/global.cfg" global
-
- dodir "${BASE_XDG_DATA}/native_feeds"
-}
-
-pkg_postinst() {
- xdg_icon_cache_update
-}
-
-pkg_postrm() {
- xdg_icon_cache_update
-}
diff --git a/sys-apps/0install/0install-2.3.11.ebuild b/sys-apps/0install/0install-2.3.11.ebuild
deleted file mode 100644
index 3cdfe4b..0000000
--- a/sys-apps/0install/0install-2.3.11.ebuild
+++ /dev/null
@@ -1,55 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI="7"
-PYTHON_COMPAT=( python3_{6,7} )
-PYTHON_REQ_USE="xml(+)"
-inherit xdg-utils distutils-r1
-
-DESCRIPTION="Zeroinstall Injector allows regular users to install software themselves"
-HOMEPAGE="http://0install.net/"
-SRC_URI="https://sourceforge.net/projects/zero-install/files/${PN}/${PV}/${P}.tar.bz2"
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~ppc ~sparc ~x86"
-RDEPEND="
- $(python_gen_any_dep '
- dev-python/pygobject:3[${PYTHON_USEDEP}]
- ')
- app-crypt/gnupg
-"
-
-python_check_deps() {
- has_version "dev-python/pygobject:3[${PYTHON_USEDEP}]"
-}
-
-python_prepare_all() {
- # Change manpage install path (Bug 207495)
- sed -i 's:man/man1:share/man/man1:' setup.py || die 'Documentation path fix sed failed.'
- distutils-r1_python_prepare_all
-}
-
-python_prepare(){
-[[ ${EPYTHON} == python3_6 ]] && continue
- sed -i 's:def async:def aasync:' zeroinstall/support/async_compat.py || die 'async name sed failed.'
-}
-
-python_install_all() {
- distutils-r1_python_install_all
-
- local BASE_XDG_CONFIG="/etc/xdg/0install.net"
- local BASE_XDG_DATA="/usr/share/0install.net"
-
- insinto "${BASE_XDG_CONFIG}/injector"
- newins "${FILESDIR}/global.cfg" global
-
- dodir "${BASE_XDG_DATA}/native_feeds"
-}
-
-pkg_postinst() {
- xdg_icon_cache_update
-}
-
-pkg_postrm() {
- xdg_icon_cache_update
-}
diff --git a/sys-apps/0install/0install-2.3.9.ebuild b/sys-apps/0install/0install-2.3.9.ebuild
deleted file mode 100644
index 3cdfe4b..0000000
--- a/sys-apps/0install/0install-2.3.9.ebuild
+++ /dev/null
@@ -1,55 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI="7"
-PYTHON_COMPAT=( python3_{6,7} )
-PYTHON_REQ_USE="xml(+)"
-inherit xdg-utils distutils-r1
-
-DESCRIPTION="Zeroinstall Injector allows regular users to install software themselves"
-HOMEPAGE="http://0install.net/"
-SRC_URI="https://sourceforge.net/projects/zero-install/files/${PN}/${PV}/${P}.tar.bz2"
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~ppc ~sparc ~x86"
-RDEPEND="
- $(python_gen_any_dep '
- dev-python/pygobject:3[${PYTHON_USEDEP}]
- ')
- app-crypt/gnupg
-"
-
-python_check_deps() {
- has_version "dev-python/pygobject:3[${PYTHON_USEDEP}]"
-}
-
-python_prepare_all() {
- # Change manpage install path (Bug 207495)
- sed -i 's:man/man1:share/man/man1:' setup.py || die 'Documentation path fix sed failed.'
- distutils-r1_python_prepare_all
-}
-
-python_prepare(){
-[[ ${EPYTHON} == python3_6 ]] && continue
- sed -i 's:def async:def aasync:' zeroinstall/support/async_compat.py || die 'async name sed failed.'
-}
-
-python_install_all() {
- distutils-r1_python_install_all
-
- local BASE_XDG_CONFIG="/etc/xdg/0install.net"
- local BASE_XDG_DATA="/usr/share/0install.net"
-
- insinto "${BASE_XDG_CONFIG}/injector"
- newins "${FILESDIR}/global.cfg" global
-
- dodir "${BASE_XDG_DATA}/native_feeds"
-}
-
-pkg_postinst() {
- xdg_icon_cache_update
-}
-
-pkg_postrm() {
- xdg_icon_cache_update
-}
diff --git a/sys-apps/0install/Manifest b/sys-apps/0install/Manifest
index 32c198e..c71f368 100644
--- a/sys-apps/0install/Manifest
+++ b/sys-apps/0install/Manifest
@@ -3,17 +3,11 @@ AUX global.cfg 0 BLAKE2B 786a02f742015903c6c6fd852552d272912f4740e15847618a86e21
DIST 0install-2.12.3.tar.bz2 445327 BLAKE2B f469aa2a2193f62f42de2595fe505c0df3f297e31b1120648f9e344df49c05d549d2c8ca7a69f2892121f8b0da1416f64f6a8307e2f218db8fc867f629ed8e78 SHA512 d2d0d304675c427af289e51ed553e8eb9c2414d6087b1dcd3261947199bfa3b140348f21bf845ece7342825e524a6551589635d0aafcc9e14233e43b4a6958c4
DIST 0install-2.13.tar.bz2 446022 BLAKE2B d5315b3c50fd6abe950efc2f943aa89c28aa4fe1050b858a197a3344a31af0b9cfb9de789d5431d480a2403bcc424a1eec001578ff7da27279264c92d139db38 SHA512 6f650de62b92597500c4439032076d1a0da621eaf0232dcce2576656889da70d529aef500a67edc13cc0d7f8ad10b1f65ea9483a42f7bdcbeda37c53a4115e8f
DIST 0install-2.15.1.tar.bz2 452954 BLAKE2B 7e678a6156a3b6c273854d21d6ec7347f53d77282ee4a21b19d53806612d26bf58f69b945cfb114ea3d73e17e68b6a5c22163cb4fb431eb0e982a27b5746146f SHA512 e8c19bfe856b6461d4019609c9e6b7a0319e868adbb61ce1688771f8f25e8e8f20ecf8d92fe57a2ffb7607da8ce687214b6df715dd6d2e1d0794dedc9cbef2b2
-DIST 0install-2.3.10.tar.bz2 454157 BLAKE2B 5a1afecd56b037bac803ff80ddfccf2cf79992e64b2d5a5edcc257293f4604cf5f8d4a4920cfba5e45a4253ef38f637cbe67032833ae91976684d01645875e2d SHA512 4f4ef3349143cbd512f4d3726354ff93a71835cd06cee6732cf4784baf4f16fedc04499693acaa70b0f6d204ab4400f1321202e731cb9945d8ed8d4512bf0e03
-DIST 0install-2.3.11.tar.bz2 454146 BLAKE2B 4daca060839b53e519824654b973958546110dc81c7efe99372b2b0bfafe2b938e14630c1bace64ba837a68b544d0eb052994175704ea2a9023073ef3c63285d SHA512 7a0bd613c543fc633b2d9e292a099adcb67dbe474164a36a21dc60eb33959ab6c4ae025572051a4b9726c22fef0774b5176720e90cb7a5a19a90b4a9a61d592e
DIST 0install-2.3.12.tar.bz2 454707 BLAKE2B 153cd2ae516e0ae41fe507d149a41052d19f9438e3f6fe26972ed2a9e71187fb809a7b2ed2eeea93cd6c235266e35a9ad1243c5b68342fd9e8163d870d40365b SHA512 2f01895ca8f26a63d78fd08ef716a63726ab0a9851d786bf90ead9d4b15c29c1ad913c23fa1f56e438493823ab511b8a8ec40ebe5254300bc05be89cce02c662
DIST 0install-2.3.13.tar.bz2 468847 BLAKE2B d896d04c261f3400469f72125981ecbf0a6b58875bc129c78c75c0bcc95fc14873e47453839bef733e80b2180966bbe7134ef9c71548e7d73077b3d2dfac4fa4 SHA512 16b7be4edfa57a395e284af835d2ae4abae9190e37b097fa2b02e49d8ee74e5812faed483b8243c622748ec4b717e9a4932afeda508c8652a0f0c94dbffd9255
-DIST 0install-2.3.9.tar.bz2 453933 BLAKE2B fc497d2d0382df9865ef715367ec43358dc0e8c2b085a64f26ae4e7cb08b34f0cb46846951156e6cb532200535e32df9288e67d6cbb4070afa7bed3990e33cc3 SHA512 3b72662d52aa5e18c78aa3e030d3e0007477a189234adbbc2847f113f98a60c0d48385e4e927538e7d870b3adb8999359368868bf5596b167789f2fcb03463bf
EBUILD 0install-2.12.3.ebuild 1229 BLAKE2B b0c9be063ae6888197979df92c1d7070eb7199eb099eb66f38ccec19127fd49bdb6dbe96e5973e823319c6fd6079186c9345d1c543aa2842d6c429a28fa8d5ce SHA512 e661e6d6ebf0514eff33ac9d1781690539706af7a533510e419902a498ab301374090733a4d79570d6dfabdd968a89b483d61b983286a85b90e6f93e7cf0a900
EBUILD 0install-2.13.ebuild 1221 BLAKE2B 6c5774b05b554c0248f106b4afa620693390eff6b3f9510200ad1030d7f9bf7082f05659e6f1337efed4b18f0bcb839123b749c8e14f6b71c890840acbd24c96 SHA512 8aa752c90cd3ada78810e2be271ed560684bb807a0d1ee3082cab2cf13825edb78f187ced1d17cd462f48d2b11a35b02bc15508cbc7a6a705a8a2300c526e0be
EBUILD 0install-2.15.1.ebuild 1227 BLAKE2B ebb422c919d011975565d752cbdb511cc56761f5ae148f41fa71466fbf1ffd2e1232c6bc16aedc6d9e0203233a14b6094e7308cf8fcf0280ac2a0a58598657ea SHA512 1450c1de317a6525cb6c67b52cc8512b507e440123fe86e58fe874cf2f278ba62d6a32f593abd90f0b285360267c4f98454eec429b80894045e2b4539dbf35e7
-EBUILD 0install-2.3.10.ebuild 1365 BLAKE2B c39938fb5c514f507f10415ccdc0d718a9e8b743a18c23b983eb2e9e7a0aab25cac69046aedeaae8ce824aa1fe347363752e635547f7164e20a1b29c349dc95c SHA512 09b081fc8c5b73975605d3244f214932507e6b6127ab58088c9185ef9ba282d7061e8f03448e7043573b5902f9084b274fac20c4e86a2f40d47bf81f3c8cc685
-EBUILD 0install-2.3.11.ebuild 1365 BLAKE2B c39938fb5c514f507f10415ccdc0d718a9e8b743a18c23b983eb2e9e7a0aab25cac69046aedeaae8ce824aa1fe347363752e635547f7164e20a1b29c349dc95c SHA512 09b081fc8c5b73975605d3244f214932507e6b6127ab58088c9185ef9ba282d7061e8f03448e7043573b5902f9084b274fac20c4e86a2f40d47bf81f3c8cc685
EBUILD 0install-2.3.12.ebuild 1320 BLAKE2B abb2235e3f22891866b491ea71a1be79de9ef517e7f9ca9d0b82d69a57f2fdb684002b7d4192691efc8ac5625cf7bf00087ef636d28c57ed70772f0212437920 SHA512 853dd1663c1a4e79671c8819ebf1b9005d1d7db9ad9c58ed7125ccd0bf49183d252a161de52a3d40b25d573da8ad37c5af06c2f58ab22db1514473522d59eeb3
EBUILD 0install-2.3.13.ebuild 1320 BLAKE2B abb2235e3f22891866b491ea71a1be79de9ef517e7f9ca9d0b82d69a57f2fdb684002b7d4192691efc8ac5625cf7bf00087ef636d28c57ed70772f0212437920 SHA512 853dd1663c1a4e79671c8819ebf1b9005d1d7db9ad9c58ed7125ccd0bf49183d252a161de52a3d40b25d573da8ad37c5af06c2f58ab22db1514473522d59eeb3
-EBUILD 0install-2.3.9.ebuild 1365 BLAKE2B c39938fb5c514f507f10415ccdc0d718a9e8b743a18c23b983eb2e9e7a0aab25cac69046aedeaae8ce824aa1fe347363752e635547f7164e20a1b29c349dc95c SHA512 09b081fc8c5b73975605d3244f214932507e6b6127ab58088c9185ef9ba282d7061e8f03448e7043573b5902f9084b274fac20c4e86a2f40d47bf81f3c8cc685
MISC metadata.xml 285 BLAKE2B 7665ca7b22bf0c8b2e486a5633130588ea83952d863912d0e8299707ed6d26dd66e40e1faa53173eb24079d4607cb783c9e0f6dce8f298607e5baf1ec5f1e587 SHA512 a8207edb781bc25e9bdc7f074ae3164ea9037077c6f6e0284474d033d57ceb188c3e1e9a77a0bbc9c7cac538a75ba23c42993340bd6555b0a71085d43c3f905d