summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRepository mirror & CI <repomirrorci@gentoo.org>2019-02-14 08:37:45 +0000
committerRepository mirror & CI <repomirrorci@gentoo.org>2019-02-14 08:37:45 +0000
commitf5c848852a897d1830df040d7ff0e28e597bc13f (patch)
treef9c51655b70a839c0ac932b1fb8150f339f2695d
parent2019-02-14 07:19:18 UTC (diff)
downloadgentoo-ci-f5c848852a897d1830df040d7ff0e28e597bc13f.tar.gz
gentoo-ci-f5c848852a897d1830df040d7ff0e28e597bc13f.tar.bz2
gentoo-ci-f5c848852a897d1830df040d7ff0e28e597bc13f.zip
2019-02-14 07:55:45 UTC
-rw-r--r--output.xml23
1 files changed, 16 insertions, 7 deletions
diff --git a/output.xml b/output.xml
index 7f290eca8..79280534d 100644
--- a/output.xml
+++ b/output.xml
@@ -70,9 +70,9 @@
<result><category>media-libs</category><package>gegl</package><version>0.4.8-r1</version><class>NonExistentDeps</class><msg>depset depends: nonexistent deps: [ dev-lang/vala:0.38, dev-lang/vala:0.44 ]</msg></result>
<result><category>media-libs</category><package>gegl</package><version>0.4.12</version><class>NonExistentDeps</class><msg>depset depends: nonexistent deps: [ dev-lang/vala:0.38, dev-lang/vala:0.44 ]</msg></result>
<result><category>media-libs</category><package>gegl</package><version>9999</version><class>NonExistentDeps</class><msg>depset depends: nonexistent deps: [ dev-lang/vala:0.38, dev-lang/vala:0.44 ]</msg></result>
+<result><category>media-libs</category><package>gexiv2</package><version>0.10.8</version><class>GLEP73BackAlteration</class><msg>REQUIRED_USE causes a preceding condition to start applying: [test] enforces [python] which may cause preceding [python &amp;&amp; !python_targets_python3_4 &amp;&amp; !python_targets_python3_5 &amp;&amp; !python_targets_python3_6] enforcing [python_targets_python2_7] to evaluate to true</msg></result>
<result><category>media-libs</category><package>gexiv2</package><version>0.10.8</version><class>NonExistentDeps</class><msg>depset depends: nonexistent deps: [ dev-lang/vala:0.38, dev-lang/vala:0.44 ]</msg></result>
<result><category>media-libs</category><package>gexiv2</package><version>0.10.8</version><class>NonExistentDeps</class><msg>depset rdepends: nonexistent deps: [ dev-lang/vala:0.38, dev-lang/vala:0.44 ]</msg></result>
-<result><category>media-libs</category><package>gexiv2</package><version>0.10.8</version><class>GLEP73BackAlteration</class><msg>REQUIRED_USE causes a preceding condition to start applying: [test] enforces [python] which may cause preceding [python &amp;&amp; !python_targets_python3_4 &amp;&amp; !python_targets_python3_5 &amp;&amp; !python_targets_python3_6] enforcing [python_targets_python2_7] to evaluate to true</msg></result>
<result><category>media-libs</category><package>gexiv2</package><version>0.10.10-r1</version><class>GLEP73BackAlteration</class><msg>REQUIRED_USE causes a preceding condition to start applying: [test] enforces [python] which may cause preceding [python &amp;&amp; !python_targets_python3_4 &amp;&amp; !python_targets_python3_5 &amp;&amp; !python_targets_python3_6] enforcing [python_targets_python2_7] to evaluate to true</msg></result>
<result><category>media-libs</category><package>grilo</package><version>0.2.15</version><class>NonExistentDeps</class><msg>depset depends: nonexistent deps: [ dev-lang/vala:0.38, dev-lang/vala:0.44 ]</msg></result>
<result><category>media-libs</category><package>grilo</package><version>0.3.6</version><class>NonExistentDeps</class><msg>depset depends: nonexistent deps: [ dev-lang/vala:0.38, dev-lang/vala:0.44 ]</msg></result>
@@ -91,8 +91,8 @@
<result><category>media-libs</category><package>libcanberra</package><version>0.30-r5</version><class>RequiredUseDefaults</class><msg>failed REQUIRED_USE: contains [alsa]</msg></result>
<result><category>media-libs</category><package>libchamplain</package><version>0.12.16</version><class>NonExistentDeps</class><msg>depset depends: nonexistent deps: [ dev-lang/vala:0.38, dev-lang/vala:0.44 ]</msg></result>
<result><category>media-libs</category><package>libharu</package><class>DirectorySizeViolation</class><msg>files directory exceeds 32k in size; 33.2 KiB total</msg></result>
-<result><category>media-libs</category><package>libmediaart</package><version>1.9.4</version><class>NonExistentDeps</class><msg>depset depends: nonexistent deps: [ dev-lang/vala:0.38, dev-lang/vala:0.44 ]</msg></result>
<result><category>media-libs</category><package>libmediaart</package><version>1.9.4</version><class>RequiredUseDefaults</class><msg>failed REQUIRED_USE: ?? ( contains [gtk] contains [qt5] )</msg></result>
+<result><category>media-libs</category><package>libmediaart</package><version>1.9.4</version><class>NonExistentDeps</class><msg>depset depends: nonexistent deps: [ dev-lang/vala:0.38, dev-lang/vala:0.44 ]</msg></result>
<result><category>media-libs</category><package>libmetalink</package><version>0.1.1-r1</version><class>RequiredUseDefaults</class><msg>failed REQUIRED_USE: ^^ ( contains [expat] contains [xml] )</msg></result>
<result><category>media-libs</category><package>libmetalink</package><version>0.1.3</version><class>RequiredUseDefaults</class><msg>failed REQUIRED_USE: ^^ ( contains [expat] contains [xml] )</msg></result>
<result><category>media-libs</category><package>libpano13</package><version>2.9.19</version><class>MissingSlotDep</class><msg>'&gt;=virtual/jdk-1.3' matches more than one slot: [ 1.8, 11 ]</msg></result>
@@ -133,8 +133,8 @@
<result><category>media-libs</category><package>spandsp</package><version>0.0.6</version><class>MissingSlotDep</class><msg>'media-libs/tiff' matches more than one slot: [ 0, 3 ]</msg></result>
<result><category>media-libs</category><package>tiff</package><version>3.9.7-r1</version><class>VulnerablePackage</class><msg>vulnerable via glsa(201709-27) ( ( ver &lt; 4.0.8 ) &amp;&amp; not ( ver &gt;= 4.0.8 ) ), keywords: alpha, amd64, amd64-linux, arm, arm64, hppa, ia64, m68k, mips, ppc, ppc-macos, ppc64, s390, sh, sparc, sparc-solaris, x64-macos, x64-solaris, x86, x86-fbsd, x86-linux, x86-macos, x86-solaris</msg></result>
<result><category>media-libs</category><package>tiff</package><version>3.9.7-r1</version><class>VulnerablePackage</class><msg>vulnerable via glsa(201701-16) ( ( ver &lt; 4.0.7 ) &amp;&amp; not ( ver &gt;= 4.0.7 ) ), keywords: alpha, amd64, amd64-linux, arm, arm64, hppa, ia64, m68k, mips, ppc, ppc-macos, ppc64, s390, sh, sparc, sparc-solaris, x64-macos, x64-solaris, x86, x86-fbsd, x86-linux, x86-macos, x86-solaris</msg></result>
-<result><category>media-libs</category><package>tiff</package><class>DirectorySizeViolation</class><msg>files directory exceeds 32k in size; 35.1 KiB total</msg></result>
<result><category>media-libs</category><package>tiff</package><version>4.0.10</version><class>DroppedKeywords</class><msg>amd64-fbsd</msg></result>
+<result><category>media-libs</category><package>tiff</package><class>DirectorySizeViolation</class><msg>files directory exceeds 32k in size; 35.1 KiB total</msg></result>
<result><category>media-libs</category><package>urt</package><version>3.1b-r1</version><class>MissingSlotDep</class><msg>'media-libs/tiff' matches more than one slot: [ 0, 3 ]</msg></result>
<result><category>media-libs</category><package>vigra</package><version>1.11.0</version><class>GLEP73BackAlteration</class><msg>REQUIRED_USE causes a preceding condition to start applying: [test] enforces [python] which may cause preceding [python] enforcing [python_targets_python2_7] to evaluate to true</msg></result>
<result><category>media-libs</category><package>vigra</package><version>1.11.1</version><class>GLEP73BackAlteration</class><msg>REQUIRED_USE causes a preceding condition to start applying: [test] enforces [python] which may cause preceding [python] enforcing [python_targets_python2_7] to evaluate to true</msg></result>
@@ -451,6 +451,7 @@
<result><category>sys-process</category><package>unixtop</package><version>3.8_beta1-r3</version><class>MissingSlotDep</class><msg>'sys-libs/ncurses' matches more than one slot: [ 0, 5 ]</msg></result>
<result><category>app-admin</category><package>aerospike-amc-community</package><version>3.6.13-r2</version><class>BadInsIntoDir</class><msg>ebuild uses insinto /etc/cron.daily on line 45</msg></result>
<result><category>app-admin</category><package>ansible-lint</package><version>4.0.1</version><class>DroppedKeywords</class><msg>x86</msg></result>
+<result><category>app-admin</category><package>eclean-kernel</package><version>1.99.4</version><class>DroppedKeywords</class><msg>x86-fbsd</msg></result>
<result><category>app-admin</category><package>mcelog</package><version>161</version><class>BadInsIntoDir</class><msg>ebuild uses insinto /etc/cron.daily on line 40</msg></result>
<result><category>app-admin</category><package>mcelog</package><version>162</version><class>BadInsIntoDir</class><msg>ebuild uses insinto /etc/cron.daily on line 40</msg></result>
<result><category>app-admin</category><package>mms-agent</package><version>6.0.0.381_p1</version><class>DroppedKeywords</class><msg>x86</msg></result>
@@ -461,6 +462,7 @@
<result><category>app-admin</category><package>rsyslog</package><version>8.1901.0</version><class>RequiredUseDefaults</class><msg>failed REQUIRED_USE: ( contains [gnutls] || contains [openssl] )</msg></result>
<result><category>app-admin</category><package>salt</package><class>DuplicateFiles</class><msg>duplicate identical files in FILESDIR: 'files/api-confd-1', 'files/master-confd-1'</msg></result>
<result><category>app-admin</category><package>salt</package><class>DuplicateFiles</class><msg>duplicate identical files in FILESDIR: 'files/minion-confd-1', 'files/syndic-confd-1'</msg></result>
+<result><category>app-admin</category><package>syslog-ng</package><version>3.19.1</version><class>DroppedKeywords</class><msg>mips, sh, x86-fbsd</msg></result>
<result><category>app-admin</category><package>syslog-ng</package><class>DirectorySizeViolation</class><msg>files directory exceeds 32k in size; 49.5 KiB total</msg></result>
<result><category>app-admin</category><package>syslog-ng</package><class>DuplicateFiles</class><msg>duplicate identical files in FILESDIR: 'files/3.13/syslog-ng.confd', 'files/3.7/syslog-ng.confd'</msg></result>
<result><category>app-admin</category><package>syslog-ng</package><class>DuplicateFiles</class><msg>duplicate identical files in FILESDIR: 'files/3.14/syslog-ng.confd', 'files/syslog-ng.confd'</msg></result>
@@ -480,7 +482,8 @@
<result><category>games-action</category><package>descent3-demo</package><version>1.4.0a-r1</version><class>RequiredUseDefaults</class><msg>failed REQUIRED_USE: ?? ( contains [alsa] contains [pulseaudio] )</msg></result>
<result><category>games-action</category><package>openclonk</package><version>7.0</version><class>MissingSlotDep</class><msg>'net-libs/libupnp' matches more than one slot: [ 0, 1.8 ]</msg></result>
<result><category>games-action</category><package>openclonk</package><version>7.0</version><class>MissingSlotDep</class><msg>'media-libs/glew' matches more than one slot: [ 0, 1.10, 1.6 ]</msg></result>
-<result><category>media-fonts</category><package>wqy-microhei</package><version>0.2.0_beta-r1</version><class>DroppedKeywords</class><msg>arm</msg></result>
+<result><category>media-fonts</category><package>wqy-microhei</package><version>0.2.0_beta-r1</version><class>DroppedKeywords</class><msg>arm, arm64</msg></result>
+<result><category>net-firewall</category><package>firewalld</package><version>0.6.3</version><class>DroppedKeywords</class><msg>arm64</msg></result>
<result><category>net-firewall</category><package>fwknop</package><version>2.6.9-r1</version><class>GLEP73BackAlteration</class><msg>REQUIRED_USE causes a preceding condition to start applying: [udp-server] enforces [server] which may cause preceding [server &amp;&amp; iptables] enforcing [!firewalld] to evaluate to true</msg></result>
<result><category>net-firewall</category><package>iptables</package><class>ExecutableFile</class><msg>unnecessary executable bit: 'files/iptables-r2.init'</msg></result>
<result><category>net-firewall</category><package>iptables</package><class>ExecutableFile</class><msg>unnecessary executable bit: 'files/iptables.init'</msg></result>
@@ -490,9 +493,9 @@
<result><category>net-fs</category><package>ncpfs</package><version>2.2.6-r3</version><class>MissingSlotDep</class><msg>'dev-lang/php' matches more than one slot: [ 5.6, 7.1, 7.2, 7.3 ]</msg></result>
<result><category>net-fs</category><package>ncpfs</package><version>2.2.6-r3</version><class>MissingSlotDep</class><msg>'virtual/httpd-php' matches more than one slot: [ 5.6, 7.1, 7.2, 7.3 ]</msg></result>
<result><category>net-fs</category><package>ncpfs</package><class>DirectorySizeViolation</class><msg>files directory exceeds 32k in size; 50.0 KiB total</msg></result>
-<result><category>net-fs</category><package>s3fs</package><version>1.80</version><class>MissingSlotDep</class><msg>'&gt;=sys-fs/fuse-2.8.4' matches more than one slot: [ 0, 3 ]</msg></result>
<result><category>net-fs</category><package>s3fs</package><version>1.80</version><class>RequiredUseDefaults</class><msg>failed REQUIRED_USE: ^^ ( contains [openssl] contains [nss] contains [gnutls] )</msg></result>
<result><category>net-fs</category><package>s3fs</package><version>1.80</version><class>GLEP73Conflict</class><msg>REQUIRED_USE can request conflicting states: [nss] requires [!gnutls] while [nettle] requires [gnutls]</msg></result>
+<result><category>net-fs</category><package>s3fs</package><version>1.80</version><class>MissingSlotDep</class><msg>'&gt;=sys-fs/fuse-2.8.4' matches more than one slot: [ 0, 3 ]</msg></result>
<result><category>net-fs</category><package>s3fs</package><version>1.83</version><class>RequiredUseDefaults</class><msg>failed REQUIRED_USE: ^^ ( contains [openssl] contains [nss] contains [gnutls] )</msg></result>
<result><category>net-fs</category><package>s3fs</package><version>1.83</version><class>GLEP73Conflict</class><msg>REQUIRED_USE can request conflicting states: [nss] requires [!gnutls] while [nettle] requires [gnutls]</msg></result>
<result><category>net-fs</category><package>samba</package><version>4.5.16</version><class>GLEP73BackAlteration</class><msg>REQUIRED_USE causes a preceding condition to start applying: [cluster] enforces [ads] which may cause preceding [ads] enforcing [ldap] to evaluate to true</msg></result>
@@ -504,7 +507,7 @@
<result><category>net-fs</category><package>samba</package><version>4.9.4-r1</version><class>GLEP73BackAlteration</class><msg>REQUIRED_USE causes a preceding condition to start applying: [cluster] enforces [ads] which may cause preceding [ads] enforcing [winbind] to evaluate to true</msg></result>
<result><category>net-fs</category><package>samba</package><version>4.10.0_rc2</version><class>UncheckableDep</class><msg>depset depends: could not be checked due to pkgcore limitation</msg></result>
<result><category>net-fs</category><package>samba</package><version>4.10.0_rc2</version><class>UncheckableDep</class><msg>depset rdepends: could not be checked due to pkgcore limitation</msg></result>
-<result><category>net-fs</category><package>samba</package><version>4.10.0_rc2</version><class>DroppedKeywords</class><msg>alpha, amd64, arm, ia64, ppc, ppc64, x86</msg></result>
+<result><category>net-fs</category><package>samba</package><version>4.10.0_rc2</version><class>DroppedKeywords</class><msg>alpha, amd64, arm, arm64, hppa, ia64, ppc, ppc64, sparc, x86</msg></result>
<result><category>net-fs</category><package>smbnetfs</package><version>0.6.0-r1</version><class>MissingSlotDep</class><msg>'&gt;=sys-fs/fuse-2.3' matches more than one slot: [ 0, 3 ]</msg></result>
<result><category>net-fs</category><package>smbnetfs</package><version>0.6.1</version><class>MissingSlotDep</class><msg>'&gt;=sys-fs/fuse-2.3' matches more than one slot: [ 0, 3 ]</msg></result>
<result><category>net-fs</category><package>wdfs</package><version>1.4.2-r1</version><class>MissingSlotDep</class><msg>'&gt;=sys-fs/fuse-2.5' matches more than one slot: [ 0, 3 ]</msg></result>
@@ -513,7 +516,8 @@
<result><category>sci-mathematics</category><package>nusmv</package><version>2.6.0</version><class>RequiredUseDefaults</class><msg>failed REQUIRED_USE: ( contains [minisat] || contains [zchaff] )</msg></result>
<result><category>sci-mathematics</category><package>rstudio</package><class>SizeViolation</class><msg>"files/rstudio-1.1.463-boost-1.69.0_p1.patch" exceeds 20k in size; 26.5 KiB total</msg></result>
<result><category>sci-mathematics</category><package>rstudio</package><class>DirectorySizeViolation</class><msg>files directory exceeds 32k in size; 60.5 KiB total</msg></result>
-<result><category>sys-cluster</category><package>ceph</package><version>13.2.4</version><class>DroppedKeywords</class><msg>arm, ppc, ppc64</msg></result>
+<result><category>sci-mathematics</category><package>singular</package><version>4.0.3</version><class>DroppedKeywords</class><msg>amd64-linux, ppc-macos, x64-macos</msg></result>
+<result><category>sys-cluster</category><package>ceph</package><version>13.2.4</version><class>DroppedKeywords</class><msg>arm, arm64, ppc, ppc64</msg></result>
<result><category>sys-cluster</category><package>ceph</package><class>DirectorySizeViolation</class><msg>files directory exceeds 32k in size; 88.9 KiB total</msg></result>
<result><category>sys-cluster</category><package>ceph</package><class>DuplicateFiles</class><msg>duplicate identical files in FILESDIR: 'files/ceph.logrotate', 'files/ceph.logrotate-r1'</msg></result>
<result><category>sys-cluster</category><package>cinder</package><version>11.1.1</version><class>RequiredUseDefaults</class><msg>failed REQUIRED_USE: ( contains [mysql] || contains [postgres] || contains [sqlite] )</msg></result>
@@ -521,6 +525,7 @@
<result><category>sys-cluster</category><package>cinder</package><version>12.0.5</version><class>RequiredUseDefaults</class><msg>failed REQUIRED_USE: ( contains [mysql] || contains [postgres] || contains [sqlite] )</msg></result>
<result><category>sys-cluster</category><package>cinder</package><version>13.0.2</version><class>RequiredUseDefaults</class><msg>failed REQUIRED_USE: ( contains [mysql] || contains [postgres] || contains [sqlite] )</msg></result>
<result><category>sys-cluster</category><package>cinder</package><version>13.0.3</version><class>RequiredUseDefaults</class><msg>failed REQUIRED_USE: ( contains [mysql] || contains [postgres] || contains [sqlite] )</msg></result>
+<result><category>sys-cluster</category><package>corosync</package><version>2.4.2</version><class>DroppedKeywords</class><msg>x86-fbsd</msg></result>
<result><category>sys-cluster</category><package>csync2</package><version>2.0</version><class>RequiredUseDefaults</class><msg>failed REQUIRED_USE: ( contains [mysql] || contains [postgres] || contains [sqlite] )</msg></result>
<result><category>sys-cluster</category><package>csync2</package><version>2.0-r1</version><class>RequiredUseDefaults</class><msg>failed REQUIRED_USE: ( contains [mysql] || contains [postgres] || contains [sqlite] )</msg></result>
<result><category>sys-cluster</category><package>heat</package><version>9.0.5</version><class>RequiredUseDefaults</class><msg>failed REQUIRED_USE: ( contains [mysql] || contains [postgres] || contains [sqlite] )</msg></result>
@@ -552,7 +557,10 @@
<result><category>x11-libs</category><package>colord-gtk</package><version>0.1.26</version><class>NonExistentDeps</class><msg>depset depends: nonexistent deps: [ dev-lang/vala:0.38, dev-lang/vala:0.44 ]</msg></result>
<result><category>x11-libs</category><package>fltk</package><class>DuplicateFiles</class><msg>duplicate identical files in FILESDIR: 'files/fltk-1.3.4-conf-tests.patch', 'files/fltk-1.3.9999-conf-tests.patch'</msg></result>
<result><category>x11-libs</category><package>fox</package><version>1.7.54</version><class>MissingSlotDep</class><msg>'&gt;=sys-devel/autoconf-2.67' matches more than one slot: [ 2.69, 9999 ]</msg></result>
+<result><category>x11-libs</category><package>fox</package><version>1.7.54</version><class>DroppedKeywords</class><msg>x86-fbsd</msg></result>
+<result><category>x11-libs</category><package>goocanvas</package><version>2.0.4</version><class>DroppedKeywords</class><msg>amd64-linux, x86-linux</msg></result>
<result><category>x11-libs</category><package>gtef</package><version>2.0.1</version><class>NonExistentDeps</class><msg>depset depends: nonexistent deps: [ dev-lang/vala:0.38, dev-lang/vala:0.44 ]</msg></result>
+<result><category>x11-libs</category><package>gtk+</package><version>3.24.5</version><class>DroppedKeywords</class><msg>x64-macos</msg></result>
<result><category>x11-libs</category><package>gtksourceview</package><version>3.24.8</version><class>NonExistentDeps</class><msg>depset depends: nonexistent deps: [ dev-lang/vala:0.38, dev-lang/vala:0.44 ]</msg></result>
<result><category>x11-libs</category><package>gtksourceview</package><version>3.24.9</version><class>NonExistentDeps</class><msg>depset depends: nonexistent deps: [ dev-lang/vala:0.38, dev-lang/vala:0.44 ]</msg></result>
<result><category>x11-libs</category><package>gtksourceview</package><version>4.0.3</version><class>NonExistentDeps</class><msg>depset depends: nonexistent deps: [ dev-lang/vala:0.38, dev-lang/vala:0.44 ]</msg></result>
@@ -563,6 +571,7 @@
<result><category>x11-libs</category><package>pango</package><version>1.40.14-r1</version><class>VulnerablePackage</class><msg>vulnerable via glsa(201811-07) ( ( ver &lt; 1.42.4 ) &amp;&amp; not ( ver &gt;= 1.42.4 ) ), keywords: alpha, amd64, amd64-fbsd, amd64-linux, arm, arm64, hppa, ia64, mips, ppc, ppc-macos, ppc64, s390, sh, sparc, sparc-solaris, x64-macos, x64-solaris, x86, x86-fbsd, x86-linux, x86-macos, x86-solaris</msg></result>
<result><category>x11-libs</category><package>vte</package><version>0.48.4</version><class>NonExistentDeps</class><msg>depset depends: nonexistent deps: [ dev-lang/vala:0.38, dev-lang/vala:0.44 ]</msg></result>
<result><category>x11-libs</category><package>vte</package><version>0.54.1</version><class>NonExistentDeps</class><msg>depset depends: nonexistent deps: [ dev-lang/vala:0.38, dev-lang/vala:0.44 ]</msg></result>
+<result><category>x11-libs</category><package>wxGTK</package><version>3.0.4-r301</version><class>DroppedKeywords</class><msg>arm64</msg></result>
<result><category>x11-libs</category><package>xapps</package><version>1.4.2</version><class>NonExistentDeps</class><msg>depset depends: nonexistent deps: [ dev-lang/vala:0.38, dev-lang/vala:0.44 ]</msg></result>
<result><category>app-accessibility</category><package>freetts</package><version>1.2.2</version><class>MissingSlotDep</class><msg>'&gt;=virtual/jre-1.4' matches more than one slot: [ 1.8, 11 ]</msg></result>
<result><category>app-accessibility</category><package>julius</package><version>4.2.2</version><class>RequiredUseDefaults</class><msg>failed REQUIRED_USE: ^^ ( contains [alsa] contains [oss] contains [portaudio] contains [pulseaudio] )</msg></result>