summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'decisions/summary-20130409.tex')
-rw-r--r--decisions/summary-20130409.tex70
1 files changed, 70 insertions, 0 deletions
diff --git a/decisions/summary-20130409.tex b/decisions/summary-20130409.tex
new file mode 100644
index 0000000..36a3701
--- /dev/null
+++ b/decisions/summary-20130409.tex
@@ -0,0 +1,70 @@
+
+\summary{2013}{4}{9}
+
+\agendaitem{Change to newer Bash version in ebuilds}
+\index{bash}\index{EAPI!6}
+
+References:
+\begin{itemize}
+\item
+\agoref{gentoo-project}{03abd30d8945aa816e39b48fab8a9a62}
+\item
+\bug{431340}
+\end{itemize}
+
+Several options were discussed:
+\begin{itemize}
+\item Change of bash version to 4.2 could be a regular item for EAPI 6.
+\item The bash update could be put into its own EAPI, to appear at least
+ one year after the date (2012-07-01) of EAPI parsing being supported
+ by stable portage.
+\item Updating the bash version could be a problem for bootstrapping on
+ some Prefix architectures (e.g., Solaris). According to grobian, it
+ should be possible to handle the issue.
+\end{itemize}
+No action is taken for now.
+
+\agendaitem{EAPI deprecation}
+\index{EAPI!deprecation}\index{EAPI!0}\index{EAPI!1}\index{EAPI!2}
+
+Reference: \agoref{gentoo-project}{9db8a88aed9d35a4cf629228564bf127}
+
+In the discussion, there was neither consensus if EAPI 0 should be
+considered deprecated, nor what should be the oldest EAPI that still
+needs to be supported for the upgrade path of users' system.
+
+Three votes were taken:
+\vote{EAPIs 0 to 2 are no longer required for the upgrade path of users'
+ systems.}{Accepted unanimously.}
+\vote{EAPIs 1 and 2 are discouraged. Repoman should warn about this.}{
+ Accepted unanimously.}
+\vote{Change wording in the first question from "0 to 2" to "0 to 3".}{
+ Tie vote (3 yes, 3 no), therefore the motion did not pass.}
+
+\agendaitem{Open bugs with council involvement}
+
+\begin{itemize}
+\item \bug{457000}:
+ No progress since last meeting.
+\item \bug{464250}:
+ Accepted in 2011-03-08 meeting, but not in the devmanual yet.
+ Action: grobian will prepare a patch.
+\item \bug{447566}:
+ Short status update from Zero\_Chaos. Discussion will be per e-mail.
+\end{itemize}
+
+\agendaitem{Open floor}
+\index{GSOC}\index{subslots}\index{slot operators}
+
+\begin{itemize}
+\item
+Q: Was the dodocs/edocs proposal, \bug{459692}, voted upon?
+A: There was no vote on any EAPI 6 features yet.
+\item
+Gentoo participates in the Google Summer of Code, for the 8th year.
+\item
+Further discussion about EAPI deprecation.
+\item
+Sub-slots and slot operators are overused, and used in the wrong way
+ in some packages, in spite of the feature being well documented.
+\end{itemize}