summaryrefslogtreecommitdiff
blob: 020f14a0a27a42cbd201eca600406087ec624540 (plain)
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
61
62
63
64
65
66
67
68
69
70
71
72
73
74
75
76
77
78
79
80
81
82
83
84
\summary{2009}{4}{23}


\agendaitem{Portage changing behaviour without EAPI bumps}
\index{portage}\index{PMS}

        David Leverton(dleverton) requested that the council mandate that portage
        is not allowed to change behaviour that is specified in PMS, as has
        occurred a few times in the past.

        Conclusion:
            The council decided that if PMS-conflicting changes occur in
            package managers then the council can mandate that versions that
            conflict will be masked. The council may take into account
	    extenuating circumstances.

\agendaitem{EAPI 3}
\index{EAPI!3}

        EAPI 3's features have been finalized and its final approval is
        pending portage support for the most important features. Some less
	critical features may be removed if they cannot be accomplished in
	a reasonable timeframe and are holding up the introduction of the
	critical features. This summary of features lists only those features
	discussed on the April 23 meeting of the Gentoo Council.

\begin{itemize}
 \item 
 New utility functions: 
'Doexample'/'Doinclude'\index{doexample}\index{doinclude}
            Some council members believed that adding these utility functions
            would complicate things for new ebuild authors while not providing
            any especially needed features.

            Conclusion:
                Voted to not be included in EAPI 3.
 \item
 Ban $\vert\vert$ ( use? ( ... ) ... ) \index{$\vert\vert$ 
 dependencies}\index{dependencies!$\vert\vert$}

            Mart Raudsepp(leio) argued that banning such constructs is
            strictly a QA issue and shouldn't be covered by PMS, while others
            argued that there are no valid use cases for the construct and
            that you need appropriate rules to parse RDEPEND/DEPEND.

            Conclusion:
                It was decided that a repoman warning would be most
                appropriate for this case and that the topic of banning it in
                an EAPI can be revisited for EAPI 4.
 \item
 Ban 'dohard'\index{dohard}

            Currently dohard cannot be guaranteed to work across filesystems
            and few packages use it.

            Conclusion:
                Voted to be banned in EAPI 3.
 \item
 New econf options,
          '--disable-dependency-tracking' / '--enable-fast-install'
 \index{disable-dependency-tracking}\index{enable-fast-install}

            The addition of '--enable-fast-install' was opposed because it is
            already a libtool default and as such is useless. No arguments
            were made against '--disable-dependency-tracking'.

            Conclusion:
                '--disable-dependency-tracking' was voted in, while
                '--enable-fast-install' was voted out.
 \item
 Add --if-compressed option to unpack(). \index{if-compressed} \index{unpack}
            
            Conclusion:
                Voted to be not included in EAPI 3.

 \item
 Slot Operator Dependencies(:= and :*) \index{slot operators}
 \index{dependencies!:=}\index{dependencies!:*}
            
            Conclusion:
                 Voted to be included in EAPI 3. Mart Raudsepp has remaining
                 queries about the final syntax.
\end{itemize}