summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDustin Polke <DuPol@gmx.de>2017-02-01 21:46:57 +0100
committerDustin Polke <DuPol@gmx.de>2017-02-01 21:47:03 +0100
commit7e0f1941387584362a8220e8b465a207b647f085 (patch)
tree263ef4acc278f28599294e755583aa972f3d83b7
parent[x11-plugins/cd-plugins-good] Drop old CMakeLists.txt. (diff)
downloadDuPol-7e0f1941387584362a8220e8b465a207b647f085.tar.gz
DuPol-7e0f1941387584362a8220e8b465a207b647f085.tar.bz2
DuPol-7e0f1941387584362a8220e8b465a207b647f085.zip
[x11-plugins/cd-plugins-stable] Drop old CMakeLists.txt.
-rw-r--r--x11-plugins/cd-plugins-stable/ChangeLog4
-rw-r--r--x11-plugins/cd-plugins-stable/files/cd-plugins-stable-3.0.0-CMakeLists.txt503
2 files changed, 4 insertions, 503 deletions
diff --git a/x11-plugins/cd-plugins-stable/ChangeLog b/x11-plugins/cd-plugins-stable/ChangeLog
index 715873f..1761196 100644
--- a/x11-plugins/cd-plugins-stable/ChangeLog
+++ b/x11-plugins/cd-plugins-stable/ChangeLog
@@ -2,6 +2,10 @@
# Copyright 1999-2017 Gentoo Foundation; Distributed under the GPL v2
# $Header: $
+ 01 Feb 2017; Dustin Polke <DuPol@gmx.de>
+ -files/cd-plugins-stable-3.0.0-CMakeLists.txt:
+ Drop old CMakeLists.txt.
+
01 Feb 2017; Dustin Polke <DuPol@gmx.de> metadata.xml:
Silence repoman complaint about metadata.
diff --git a/x11-plugins/cd-plugins-stable/files/cd-plugins-stable-3.0.0-CMakeLists.txt b/x11-plugins/cd-plugins-stable/files/cd-plugins-stable-3.0.0-CMakeLists.txt
deleted file mode 100644
index 6606bb0..0000000
--- a/x11-plugins/cd-plugins-stable/files/cd-plugins-stable-3.0.0-CMakeLists.txt
+++ /dev/null
@@ -1,503 +0,0 @@
-########### requirements ###############
-
-cmake_minimum_required (VERSION 2.6)
-find_package (PkgConfig)
-include (CheckLibraryExists)
-include (CheckIncludeFiles)
-include (CheckFunctionExists)
-include (CheckSymbolExists)
-include ("${CMAKE_CURRENT_SOURCE_DIR}/cmake_modules/GNUInstallDirs.cmake")
-
-########### project ###############
-
-project ("cairo-dock-plugins")
-set (VERSION "3.0.0")
-
-add_definitions (-std=c99 -Wextra -Wwrite-strings -Wuninitialized -Werror-implicit-function-declaration -Wstrict-prototypes) # removed for stable versions: -Wstrict-prototypes #-Wunreachable-code -Wno-unused-parameter -Wall
-add_definitions (-DGL_GLEXT_PROTOTYPES="1")
-
-############ sources tarball #############
-
-set (CPACK_SOURCE_GENERATOR "TGZ")
-set (CPACK_SOURCE_PACKAGE_FILE_NAME "${CMAKE_PROJECT_NAME}-${VERSION}")
-set (CPACK_SOURCE_IGNORE_FILES
- "/build/;/.bzr/;bzrignore$;/misc/;~$;${CPACK_SOURCE_IGNORE_FILES}")
-include (CPack)
-
-add_custom_target(dist
- COMMAND ${CMAKE_MAKE_PROGRAM} package_source)
-add_custom_target(dist-bzr
- COMMAND bzr export ${CMAKE_PROJECT_NAME}-${VERSION}.tar.gz
- WORKING_DIRECTORY ${CMAKE_SOURCE_DIR})
-
-########### global variables ###############
-
-if( WIN32 )
- message(FATAL_ERROR "Cairo-Dock requires an air-conditioned room. Please close Windows!")
-endif( WIN32 )
-
-set (PACKAGE ${CMAKE_PROJECT_NAME})
-set (GETTEXT_PACKAGE ${PACKAGE})
-
-# get plug-ins install dir
-execute_process(
- COMMAND pkg-config gldi --variable=pluginsdir # /usr/lib/cairo-dock # or /usr/lib/x86_64-linux-gnu/cairo-dock
- OUTPUT_VARIABLE pluginsdir)
-STRING (REGEX REPLACE "\n" "" pluginsdir ${pluginsdir}) # remove the \n
-# get plug-ins data dir
-execute_process(
- COMMAND pkg-config gldi --variable=pluginsdatadir # /usr/share/cairo-dock/plug-ins
- OUTPUT_VARIABLE pluginsdatadir)
-STRING (REGEX REPLACE "\n" "" pluginsdatadir ${pluginsdatadir})
-# get prefix dir
-execute_process(
- COMMAND pkg-config gldi --variable=prefix # /usr/share/cairo-dock/plug-ins
- OUTPUT_VARIABLE prefix)
-STRING (REGEX REPLACE "\n" "" prefix ${prefix})
-# get GTK version (must be the same as the core, as GTK2 and GTK3 can't coexist at runtime)
-execute_process(
- COMMAND pkg-config gldi --variable=gtkversion # 2 or 3
- OUTPUT_VARIABLE gtkversion)
-STRING (REGEX REPLACE "\n" "" gtkversion ${gtkversion})
-# check that version matches with the core
-execute_process(
- COMMAND pkg-config --modversion gldi # 2.2.0-3
- OUTPUT_VARIABLE dock_version)
-STRING (REGEX REPLACE "\n" "" dock_version ${dock_version})
-if (NOT "${dock_version}" STREQUAL "${VERSION}") # Version
- if ("${PACKAGEMENT}" STREQUAL "")
- MESSAGE (FATAL_ERROR "Error : version mismatch with the core : " ${VERSION} <> ${dock_version})
- else ()
- MESSAGE (WARNING "Warning : version mismatch with the core : " ${VERSION} <> ${dock_version})
- endif ()
-endif()
-
-# check that installation dir matches with the core
-GET_FILENAME_COMPONENT(libdir "${pluginsdir}/.." ABSOLUTE) # /usr/lib # or /usr/lib/x86_64-linux-gnu
-GET_FILENAME_COMPONENT(datadir "${pluginsdatadir}/../.." ABSOLUTE) # /usr/share
-if (NOT "${CMAKE_INSTALL_PREFIX}" STREQUAL "${prefix}"
- OR NOT "${CMAKE_INSTALL_PREFIX}/${CMAKE_INSTALL_LIBDIR}" STREQUAL "${libdir}"
- OR NOT "${CMAKE_INSTALL_PREFIX}/${CMAKE_INSTALL_DATAROOTDIR}" STREQUAL "${datadir}")
- message (STATUS "It seems that the current CMAKE_INSTALL_{PREFIX,LIBDIR,DATAROOTDIR} flags are not the same that you have used with the core.")
- message (STATUS " It will be replaced by this value: ${prefix}")
- message (WARNING "Plug-ins should be installed in the same directory as the core, that is to say in ${pluginsdir}")
- set (CMAKE_INSTALL_PREFIX "${prefix}")
- #set (libdir "${CMAKE_INSTALL_PREFIX}/${libname}/cairo-dock")
-endif()
-
-# set internationalisation
-set (GETTEXT_PLUGINS "cairo-dock-plugins")
-set (localedir "${prefix}/${CMAKE_INSTALL_LOCALEDIR}")
-set (gaugesdir "${datadir}/cairo-dock/gauges")
-
-set(CMAKE_MODULE_PATH "${CMAKE_SOURCE_DIR}/cmake_modules/") # additionnal FindPackage files
-
-########### dependencies ###############
-
-message ("")
-message (STATUS "=====================")
-message (STATUS "Check dependencies...")
-message (STATUS "=====================")
-message ("")
-
-pkg_check_modules ("PACKAGE" REQUIRED "cairo" "librsvg-2.0" "dbus-1" "dbus-glib-1" "libxml-2.0")
-#pkg_check_modules ("PACKAGE" REQUIRED "ig")
-pkg_check_modules ("GLDI" REQUIRED "gldi") # we don't want to link with gldi, so we check it separately.
-set (PACKAGE_INCLUDE_DIRS "${GLDI_INCLUDE_DIRS}")
-
-add_definitions (-DGTK_DISABLE_DEPRECATED="1")
-
-############# GLIB #################
-pkg_check_modules (GLIB glib-2.0)
- STRING (REGEX REPLACE "\\..*" "" GLIB_MAJOR "${GLIB_VERSION}") # 2.28.3 => 2
- STRING (REGEX REPLACE "[0-9]*\\.([^ ]+)" "\\1" GLIB_MINOR "${GLIB_VERSION}") # 2.28.3 => 2.28
- STRING (REGEX REPLACE "\\.[0-9]*" "" GLIB_MINOR "${GLIB_MINOR}") # 2.28 => 28
- STRING (REGEX REPLACE ".*\\." "" GLIB_NANO "${GLIB_VERSION}") # 2.28.3 => 3
- STRING (REGEX REPLACE "-.*" "" GLIB_NANO "${GLIB_NANO}")
-
-############# ALSA_MIXER #################
-if (ENABLE_ALSA-MIXER-PLUGIN)
- message (STATUS "> AlsaMixer:")
- pkg_check_modules ("ALSA_MIXER_PACKAGE" REQUIRED "alsa")
- set (GETTEXT_ALSA_MIXER ${GETTEXT_PLUGINS})
- set (VERSION_ALSA_MIXER "2.0.0")
- set (PACKAGE_ALSA_MIXER "cd-AlsaMixer")
- set (with_alsa "yes")
- set (alsa_mixerdatadir "${pluginsdatadir}/AlsaMixer")
- configure_file (${CMAKE_CURRENT_SOURCE_DIR}/alsaMixer/data/AlsaMixer.conf.in ${CMAKE_CURRENT_BINARY_DIR}/alsaMixer/data/AlsaMixer.conf)
- add_subdirectory ("alsaMixer")
-else()
- set (with_alsa "no")
-endif()
-
-############# CAIRO_PENGUIN #################
-if (ENABLE_CAIRO-PENGUIN-PLUGIN)
- message (STATUS "> Cairo Penguin:")
- set (GETTEXT_CAIRO_PENGUIN ${GETTEXT_PLUGINS})
- set (VERSION_CAIRO_PENGUIN "1.1.10")
- set (PACKAGE_CAIRO_PENGUIN "cd-Cairo-Penguin")
- set (cairo_penguinuserdirname "Cairo-Penguin")
- set (cairo_penguindatadir "${pluginsdatadir}/Cairo-Penguin")
- configure_file (${CMAKE_CURRENT_SOURCE_DIR}/Cairo-Penguin/data/Cairo-Penguin.conf.in ${CMAKE_CURRENT_BINARY_DIR}/Cairo-Penguin/data/Cairo-Penguin.conf)
- add_subdirectory (Cairo-Penguin)
- set (enable-penguin-plugin "yes")
-else()
- set (enable-penguin-plugin "no")
-endif()
-
-############# CLIPPER #################
-if (ENABLE_CLIPPER-PLUGIN)
- message (STATUS "> Clipper:")
- set (GETTEXT_CLIPPER ${GETTEXT_PLUGINS})
- set (VERSION_CLIPPER "1.1.6")
- set (PACKAGE_CLIPPER "cd-Clipper")
- set (Clipperdatadir "${pluginsdatadir}/Clipper")
- configure_file (${CMAKE_CURRENT_SOURCE_DIR}/Clipper/data/Clipper.conf.in ${CMAKE_CURRENT_BINARY_DIR}/Clipper/data/Clipper.conf)
- add_subdirectory (Clipper)
- set (enable-clipper-plugin "yes")
-else()
- set (enable-clipper-plugin "no")
-endif()
-
-############# CLOCK #################
-if (ENABLE_CLOCK-PLUGIN)
- message (STATUS "> Clock:")
- if (WITH_ICAL-SUPPORT)
- pkg_check_modules ("LIBICAL_PACKAGE" REQUIRED "libical")
- set (with_ical "yes")
- else()
- set (with_ical "no")
- endif()
- set (GETTEXT_CLOCK ${GETTEXT_PLUGINS})
- set (VERSION_CLOCK "2.1.5")
- set (PACKAGE_CLOCK "cd-clock")
- set (clockuserdirname "clock")
- set (clockdatadir "${pluginsdatadir}/clock")
- configure_file (${CMAKE_CURRENT_SOURCE_DIR}/clock/data/clock.conf.in ${CMAKE_CURRENT_BINARY_DIR}/clock/data/clock.conf)
- add_subdirectory (clock)
- set (enable-clock-plugin "yes")
-else()
- set (enable-clock-plugin "no")
-endif()
-
-############# DUSTBIN #################
-if (ENABLE_DUSTBIN-PLUGIN)
- message (STATUS "> Dustbin:")
- set (GETTEXT_DUSTBIN ${GETTEXT_PLUGINS})
- set (VERSION_DUSTBIN "2.3.3")
- set (PACKAGE_DUSTBIN "cd-dustbin")
- set (dustbinuserdirname "dustbin")
- set (dustbindatadir "${pluginsdatadir}/dustbin")
- configure_file (${CMAKE_CURRENT_SOURCE_DIR}/dustbin/data/dustbin.conf.in ${CMAKE_CURRENT_BINARY_DIR}/dustbin/data/dustbin.conf)
- add_subdirectory (dustbin)
- set (enable-dustbin-plugin "yes")
-else()
- set (enable-dustbin-plugin "no")
-endif()
-
-############# GMENU #################
-if (ENABLE_GMENU-PLUGIN)
- message (STATUS "> GMenu:")
- if ("${gtkversion}" STREQUAL "2")
- set (GMENU_MODULE libgnome-menu)
- else()
- set (GMENU_MODULE libgnome-menu)
- # set (GMENU_MODULE libgnome-menu-3.0) # TODO
- endif()
- pkg_check_modules ("GMENU_PACKAGE" REQUIRED "${GMENU_MODULE}")
- set (GETTEXT_GMENU ${GETTEXT_PLUGINS})
- set (VERSION_GMENU "1.1.9")
- set (PACKAGE_GMENU "cd-GMenu")
- set (with_gmenu "yes")
- set (gmenudatadir "${pluginsdatadir}/GMenu")
- configure_file (${CMAKE_CURRENT_SOURCE_DIR}/GMenu/data/GMenu.conf.in ${CMAKE_CURRENT_BINARY_DIR}/GMenu/data/GMenu.conf)
- add_subdirectory ("GMenu")
-else()
- set (with_gmenu "no")
-endif()
-
-############# GVFS-INTEGRATION #################
-if (ENABLE_KDE-INTEGRATION)
- message (STATUS "> GVFS-Integration:")
- pkg_check_modules ("LIBGIO" REQUIRED "gio-2.0")
- add_subdirectory (gvfs-integration)
-endif()
-
-############# KDE-INTEGRATION #################
-if (ENABLE_KDE-INTEGRATION)
- message (STATUS "> KDE-Integration:")
- pkg_check_modules ("KDE_INTEGRATION" REQUIRED "gio-2.0")
- set (VERSION_KDE_INTEGRATION "1.0.3")
- set (PACKAGE_KDE_INTEGRATION "cd_kde-integration")
- set (with_kde_integration "yes")
- set (kde_integrationdatadir "${pluginsdatadir}/kde-integration")
- add_subdirectory ("kde-integration")
-else()
- set (with_kde_integration "no")
-endif()
-set (with_kde_integration2 "no")
-
-############# LOGOUT #################
-if (ENABLE_LOGOUT-PLUGIN)
- message (STATUS "> LogOut:")
- if (WITH_UPOWER-SUPPORT)
- pkg_check_modules ("UPOWER" REQUIRED "upower-glib") # useful for Powermanager too.
- set (with_upower_support "yes")
- else()
- set (with_upower_support "no")
- endif()
- set (GETTEXT_LOGOUT ${GETTEXT_PLUGINS})
- set (VERSION_LOGOUT "2.0.0")
- set (PACKAGE_LOGOUT "cd-logout")
- set (logoutdatadir "${pluginsdatadir}/logout")
- configure_file (${CMAKE_CURRENT_SOURCE_DIR}/logout/data/logout.conf.in ${CMAKE_CURRENT_BINARY_DIR}/logout/data/logout.conf)
- add_subdirectory (logout)
- set (enable-logout-plugin "yes")
-else()
- set (enable-logout-plugin "no")
-endif()
-
-############# MOTION BLUR #################
-if (ENABLE_MOTION-BLUR-PLUGIN)
- message (STATUS "> Motion Blur:")
- set (GETTEXT_MOTION_BLUR ${GETTEXT_PLUGINS})
- set (VERSION_MOTION_BLUR "1.0.4")
- set (PACKAGE_MOTION_BLUR "cd-motion_blur")
- set (motion_blurdatadir "${pluginsdatadir}/motion-blur")
- configure_file (${CMAKE_CURRENT_SOURCE_DIR}/motion-blur/data/motion_blur.conf.in ${CMAKE_CURRENT_BINARY_DIR}/motion-blur/data/motion_blur.conf)
- add_subdirectory (motion-blur)
- set (enable-motion-blur-plugin "yes")
-else()
- set (enable-motion-blur-plugin "no")
-endif()
-
-############# POWERMANAGER #################
-if (ENABLE_POWERMANAGER-PLUGIN)
- message (STATUS "> PowerManager:")
- set (GETTEXT_POWERMANAGER ${GETTEXT_PLUGINS})
- set (VERSION_POWERMANAGER "1.3.8")
- set (PACKAGE_POWERMANAGER "cd-powermanager")
- set (powermanagerdatadir "${pluginsdatadir}/powermanager")
- configure_file (${CMAKE_CURRENT_SOURCE_DIR}/powermanager/data/powermanager.conf.in ${CMAKE_CURRENT_BINARY_DIR}/powermanager/data/powermanager.conf)
- add_subdirectory (powermanager)
- set (enable-powermanager-plugin "yes")
-else()
- set (enable-powermanager-plugin "no")
-endif()
-
-############# QUICK BROWSER #################
-if (ENABLE_QUICK-BROWSER-PLUGIN)
- message (STATUS "> Quick Browser:")
- set (GETTEXT_QUICK_BROWSER ${GETTEXT_PLUGINS})
- set (VERSION_QUICK_BROWSER "1.0.10")
- set (PACKAGE_QUICK_BROWSER "cd-quick-browser")
- set (quick_browserdatadir "${pluginsdatadir}/quick_browser")
- configure_file (${CMAKE_CURRENT_SOURCE_DIR}/quick-browser/data/quick-browser.conf.in ${CMAKE_CURRENT_BINARY_DIR}/quick-browser/data/quick-browser.conf)
- add_subdirectory (quick-browser)
- set (enable-quick-browser-plugin "yes")
-else()
- set (enable-quick-browser-plugin "no")
-endif()
-
-############# SHORTCUTS #################
-if (ENABLE_SHORTCUTS-PLUGIN)
- message (STATUS "> Shortcuts:")
- set (GETTEXT_SHORTCUTS ${GETTEXT_PLUGINS})
- set (VERSION_SHORTCUTS "1.3.3")
- set (PACKAGE_SHORTCUTS "cd-shortcuts")
- set (shortcutsdatadir "${pluginsdatadir}/shortcuts")
- configure_file (${CMAKE_CURRENT_SOURCE_DIR}/shortcuts/data/shortcuts.conf.in ${CMAKE_CURRENT_BINARY_DIR}/shortcuts/data/shortcuts.conf)
- add_subdirectory (shortcuts)
- set (enable-shortcuts-plugin "yes")
-else()
- set (enable-shortcuts-plugin "no")
-endif()
-
-############# SHOW DESKTOP #################
-if (ENABLE_SHOW-DESKTOP-PLUGIN)
- message (STATUS "> ShowDesktop:")
- if (WITH_XRANDR-SUPPORT)
- pkg_check_modules ("SHOW_DESKTOP_XRANDR" REQUIRED "xrandr")
- set (with_xrandr "yes")
- else()
- set (with_xrandr "no")
- endif()
- set (GETTEXT_SHOW_DESKTOP ${GETTEXT_PLUGINS})
- set (VERSION_SHOW_DESKTOP "1.2.6")
- set (PACKAGE_SHOW_DESKTOP "cd-showDesktop")
- set (show_desktopdatadir "${pluginsdatadir}/showDesktop")
- configure_file (${CMAKE_CURRENT_SOURCE_DIR}/showDesktop/data/showDesktop.conf.in ${CMAKE_CURRENT_BINARY_DIR}/showDesktop/data/showDesktop.conf)
- add_subdirectory (showDesktop)
- set (enable-show-desktop-plugin "yes")
-else()
- set (enable-show-desktop-plugin "no")
-endif()
-
-############# SHOW MOUSE #################
-if (ENABLE_SHOW-MOUSE-PLUGIN)
- message (STATUS "> Show Mouse:")
- set (GETTEXT_SHOW_MOUSE ${GETTEXT_PLUGINS})
- set (VERSION_SHOW_MOUSE "1.0.4")
- set (PACKAGE_SHOW_MOUSE "cd-show_mouse")
- set (show_mousedatadir "${pluginsdatadir}/show_mouse")
- configure_file (${CMAKE_CURRENT_SOURCE_DIR}/show-mouse/data/show_mouse.conf.in ${CMAKE_CURRENT_BINARY_DIR}/show-mouse/data/show_mouse.conf)
- add_subdirectory (show-mouse)
- set (enable-show-mouse-plugin "yes")
-else()
- set (enable-show-mouse-plugin "no")
-endif()
-
-############# SLIDER #################
-if (ENABLE_SLIDER-PLUGIN)
- message (STATUS "> Slider:")
- if (WITH_EXIF-SUPPORT)
- pkg_check_modules ("EXIF" REQUIRED "libexif")
- set (with_exif "yes")
- else()
- set (with_exif "no")
- endif()
- set (GETTEXT_SLIDER ${GETTEXT_PLUGINS})
- set (VERSION_SLIDER "2.0.11")
- set (PACKAGE_SLIDER "cd-slider")
- set (sliderdatadir "${pluginsdatadir}/slider")
- configure_file (${CMAKE_CURRENT_SOURCE_DIR}/slider/data/slider.conf.in ${CMAKE_CURRENT_BINARY_DIR}/slider/data/slider.conf)
- add_subdirectory (slider)
- set (enable-slider-plugin "yes")
-else()
- set (enable-slider-plugin "no")
-endif()
-
-############# SWITCHER #################
-if (ENABLE_SWITCHER-PLUGIN)
- message (STATUS "> Switcher:")
- set (GETTEXT_SWITCHER ${GETTEXT_PLUGINS})
- set (VERSION_SWITCHER "2.1.8")
- set (PACKAGE_SWITCHER "cd-switcher")
- set (switcherdatadir "${pluginsdatadir}/switcher")
- configure_file (${CMAKE_CURRENT_SOURCE_DIR}/switcher/data/switcher.conf.in ${CMAKE_CURRENT_BINARY_DIR}/switcher/data/switcher.conf)
- add_subdirectory (switcher)
- set (enable-switcher-plugin "yes")
-else()
- set (enable-switcher-plugin "no")
-endif()
-
-############# TERMINAL #################
-if (ENABLE_TERMINAL-PLUGIN)
- message (STATUS "> Terminal:")
- if ("${gtkversion}" STREQUAL "2")
- set (TERMINAL_MODULE vte)
- else()
- set (TERMINAL_MODULE vte-2.90)
- endif()
- pkg_check_modules ("TERMINAL_PACKAGE" REQUIRED "${TERMINAL_MODULE}")
- set (GETTEXT_TERMINAL ${GETTEXT_PLUGINS})
- set (VERSION_TERMINAL "1.0.12")
- set (PACKAGE_TERMINAL "cd-terminal")
- set (with_terminal "yes")
- set (terminaldatadir "${pluginsdatadir}/terminal")
- configure_file (${CMAKE_CURRENT_SOURCE_DIR}/terminal/data/terminal.conf.in ${CMAKE_CURRENT_BINARY_DIR}/terminal/data/terminal.conf)
- add_subdirectory (terminal)
-else()
- set (with_terminal "no")
-endif()
-
-############# TOONS #################
-if (ENABLE_TOONS-PLUGIN)
- message (STATUS "> Toons:")
- set (GETTEXT_TOONS ${GETTEXT_PLUGINS})
- set (VERSION_TOONS "1.0.11")
- set (PACKAGE_TOONS "cd-Toons")
- set (toonsdatadir "${pluginsdatadir}/Toons")
- set (toonsuserdirname "Toons")
- configure_file (${CMAKE_CURRENT_SOURCE_DIR}/Toons/data/Toons.conf.in ${CMAKE_CURRENT_BINARY_DIR}/Toons/data/Toons.conf)
- add_subdirectory (Toons)
- set (enable-toons-plugin "yes")
-else()
- set (enable-toons-plugin "no")
-endif()
-
-############# WEATHER #################
-if (ENABLE_WEATHER-PLUGIN)
- message (STATUS "> Weather:")
- set (GETTEXT_WEATHER ${GETTEXT_PLUGINS})
- set (VERSION_WEATHER "1.2.12")
- set (PACKAGE_WEATHER "cd-weather")
- set (weatherdatadir "${pluginsdatadir}/weather")
- set (weatheruserdirname "weather")
- configure_file (${CMAKE_CURRENT_SOURCE_DIR}/weather/data/weather.conf.in ${CMAKE_CURRENT_BINARY_DIR}/weather/data/weather.conf)
- add_subdirectory (weather)
- set (enable-weather-plugin "yes")
-else()
- set (enable-weather-plugin "no")
-endif()
-
-############# WEBLETS #################
-if (ENABLE_WEBLETS-PLUGIN)
- message (STATUS "> Weblets:")
- if ("${gtkversion}" STREQUAL "2")
- set (WEBKIT_MODULE webkit-1.0)
- else()
- set (WEBKIT_MODULE webkitgtk-3.0)
- endif()
- pkg_check_modules ("WEBKIT" REQUIRED "${WEBKIT_MODULE}")
- set (GETTEXT_WEBLETS ${GETTEXT_PLUGINS})
- set (VERSION_WEBLETS "0.0.12")
- set (PACKAGE_WEBLETS "cd-weblets")
- set (webletsdatadir "${pluginsdatadir}/weblets")
- set (with_weblets "yes")
- configure_file (${CMAKE_CURRENT_SOURCE_DIR}/weblets/data/weblets.conf.in ${CMAKE_CURRENT_BINARY_DIR}/weblets/data/weblets.conf)
- add_subdirectory ("weblets")
-else()
- set (with_weblets "no")
-endif()
-
-############# XGAMMA #################
-if (ENABLE_XGAMMA-PLUGIN)
- message (STATUS "> XGamma:")
- pkg_check_modules ("XGAMMA_PACKAGE" REQUIRED "x11" "xxf86vm")
- set (GETTEXT_XGAMMA ${GETTEXT_PLUGINS})
- set (VERSION_XGAMMA "1.2.2")
- set (PACKAGE_XGAMMA "cd-Xgamma")
- set (with_xgamma "yes")
- set (xgammadatadir "${pluginsdatadir}/Xgamma")
- configure_file (${CMAKE_CURRENT_SOURCE_DIR}/Xgamma/data/Xgamma.conf.in ${CMAKE_CURRENT_BINARY_DIR}/Xgamma/data/Xgamma.conf)
- add_subdirectory ("Xgamma")
-else()
- set (with_xgamma "no")
-endif()
-
-message ("")
-message (STATUS "===============")
-message (STATUS "Plug-ins build:")
-message (STATUS "===============")
-message ("")
-message (STATUS "Stable:")
-message (STATUS " Integration plug-ins:")
-message (STATUS " - with KDE support: ${with_kde_integration}")
-message (STATUS " Plug-ins:")
-message (STATUS " - with Alsa-Mixer applet: ${with_alsa}")
-message (STATUS " - with Cairo-Penguin applet: ${enable-penguin-plugin}")
-message (STATUS " - with Clipper applet: ${enable-clipper-plugin}")
-message (STATUS " - with Clock applet: ${enable-clock-plugin}")
-message (STATUS " - with Dustbin applet: ${enable-dustbin-plugin}")
-message (STATUS " - with GMenu applet: ${with_gmenu}")
-message (STATUS " - with Logout applet: ${enable-logout-plugin}")
-message (STATUS " - with Motion-Blur applet: ${enable-motion-blur-plugin}")
-message (STATUS " - with Powermanager applet: ${enable-powermanager-plugin}")
-message (STATUS " - with Quick-Browser applet: ${enable-quick-browser-plugin}")
-message (STATUS " - with Shortcuts applet: ${enable-shortcuts-plugin}")
-message (STATUS " - with Show-Desktop applet: ${enable-show-desktop-plugin}")
-message (STATUS " - with Show-Mouse applet: ${enable-show-mouse-plugin}")
-message (STATUS " - with Slider applet: ${enable-slider-plugin}")
-message (STATUS " - with Switcher applet: ${enable-switcher-plugin}")
-message (STATUS " - with Terminal applet: ${with_terminal}")
-message (STATUS " - with Toons applet: ${enable-toons-plugin}")
-message (STATUS " - with Weather applet: ${enable-weather-plugin}")
-message (STATUS " - with Weblets applet: ${with_weblets}")
-message (STATUS " - with Xgamma applet: ${with_xgamma}")
-message (STATUS "Add On:")
-message (STATUS " - with iCal support: ${with_ical}")
-message (STATUS " - with UPower support: ${with_upower_support}")
-message (STATUS " - with Screen Resolution support: ${with_xrandr}")
-message (STATUS " - with Image Rotation support: ${with_exif}")
-message ("")