summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-util/monodevelop-database/monodevelop-database-2.3.1.ebuild')
-rw-r--r--dev-util/monodevelop-database/monodevelop-database-2.3.1.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/dev-util/monodevelop-database/monodevelop-database-2.3.1.ebuild b/dev-util/monodevelop-database/monodevelop-database-2.3.1.ebuild
new file mode 100644
index 0000000..8cbb4af
--- /dev/null
+++ b/dev-util/monodevelop-database/monodevelop-database-2.3.1.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=2
+
+inherit mono multilib
+
+DESCRIPTION="Database Browser Extension for MonoDevelop"
+HOMEPAGE="http://www.monodevelop.com/"
+SRC_URI="http://ftp.novell.com/pub/mono/sources/${PN}/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=">=dev-lang/mono-2.6.1
+ =dev-util/monodevelop-${PV}*
+ dev-dotnet/gtksourceview-sharp:1"
+
+DEPEND="${RDEPEND}
+ x11-misc/shared-mime-info
+ >=dev-util/intltool-0.35
+ >=dev-util/pkgconfig-0.19"
+
+src_compile() {
+ emake -j1 || die "make failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "install failed"
+ dodoc ChangeLog README || die "dodoc failed"
+ mono_multilib_comply
+}