summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnthoine Bourgeois <anthoine.bourgeois@gmail.com>2012-01-08 16:43:53 +0100
committerAnthoine Bourgeois <anthoine.bourgeois@gmail.com>2012-01-08 16:43:53 +0100
commit1cb439200d2c013db8ba3920f6c0b2c4a6bfc0f8 (patch)
tree9f59b200087fb925240c03ad69b0fcf1110dd05e
parent+blender-2.61-r1.ebuild (diff)
downloadaluco-1cb439200d2c013db8ba3920f6c0b2c4a6bfc0f8.tar.gz
aluco-1cb439200d2c013db8ba3920f6c0b2c4a6bfc0f8.tar.bz2
aluco-1cb439200d2c013db8ba3920f6c0b2c4a6bfc0f8.zip
Fix bug #388931: lspci command not found on first run.
-rw-r--r--app-benchmarks/phoronix-test-suite/Manifest3
-rw-r--r--app-benchmarks/phoronix-test-suite/files/phoronix-test-suite-3.6.1-lspci.patch24
-rw-r--r--app-benchmarks/phoronix-test-suite/phoronix-test-suite-3.6.1.ebuild1
3 files changed, 27 insertions, 1 deletions
diff --git a/app-benchmarks/phoronix-test-suite/Manifest b/app-benchmarks/phoronix-test-suite/Manifest
index 52bcfed..d73f7c8 100644
--- a/app-benchmarks/phoronix-test-suite/Manifest
+++ b/app-benchmarks/phoronix-test-suite/Manifest
@@ -1,7 +1,8 @@
+AUX phoronix-test-suite-3.6.1-lspci.patch 1552 RMD160 227642f825f8ffb97fad2c3909abc68409e7c60a SHA1 ae866246a002242a75badce244bc82173c4e0adb SHA256 bc990c892c380ad98a7442faccce1d0a5d1ddb047a868be47b32d8c9d3289ff7
DIST phoronix-test-suite-3.4.0.tar.gz 418224 RMD160 858605ba618cb8c721b68a142db70d9a298ab6d7 SHA1 10be51fc45c077fd73193a8f4bd6c850a9198f84 SHA256 112f394f2bc4b9ea6d472957300d3141fbbf7fd982bc4024597aff941e6d7c03
DIST phoronix-test-suite-3.6.0.tar.gz 431651 RMD160 a8e471a2cad502d89f589de7133ca75fb8bc812b SHA1 4189327380cca588fa469dbb635fab7f1b570038 SHA256 a4ea566e3da36bbcaaf10f1fa3ca21f4089ff961c2ff9b58816236801338aa90
DIST phoronix-test-suite-3.6.1.tar.gz 432754 RMD160 3b6ccc9034f0b47c569fa7fec2740293cadfa0ea SHA1 c704f053cdd45e34a9ea912ef426f92e441d3dde SHA256 a394ae9529ed1ae37e6c8d0ee0092110c199ab6067c2c61dbb3233525377b738
EBUILD phoronix-test-suite-3.4.0.ebuild 3480 RMD160 21d6467dc0c0b26aea63d3f44fe5e0e8545e14e0 SHA1 e38df570d756a9892f79f38421e5f6223affafeb SHA256 88c6046bf862e36b3cae3b66ffa71eb729fe06af164062bfa3d8fc8e0a547eff
EBUILD phoronix-test-suite-3.6.0.ebuild 2242 RMD160 c8cb88f67f56ef7e4620e0bf3965d8539002ec3d SHA1 9f0586466c7dcf480a325a98f11c51ed08c4a401 SHA256 b01f234283940d443c239f67ed8184692f13f53fa69225f83a5bda3983350d95
-EBUILD phoronix-test-suite-3.6.1.ebuild 2242 RMD160 c8cb88f67f56ef7e4620e0bf3965d8539002ec3d SHA1 9f0586466c7dcf480a325a98f11c51ed08c4a401 SHA256 b01f234283940d443c239f67ed8184692f13f53fa69225f83a5bda3983350d95
+EBUILD phoronix-test-suite-3.6.1.ebuild 2281 RMD160 07424d10c6eb58497b0c04af9356b416cc523c22 SHA1 16078cc1fffe716c3594620d1d8b539469fcdbc2 SHA256 5579bcfcee4084a6f3c3e6c9cd3feb6e53432fb3d625732030c0471f5194480d
MISC metadata.xml 783 RMD160 8b282ed79507ed65205c1374665c292d08e19243 SHA1 ac8c56cddd4c68e7d639a566aa758549bbc2fd2f SHA256 6067a77bc4ffa158a5d3444b84ce21f0c3f3490afc19fcafc4e553c38bb372e6
diff --git a/app-benchmarks/phoronix-test-suite/files/phoronix-test-suite-3.6.1-lspci.patch b/app-benchmarks/phoronix-test-suite/files/phoronix-test-suite-3.6.1-lspci.patch
new file mode 100644
index 0000000..74deee8
--- /dev/null
+++ b/app-benchmarks/phoronix-test-suite/files/phoronix-test-suite-3.6.1-lspci.patch
@@ -0,0 +1,24 @@
+diff -Npur phoronix-test-suite.old/pts-core/objects/phodevi/components/phodevi_motherboard.php phoronix-test-suite/pts-core/objects/phodevi/components/phodevi_motherboard.php
+--- phoronix-test-suite.old/pts-core/objects/phodevi/components/phodevi_motherboard.php 2012-01-08 16:27:36.731691743 +0100
++++ phoronix-test-suite/pts-core/objects/phodevi/components/phodevi_motherboard.php 2012-01-08 16:28:37.654689437 +0100
+@@ -94,7 +94,7 @@ class phodevi_motherboard extends phodev
+
+ if(phodevi::is_linux())
+ {
+- $lspci = shell_exec('lspci -mmkvnn 2> /dev/null');
++ $lspci = shell_exec('/usr/sbin/lspci -mmkvnn 2> /dev/null');
+ $lspci = explode("\n\n", $lspci);
+
+ foreach($lspci as $o => &$lspci_section)
+diff -Npur phoronix-test-suite.old/pts-core/objects/pts_client.php phoronix-test-suite/pts-core/objects/pts_client.php
+--- phoronix-test-suite.old/pts-core/objects/pts_client.php 2012-01-08 16:27:36.729691744 +0100
++++ phoronix-test-suite/pts-core/objects/pts_client.php 2012-01-08 16:36:51.906670711 +0100
+@@ -1446,7 +1446,7 @@ class pts_client
+
+ if(!isset($cache[$executable]))
+ {
+- $paths = pts_strings::trim_explode((phodevi::is_windows() ? ';' : ':'), (($path = pts_client::read_env('PATH')) == false ? '/usr/bin:/usr/local/bin' : $path));
++ $paths = pts_strings::trim_explode((phodevi::is_windows() ? ';' : ':'), (($path = pts_client::read_env('PATH')) == false ? '/usr/bin:/usr/local/bin:/usr/sbin/:/usr/local/sbin' : $path . ":/usr/sbin:/usr/local/sbin"));
+ $executable_path = false;
+
+ foreach($paths as $path)
diff --git a/app-benchmarks/phoronix-test-suite/phoronix-test-suite-3.6.1.ebuild b/app-benchmarks/phoronix-test-suite/phoronix-test-suite-3.6.1.ebuild
index 1eb1b74..8caea0f 100644
--- a/app-benchmarks/phoronix-test-suite/phoronix-test-suite-3.6.1.ebuild
+++ b/app-benchmarks/phoronix-test-suite/phoronix-test-suite-3.6.1.ebuild
@@ -26,6 +26,7 @@ S="${WORKDIR}/${PN}"
src_prepare() {
sed -i -e "s,export PTS_DIR=\`pwd\`,export PTS_DIR=\"/usr/share/${PN}\"," \
phoronix-test-suite
+ epatch "${FILESDIR}"/${P}-lspci.patch
}
src_configure() {