summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorandy <andy@ndyk.de>2016-01-10 17:56:09 +0100
committerandy <andy@ndyk.de>2016-01-10 17:56:09 +0100
commit745b38aa557685109789024535721f4651f2a3ea (patch)
tree8d6a4f9666033f6a691f8ec136627302fe5a5c1d
parentfixed manifest (diff)
downloadandy-745b38aa557685109789024535721f4651f2a3ea.tar.gz
andy-745b38aa557685109789024535721f4651f2a3ea.tar.bz2
andy-745b38aa557685109789024535721f4651f2a3ea.zip
added brother mfcj480dw ebuild
-rw-r--r--net-print/brother-mfcj480dw/ChangeLog11
-rw-r--r--net-print/brother-mfcj480dw/Manifest4
-rw-r--r--net-print/brother-mfcj480dw/brother-mfcj480dw-20150110.ebuild78
-rw-r--r--net-print/brother-mfcj480dw/metadata.xml10
4 files changed, 103 insertions, 0 deletions
diff --git a/net-print/brother-mfcj480dw/ChangeLog b/net-print/brother-mfcj480dw/ChangeLog
new file mode 100644
index 0000000..3d77b31
--- /dev/null
+++ b/net-print/brother-mfcj480dw/ChangeLog
@@ -0,0 +1,11 @@
+# ChangeLog for net-print/brother-mfcj480dw
+# Copyright 1999-2016 Gentoo Foundation; Distributed under the GPL v2
+# $Id$
+
+*brother-mfcj480dw-20150110 (10 Jan 2016)
+
+ 10 Jan 2016; <andy@gentoo.org> +brother-mfcj480dw-20150110.ebuild,
+ +metadata.xml:
+ Added Brother MFC-J480DW Driver based on ebuild from ulm:
+ https://cgit.gentoo.org/repo/dev/ulm.git/tree/net-print/brother-mfcj870dw
+
diff --git a/net-print/brother-mfcj480dw/Manifest b/net-print/brother-mfcj480dw/Manifest
new file mode 100644
index 0000000..53dc319
--- /dev/null
+++ b/net-print/brother-mfcj480dw/Manifest
@@ -0,0 +1,4 @@
+DIST mfcj480dwcupswrapper-1.0.0-0.i386.rpm 17459 SHA256 2a18c4943adc92a2e97f674a638dbdfb87656137a97073577f716ace6a196854 SHA512 63b0a813c8f7c06a44c9506d5c9a11bb651f28c8028a870041b59f91600566128139860320141c66039f6ce79e8877cd5055768fbd6008dc6dd0ec5bbe14fe38 WHIRLPOOL ab0ce1e54476e08f87563ff68742bc8d6917a313d0eb0ccad9efa17e299edf9a4716370d8d94fa919d56eb299389eb98adb1d2213104c073898976c2ea490be3
+DIST mfcj480dwlpr-1.0.0-0.i386.rpm 2654483 SHA256 2a1e03b59d6af9dc8d67a9799f06ab439e67565410373081f2f8be65eb697a64 SHA512 9e683e3398737b766e3408449145d91539f3e4276464b0a6e5be457feefaa64c6915bd26f127ae20e15ce4a9d5075176aa4076bf11542745d70bd5638eecf17a WHIRLPOOL df9a1d5595bac95b69695cf19de865e68767f5c269c220cac5ed45beee8083599eebb173deef588dfd6c25385b00826b32407a659d44a9a94a6248eb68f880f3
+EBUILD brother-mfcj480dw-20150110.ebuild 2191 SHA256 329c0c365d31472c1fa083fcdece1aef627e5d9763ebdb878280d5305ebbd1f1 SHA512 c8a6cb63c43e9a91af9e9ef3b743874ca3dd125d4902ffbc56870fb272a836ea91b564c6aa69f4693197ff93d72bfafce1d56d596745e112298c7b0bbe5516ac WHIRLPOOL 28e60ca3ac260e88a986509cb434f8572db0b169bdadee602ac352e26f298f9f817d68c1e153b6e46e1e16bf33de46aca27eb0bedbc0f76362c2c5a6e4cdc25f
+MISC metadata.xml 263 SHA256 962d97f242ce31ca012f0495e7969a2c3b6a2c44722d3b5dc7b4cd6de71963ee SHA512 c9b64416d22357260d43a8e663790bf1db558b652c92908855d4ce6e2ec7cc12d661edbc4222a51859ef8532413ea732e853761a31137a933318b9b87a602b2e WHIRLPOOL 33063b3431b6f3be522b462881e18d5cc62384ca450047425d45135fe6054a1b361452b111ba09c4ddded86011b2f47f6eed3c66f93e41346abdc63c2158ae6c
diff --git a/net-print/brother-mfcj480dw/brother-mfcj480dw-20150110.ebuild b/net-print/brother-mfcj480dw/brother-mfcj480dw-20150110.ebuild
new file mode 100644
index 0000000..8379b05
--- /dev/null
+++ b/net-print/brother-mfcj480dw/brother-mfcj480dw-20150110.ebuild
@@ -0,0 +1,78 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+EAPI=5
+
+inherit rpm multilib
+
+MODEL="${PN#*-}"
+PV_LPR="1.0.0-0"
+PV_CUPSWRAPPER="1.0.0-0"
+
+DESCRIPTION="Brother MFC-J480DW LPR+cupswrapper drivers"
+HOMEPAGE="http://support.brother.com/g/b/downloadtop.aspx?c=us&lang=en&prod=mfcj480dw_us_eu_as"
+SRC_URI="http://download.brother.com/welcome/dlf102091/${MODEL}lpr-${PV_LPR}.i386.rpm
+ http://download.brother.com/welcome/dlf102092/${MODEL}cupswrapper-${PV_CUPSWRAPPER}.i386.rpm"
+
+LICENSE="GPL-2+ Brother-lpr no-source-code"
+SLOT="0"
+KEYWORDS="~x86 ~amd64"
+IUSE="metric"
+RESTRICT="strip"
+
+DEPEND="net-print/cups"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/opt/brother/Printers/${MODEL}"
+
+src_unpack() {
+ rpm_unpack ${A}
+}
+
+src_prepare() {
+ if use metric; then
+ sed -i "/^PaperType/s/Letter/A4/" inf/br${MODEL}rc || die
+ fi
+}
+
+src_install() {
+ has_multilib_profile && ABI=x86
+
+ local dest=/opt/brother/Printers/${MODEL}
+ cd "${S}"/lpd || die
+ exeinto ${dest}/lpd
+ doexe br${MODEL}filter filter${MODEL} psconvertij2
+
+ dosym ${dest}/lpd/filter${MODEL} \
+ /usr/libexec/cups/filter/brother_lpdwrapper_${MODEL}
+
+ cd "${S}"/inf || die
+ insinto ${dest}/inf
+ doins br${MODEL}func ImagingArea PaperDimension paperinfij2
+ doins -r lut
+ insinto /etc${dest}/inf
+ doins br${MODEL}rc # config file
+ dosym /etc${dest}/inf/br${MODEL}rc ${dest}/inf/br${MODEL}rc
+
+ cd "${S}"/cupswrapper || die
+ insinto ${dest}/cupswrapper
+ doins brother_${MODEL}_printer_en.ppd
+ dosym ${dest}/cupswrapper/brother_${MODEL}_printer_en.ppd \
+ /usr/share/cups/model/Brother/brother_${MODEL}_printer_en.ppd
+
+ # The brprintconf utility is very broken and mangles the path
+ # of the function list file. Therefore, don't install it.
+ exeinto ${dest}/bin
+ doexe "${WORKDIR}"/usr/bin/brprintconf_${MODEL}
+}
+
+pkg_postinst () {
+ elog "You may use brprintconf_${MODEL} to change printer options"
+ elog
+ elog "Set 'Fast Normal' quality:"
+ elog " ${dest}/bin/brprintconf_${MODEL} -reso 300x300dpi"
+ elog
+ elog "For more options just execute brprintconf_${MODEL} as root"
+ elog "You can check current settings in:"
+ elog " /opt/brother/Printers/${MODEL}/inf/br${MODEL}rc"
+}
diff --git a/net-print/brother-mfcj480dw/metadata.xml b/net-print/brother-mfcj480dw/metadata.xml
new file mode 100644
index 0000000..2c7de38
--- /dev/null
+++ b/net-print/brother-mfcj480dw/metadata.xml
@@ -0,0 +1,10 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer>
+ <email>andy@ndyk.de</email>
+</maintainer>
+<use>
+ <flag name='metric'>Default to A4 paper size</flag>
+</use>
+</pkgmetadata>