summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--net-print/brother-dcp-j515w-drivers/Manifest3
-rw-r--r--net-print/brother-dcp-j515w-drivers/brother-dcp-j515w-drivers-1.ebuild60
2 files changed, 63 insertions, 0 deletions
diff --git a/net-print/brother-dcp-j515w-drivers/Manifest b/net-print/brother-dcp-j515w-drivers/Manifest
new file mode 100644
index 0000000..0172236
--- /dev/null
+++ b/net-print/brother-dcp-j515w-drivers/Manifest
@@ -0,0 +1,3 @@
+DIST dcpj515wcupswrapper-1.1.1-3.i386.rpm 15610 SHA256 a323a9a78a8c14aaf69d6d8adb85c05942674d1a5e1d5eae660eb41cc5aea4e4 SHA512 3eb0cfb303fd2c6333ef4ebd2ab75309112ca1afe82f47e4212276386860bb5b342e2e1d179018e7f2308aff1485374b2787f7ba7eb67aca9c344ff4853c9c2d WHIRLPOOL f16bf0ae9700517ac8dfda245edf7c036923bb04b3a6a1b1c053296c60f1141d66a10fde7825e988d0720574cfb4d7c9326f3e65e162e4e90d6bb2f7901a9fc8
+DIST dcpj515wlpr-1.1.1-1.i386.rpm 1900631 SHA256 0ed2a03bebae8b7d7de28e577730f7a79ba0c43112768e6561bfa7c45bddf1ab SHA512 b06ec52e56ae2d8735cf649d367051f6fc6d1391ae0bb5ef3beba8045ed7fc433bf959ab81d11f88a231d0dd598b9b78e404515212560b34ee33db1cf57a964f WHIRLPOOL 4da19b72ceb86c8bc423273d13574c94b920d244fd53ff7e65c2e0f67173c0ca31f12e19cbebdf79fe60da98d0139b83d53540635a31248cc70e385645b5f9f0
+EBUILD brother-dcp-j515w-drivers-1.ebuild 1943 SHA256 4258bd0a75f74c31fc3bb8494a6059140fbabf7de6df19bcfff2f6406ed8ed7d SHA512 00dd425defb3ccb572d3876a2519ab673929096bfc48ec04fb8e7c963a7d171ad775dd3453f45bff05bfff53c2e3737b2aa97a00f1a5c45c7fdc45fe7af06a66 WHIRLPOOL 038e682192f778951a1c1515f09603fe15e108ca5181411b5bf84a0c8f3e8dbb92fd9dc58bc8e0fe201c38676ad0eeefeab2f29efcbe9703f9e94cb3bf929ee8
diff --git a/net-print/brother-dcp-j515w-drivers/brother-dcp-j515w-drivers-1.ebuild b/net-print/brother-dcp-j515w-drivers/brother-dcp-j515w-drivers-1.ebuild
new file mode 100644
index 0000000..4f5ac4b
--- /dev/null
+++ b/net-print/brother-dcp-j515w-drivers/brother-dcp-j515w-drivers-1.ebuild
@@ -0,0 +1,60 @@
+EAPI=4
+
+inherit rpm multilib
+
+DESCRIPTION="Brother DCP-J515W LPR+cupswrapper drivers"
+HOMEPAGE="http://welcome.solutions.brother.com/bsc/public_s/id/linux/en/download_prn.html#DCP-J515W"
+SRC_URI="http://pub.brother.com/pub/com/bsc/linux/dlf/dcpj515wlpr-1.1.1-1.i386.rpm
+ http://pub.brother.com/pub/com/bsc/linux/dlf/dcpj515wcupswrapper-1.1.1-3.i386.rpm"
+
+LICENSE="GPL"
+SLOT="0"
+KEYWORDS="~x86 ~amd64"
+IUSE=""
+RESTRICT="strip"
+
+DEPEND="net-print/cups
+ app-text/a2ps"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}" # Portage will bitch about missing $S so lets pretend that we have vaild $S.
+
+src_unpack() {
+ rpm_unpack ${A}
+}
+
+src_install() {
+ has_multilib_profile && ABI=x86
+
+ dosbin "${WORKDIR}/usr/bin/brprintconf_dcpj515w"
+
+ cp -r usr "${D}" || die
+
+ mkdir -p ${D}/usr/libexec/cups/filter || die
+ ( cd ${D}/usr/libexec/cups/filter/ && ln -s ../../../../usr/local/Brother/Printer/dcpj515w/lpd/filterdcpj515w brlpdwrapperdcpj515w ) || die
+ mkdir -p ${D}/usr/share/cups/model || die
+ ( cd ${D}/usr/share/cups/model && ln -s ../../../../usr/local/Brother/Printer/dcpj515w/cupswrapper/brdcpj515w.ppd ) || die
+}
+
+pkg_postinst () {
+ ewarn "You really wanna read this."
+ elog "You need to use brprintconf_dcpj515w to change printer options"
+ elog "For example, you should set paper type to A4 right after instalation"
+ elog "or your prints will be misaligned!"
+ elog
+ elog "Set A4 Paper type:"
+ elog " brprintconf_dcpj515w -pt A4"
+ elog "Set 'Fast Normal' quality:"
+ elog " brprintconf_dcpj515w -reso 300x300dpi"
+ elog
+ elog "For more options just execute brprintconf_dcpj515w as root"
+ elog "You can check current settings in:"
+ elog " /usr/local/Brother/Printer/dcpj515w/inf/brdcpj515wrc"
+ elog
+ elog "To add printer over WIFI add use LPD or SOCKET protocol, for example:"
+ elog " lpd://<host_or_ip>/BINARY_P1"
+ elog " - or -"
+ elog " socket://<host_or_ip>:9100"
+}
+
+# TODO: Write alternative to filterdcpj515w or patch it for the security manner.