summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJaak Ristioja <jaak@ristioja.ee>2011-11-23 03:12:53 +0200
committerJaak Ristioja <jaak@ristioja.ee>2011-11-23 03:12:53 +0200
commitd618e81ab8a4fe0e9504d69eb92399912f81f004 (patch)
tree1b9eb15bd6b94373835b9f10e91d951cfd1d4fbc /app-text/bibletime
parentVersion bump to 2.8.4. (diff)
downloadbibletime-d618e81ab8a4fe0e9504d69eb92399912f81f004.tar.gz
bibletime-d618e81ab8a4fe0e9504d69eb92399912f81f004.tar.bz2
bibletime-d618e81ab8a4fe0e9504d69eb92399912f81f004.zip
Actually version bumped to 2.8.4.
Diffstat (limited to 'app-text/bibletime')
-rw-r--r--app-text/bibletime/bibletime-2.8.4.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/app-text/bibletime/bibletime-2.8.4.ebuild b/app-text/bibletime/bibletime-2.8.4.ebuild
new file mode 100644
index 0000000..792cafd
--- /dev/null
+++ b/app-text/bibletime/bibletime-2.8.4.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Copyright 2010-2011 The BibleTime team
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=2
+inherit cmake-utils
+
+DESCRIPTION="Qt4 Bible study application using the SWORD library."
+HOMEPAGE="http://www.bibletime.info/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="alpha amd64 hppa ia64 ppc ppc64 sparc x86"
+IUSE="debug"
+
+RDEPEND=">=app-text/sword-1.6.0
+ >=dev-cpp/clucene-0.9.16a
+ x11-libs/qt-dbus:4
+ x11-libs/qt-gui:4
+ x11-libs/qt-webkit:4"
+DEPEND="${RDEPEND}
+ x11-libs/qt-test:4"
+
+DOCS="ChangeLog README"
+
+src_configure() {
+ mycmakeargs="${mycmakeargs} -DUSE_QT_WEBKIT=ON"
+ cmake-utils_src_configure
+}