summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--media-video/simplescreenrecorder/Manifest2
-rw-r--r--media-video/simplescreenrecorder/simplescreenrecorder-0.3.6.ebuild112
2 files changed, 114 insertions, 0 deletions
diff --git a/media-video/simplescreenrecorder/Manifest b/media-video/simplescreenrecorder/Manifest
new file mode 100644
index 0000000..6b2544e
--- /dev/null
+++ b/media-video/simplescreenrecorder/Manifest
@@ -0,0 +1,2 @@
+DIST 0.3.6.tar.gz 1640585 SHA256 146f5bf26bd56d68ff4506c9756526fbf60c8737cb023759250c357935b309b5 SHA512 54e07050ae58c2d59327b13be6613754ada26891c157c6e9d121db2658508245c8f9a6c92921fdc125cdf82611099abf9c89d64ee093a6592fc81fb9c96cb09d WHIRLPOOL 715be064a3e8fd86d299a22d92f812f45fa522652bb5ab21c1492a05dd384b2cc385ce62ab9cb74fe8e9ee7168c29ccc3ef5eae3d2412189ed2c8e1c891bd998
+EBUILD simplescreenrecorder-0.3.6.ebuild 3023 SHA256 fa6e26c365c6d3ae5752284d32bca251ef038a1b4854878faa321b807989a1de SHA512 a2a0df0745608d5bcb2ddc4bcf8aea7d50d81564d0c2e9a323b08e2866e6eece168f912bf12494f596c95978a8764fb691b23ada06fd3191531a9cca691b094b WHIRLPOOL 43890098823317e24b4c287d6f1ad01ed0057d165827e7b72ca2e764670c24d5f7ef7cc5aa8aa89771ad74c0cb91c9e45cfda23289bdcb417990bc978c5f6f04
diff --git a/media-video/simplescreenrecorder/simplescreenrecorder-0.3.6.ebuild b/media-video/simplescreenrecorder/simplescreenrecorder-0.3.6.ebuild
new file mode 100644
index 0000000..e808338
--- /dev/null
+++ b/media-video/simplescreenrecorder/simplescreenrecorder-0.3.6.ebuild
@@ -0,0 +1,112 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+inherit flag-o-matic multilib-minimal
+
+if [[ ${PV} = 9999 ]]; then
+ inherit git-2
+fi
+
+DESCRIPTION="A Simple Screen Recorder"
+HOMEPAGE="http://www.maartenbaert.be/simplescreenrecorder"
+LICENSE="GPL-3"
+PKGNAME="ssr"
+S=${WORKDIR}/${PKGNAME}-${PV}
+if [[ ${PV} = 9999 ]]; then
+ EGIT_REPO_URI="git://github.com/MaartenBaert/${PKGNAME}.git
+ https://github.com/MaartenBaert/${PKGNAME}.git"
+ EGIT_BOOTSTRAP=""
+ KEYWORDS=""
+else
+ SRC_URI="https://github.com/MaartenBaert/${PKGNAME}/archive/${PV}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+SLOT="0"
+IUSE="+asm debug jack mp3 pulseaudio theora vorbis vpx x264 +qt4 qt5"
+REQUIRED_USE="^^ ( qt4 qt5 )"
+
+RDEPEND="
+ qt4? (
+ dev-qt/qtcore:4
+ dev-qt/qtgui:4
+ )
+ qt5? (
+ dev-qt/qtcore:5
+ dev-qt/qtgui:5
+ dev-qt/qtwidgets:5
+ dev-qt/qtx11extras:5
+ )
+ virtual/glu[${MULTILIB_USEDEP}]
+ media-libs/alsa-lib
+ media-libs/mesa[${MULTILIB_USEDEP}]
+ x11-libs/libX11[${MULTILIB_USEDEP}]
+ x11-libs/libXext
+ x11-libs/libXfixes[${MULTILIB_USEDEP}]
+ jack? ( media-sound/jack-audio-connection-kit )
+ pulseaudio? ( media-sound/pulseaudio )
+ || (
+ media-video/ffmpeg:0[vorbis?,vpx?,x264?,mp3?,theora?]
+ media-video/libav[vorbis?,vpx?,x264?,mp3?,theora?]
+ )
+ "
+DEPEND="${RDEPEND}"
+
+pkg_setup() {
+ if [[ ${PV} == "9999" ]]; then
+ elog
+ elog "This ebuild merges the latest revision available from upstream's"
+ elog "git repository, and might fail to compile or work properly once"
+ elog "merged."
+ elog
+ fi
+
+ if [[ ${ABI} == amd64 ]]; then
+ elog "You may want to add USE flag 'abi_x86_32' when running a 64bit system"
+ elog "When added 32bit GLInject libraries are also included. This is"
+ elog "required if you want to use OpenGL recording on 32bit applications."
+ elog
+ fi
+
+ if ( has_version media-video/ffmpeg[x264] || has_version media-video/libav[x264] ) && has_version media-libs/x264[10bit]; then
+ ewarn
+ ewarn "media-libs/x264 is currently built with 10bit useflag."
+ ewarn "This is known to prevent simplescreenrecorder from recording x264 videos"
+ ewarn "correctly. Please build media-libs/x264 without 10bit if you want to "
+ ewarn "record videos with x264."
+ ewarn
+ fi
+
+ # QT requires -fPIC. Compile fails otherwise.
+ # Recently removed from the default compile options upstream
+ # https://github.com/MaartenBaert/ssr/commit/25fe1743058f0d1f95f6fbb39014b6ac146b5180
+ append-flags -fPIC
+}
+
+multilib_src_configure() {
+
+ local myconf=(
+ --enable-dependency-tracking
+ $(multilib_native_use_enable debug assert)
+ $(multilib_native_use_with pulseaudio)
+ $(multilib_native_use_with jack)
+ $(multilib_native_use_with qt5)
+ $(use_enable asm x86-asm)
+ )
+
+ # libav doesn't have AVFrame::channels
+ # https://github.com/MaartenBaert/ssr/issues/195#issuecomment-45646159
+ if has_version media-video/libav; then
+ myconf+=( --disable-ffmpeg-versions )
+ fi
+
+ multilib_is_native_abi || myconf+=( --disable-ssrprogram )
+
+ ECONF_SOURCE="${S}" \
+ econf \
+ ${myconf[@]}
+
+}