summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-tcltk/tkpath/Manifest2
-rw-r--r--dev-tcltk/tkpath/files/man-pages.patch27
-rw-r--r--dev-tcltk/tkpath/tkpath-9999.ebuild55
-rw-r--r--dev-util/idea-community/Manifest4
-rw-r--r--dev-util/idea-community/idea-community-10.0.1.99.32.ebuild37
-rw-r--r--dev-util/idea-community/idea-community-9.0.1.93.94.ebuild2
-rw-r--r--dev-util/idea-ultimate/Manifest2
-rw-r--r--dev-util/idea-ultimate/idea-ultimate-10.0.1.99.32.ebuild37
-rw-r--r--net-im/gajim/Manifest2
-rw-r--r--net-im/gajim/files/window_class.patch46
-rw-r--r--net-im/gajim/gajim-9999.ebuild109
-rw-r--r--profiles/package.mask2
-rw-r--r--sys-libs/libhx/libhx-3.4.ebuild7
-rw-r--r--x11-misc/dzen/Manifest1
-rw-r--r--x11-misc/dzen/dzen-9999.ebuild47
-rw-r--r--x11-wm/wmname/Manifest2
-rw-r--r--x11-wm/wmname/wmname-0.1.ebuild20
17 files changed, 394 insertions, 8 deletions
diff --git a/dev-tcltk/tkpath/Manifest b/dev-tcltk/tkpath/Manifest
new file mode 100644
index 0000000..9298a0a
--- /dev/null
+++ b/dev-tcltk/tkpath/Manifest
@@ -0,0 +1,2 @@
+AUX man-pages.patch 908 RMD160 1f2a0b1ebce3a55aad6f4c86a98726ce7e648ce1 SHA1 e5b5a5c965578bb346c775bfaaca46f8b29cc26c SHA256 83b6ccdeaec481db0386949128f2613740886065ddb17f96460ce4190ceaae87
+EBUILD tkpath-9999.ebuild 978 RMD160 c7e6b8c789840a29aa408d4a1bddc5631f08fe5b SHA1 ff0622106908c5fb1ff9255e1dc4bca39c5f848e SHA256 d51c077a180c59fcde1b47d1902912c32d8b725720be619637bd29e3703f6283
diff --git a/dev-tcltk/tkpath/files/man-pages.patch b/dev-tcltk/tkpath/files/man-pages.patch
new file mode 100644
index 0000000..5e135c1
--- /dev/null
+++ b/dev-tcltk/tkpath/files/man-pages.patch
@@ -0,0 +1,27 @@
+*** Makefile.in 2009-04-01 22:45:45.000000000 +0000
+--- Makefile.in- 2011-01-06 01:12:26.000000000 +0000
+***************
+*** 224,237 ****
+ # directory.
+ #========================================================================
+
+ install-doc: doc
+- @mkdir -p $(DESTDIR)$(mandir)/mann
+- @echo "Installing documentation in $(DESTDIR)$(mandir)"
+- @list='$(srcdir)/doc/*.n'; for i in $$list; do \
+- echo "Installing $$i"; \
+- rm -f $(DESTDIR)$(mandir)/mann/`basename $$i`; \
+- $(INSTALL_DATA) $$i $(DESTDIR)$(mandir)/mann ; \
+- done
+
+ # Piping to cat is necessary on Windows to see the output, and
+ # harmless on Unix
+--- 224,231 ----
+ # directory.
+ #========================================================================
+
++ # no-op target as package has no manual pages
+ install-doc: doc
+
+ # Piping to cat is necessary on Windows to see the output, and
+ # harmless on Unix
diff --git a/dev-tcltk/tkpath/tkpath-9999.ebuild b/dev-tcltk/tkpath/tkpath-9999.ebuild
new file mode 100644
index 0000000..96c1e2b
--- /dev/null
+++ b/dev-tcltk/tkpath/tkpath-9999.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=3
+
+inherit cvs
+
+DESCRIPTION="Tkpath implements path drawing modelled after its SVG counterpart"
+HOMEPAGE="http://tclbitprint.sourceforge.net/"
+SRC_URI=""
+
+ECVS_SERVER="tclbitprint.cvs.sourceforge.net:/cvsroot/tclbitprint"
+ECVS_MODULE="tkpath"
+ECVS_USER="anonymous"
+ECVS_PASS=""
+ECVS_CVS_OPTIONS="-z3 -d"
+ECVS_AUTH="pserver"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS=""
+IUSE="64bit threads"
+
+DEPEND="
+ dev-lang/tk
+ x11-libs/cairo"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/${PN}"
+
+src_prepare() {
+ epatch "${FILESDIR}/man-pages.patch"
+}
+
+src_configure(){
+ cd "${WORKDIR}/${PN}"
+ econf \
+ $(use_enable symbols) \
+ $(use_enable 64bit) \
+ $(use_enable threads)
+}
+
+src_compile() {
+ emake || die
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+ dodoc ChangeLog doc/README.txt || die
+ dodir /usr/share/${PN}/demos
+ insinto /usr/share/${PN}/demos
+ doins demos/*
+}
+
diff --git a/dev-util/idea-community/Manifest b/dev-util/idea-community/Manifest
index f886785..470859a 100644
--- a/dev-util/idea-community/Manifest
+++ b/dev-util/idea-community/Manifest
@@ -1,2 +1,4 @@
-EBUILD idea-community-9.0.1.93.94.ebuild 947 RMD160 a38065bcb92247708c298ffee2fd868a32f3e3ec SHA1 ec8d2b70b7d9f865f845956a1e7e0d1d3b6ab4b0 SHA256 e359f76099d4603f9e322edfa4965313126f3d230d2a10b18139622c1f774a08
+DIST ideaIC-10.0.1.tar.gz 82969729 RMD160 4c781e45b8836414751f12e9ed3090da4aa581b7 SHA1 b58e39e8e0bbef000ab5f4c01dbc8d7c68cd95b9 SHA256 eab3d0ea306faf597a27406c1e242100cc07422bdcb1521f72b37634e6d20606
DIST ideaIC-9.0.1.tar.gz 68263881 RMD160 e3bc3395ad23c29eac9d631c6fc4705481191296 SHA1 39971aa471dbeca1a0637cf868a986d7429439d4 SHA256 9d3a7aafe1103078e9fc4d5a67475be1702acd5df802e256501de3d2c7b96c6e
+EBUILD idea-community-10.0.1.99.32.ebuild 982 RMD160 f6d2f2f36d277a43fb9b358682b5a9491ba7d806 SHA1 c9b750e2a4e8a9198f91f69c58489490a1f0660a SHA256 bffffc90bc95171eb70b18f2420fb617401027dadb460fd307cb54760b72b5d2
+EBUILD idea-community-9.0.1.93.94.ebuild 982 RMD160 f6d2f2f36d277a43fb9b358682b5a9491ba7d806 SHA1 c9b750e2a4e8a9198f91f69c58489490a1f0660a SHA256 bffffc90bc95171eb70b18f2420fb617401027dadb460fd307cb54760b72b5d2
diff --git a/dev-util/idea-community/idea-community-10.0.1.99.32.ebuild b/dev-util/idea-community/idea-community-10.0.1.99.32.ebuild
new file mode 100644
index 0000000..70c02d6
--- /dev/null
+++ b/dev-util/idea-community/idea-community-10.0.1.99.32.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+inherit eutils versionator
+
+SLOT="$(get_major_version)"
+RDEPEND=">=virtual/jdk-1.6"
+
+MY_PV="$(get_version_component_range 4-5)"
+MY_PN="idea"
+
+RESTRICT="strip"
+QA_TEXTRELS="opt/${P}/bin/libbreakgen.so"
+
+DESCRIPTION="IntelliJ IDEA is an intelligent Java IDE"
+HOMEPAGE="http://jetbrains.com/idea/"
+SRC_URI="http://download.jetbrains.com/${MY_PN}/${MY_PN}IC-$(get_version_component_range 1-3).tar.gz"
+LICENSE="IntelliJ-IDEA"
+IUSE=""
+KEYWORDS="~x86 ~amd64"
+S="${WORKDIR}/${MY_PN}-IC-${MY_PV}"
+
+RDEPEND="!dev-util/idea-ultimate"
+
+src_install() {
+ local dir="/opt/${P}"
+ insinto "${dir}"
+ doins -r *
+ fperms 755 "${dir}/bin/${MY_PN}.sh"
+ local exe=${MY_PN}-${SLOT}
+ local icon=${exe}.png
+ newicon "bin/${MY_PN}32.png" ${icon}
+ dodir /usr/bin
+ make_wrapper "$exe" "/opt/${P}/bin/${MY_PN}.sh"
+ make_desktop_entry ${exe} "IntelliJ IDEA ${PV}" ${icon} "Development;IDE"
+}
diff --git a/dev-util/idea-community/idea-community-9.0.1.93.94.ebuild b/dev-util/idea-community/idea-community-9.0.1.93.94.ebuild
index 2bf75fa..70c02d6 100644
--- a/dev-util/idea-community/idea-community-9.0.1.93.94.ebuild
+++ b/dev-util/idea-community/idea-community-9.0.1.93.94.ebuild
@@ -21,6 +21,8 @@ IUSE=""
KEYWORDS="~x86 ~amd64"
S="${WORKDIR}/${MY_PN}-IC-${MY_PV}"
+RDEPEND="!dev-util/idea-ultimate"
+
src_install() {
local dir="/opt/${P}"
insinto "${dir}"
diff --git a/dev-util/idea-ultimate/Manifest b/dev-util/idea-ultimate/Manifest
new file mode 100644
index 0000000..d2f5a18
--- /dev/null
+++ b/dev-util/idea-ultimate/Manifest
@@ -0,0 +1,2 @@
+DIST ideaIU-10.0.1.tar.gz 157460582 RMD160 d24eda685d6b8ed7764c8faf1d85a769040b16eb SHA1 fde779df7c69b27601da10bca906e94aa961ddc7 SHA256 e000823f92a227bcd6c434b2add953ed9ab2f2c5af48ede070b629444566ba51
+EBUILD idea-ultimate-10.0.1.99.32.ebuild 983 RMD160 631a1e42bc227df0e24a3b7f847fb8fe7e94af3f SHA1 6072fb25c8ad3317ffdd9a4c4b11910d60289802 SHA256 d86ed2b6ed387a264b06907f4ccb7f3987aeea308ce666aa50f918d1f5066041
diff --git a/dev-util/idea-ultimate/idea-ultimate-10.0.1.99.32.ebuild b/dev-util/idea-ultimate/idea-ultimate-10.0.1.99.32.ebuild
new file mode 100644
index 0000000..facdf0c
--- /dev/null
+++ b/dev-util/idea-ultimate/idea-ultimate-10.0.1.99.32.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+inherit eutils versionator
+
+SLOT="$(get_major_version)"
+RDEPEND=">=virtual/jdk-1.6"
+
+MY_PV="$(get_version_component_range 4-5)"
+MY_PN="idea"
+
+RESTRICT="strip"
+QA_TEXTRELS="opt/${P}/bin/libbreakgen.so"
+
+DESCRIPTION="IntelliJ IDEA is an intelligent Java IDE"
+HOMEPAGE="http://jetbrains.com/idea/"
+SRC_URI="http://download.jetbrains.com/${MY_PN}/${MY_PN}IU-$(get_version_component_range 1-3).tar.gz"
+LICENSE="IntelliJ-IDEA"
+IUSE=""
+KEYWORDS="~x86 ~amd64"
+S="${WORKDIR}/${MY_PN}-IU-${MY_PV}"
+
+RDEPEND="!dev-util/idea-community"
+
+src_install() {
+ local dir="/opt/${P}"
+ insinto "${dir}"
+ doins -r *
+ fperms 755 "${dir}/bin/${MY_PN}.sh"
+ local exe=${MY_PN}-${SLOT}
+ local icon=${exe}.png
+ newicon "bin/${MY_PN}32.png" ${icon}
+ dodir /usr/bin
+ make_wrapper "$exe" "/opt/${P}/bin/${MY_PN}.sh"
+ make_desktop_entry ${exe} "IntelliJ IDEA ${PV}" ${icon} "Development;IDE"
+}
diff --git a/net-im/gajim/Manifest b/net-im/gajim/Manifest
new file mode 100644
index 0000000..3a32529
--- /dev/null
+++ b/net-im/gajim/Manifest
@@ -0,0 +1,2 @@
+AUX window_class.patch 1723 RMD160 29a38f5a50f9c2890b40b99ab942c1c9c8c5cfc5 SHA1 2298d605b92c7881c3f7ccd8bb61a4c6fadc8fff SHA256 4c7977fa971209ee8882b55aedb459fbe73dd85035eb97767ecb01d6b07d93e7
+EBUILD gajim-9999.ebuild 2384 RMD160 64a9d90368cf11f547b8d690b9f6b1af9a8b92d0 SHA1 82086a03effa660e5e4d6dbe903554c27b0f55fa SHA256 1e8d85e4944569d8f3ae940fb442ef21a61dbd225b4c0b473e5a43edc095ce20
diff --git a/net-im/gajim/files/window_class.patch b/net-im/gajim/files/window_class.patch
new file mode 100644
index 0000000..007cd25
--- /dev/null
+++ b/net-im/gajim/files/window_class.patch
@@ -0,0 +1,46 @@
+diff -r 09d54b679f9d src/message_window.py
+--- a/src/message_window.py Wed Dec 01 17:03:38 2010 +0300
++++ b/src/message_window.py Fri Dec 10 19:14:34 2010 +0300
+@@ -75,6 +75,7 @@
+ self.widget_name = 'message_window'
+ self.xml = gtkgui_helpers.get_gtk_builder('%s.ui' % self.widget_name)
+ self.window = self.xml.get_object(self.widget_name)
++ self.window.set_wmclass("%s - Gajim" % self.make_wmname(False), "gajim[%s]" % self.type_)
+ self.notebook = self.xml.get_object('notebook')
+ self.parent_paned = None
+
+@@ -443,6 +444,20 @@
+ if icon:
+ self.window.set_icon(icon.get_pixbuf())
+
++ def make_wmname(self, translate=True):
++ if not translate:
++ tr = lambda x: x
++ else:
++ tr = _
++ if self.type_ == 'chat':
++ label = tr('Chats')
++ elif self.type_ == 'gc':
++ label = tr('Group Chats')
++ else:
++ label = tr('Private Chats')
++
++ return label
++
+ def show_title(self, urgent=True, control=None):
+ """
+ Redraw the window's title
+@@ -481,12 +496,7 @@
+ window_mode = gajim.interface.msg_win_mgr.mode
+ if window_mode == MessageWindowMgr.ONE_MSG_WINDOW_PERTYPE:
+ # Show the plural form since number of tabs > 1
+- if self.type_ == 'chat':
+- label = _('Chats')
+- elif self.type_ == 'gc':
+- label = _('Group Chats')
+- else:
+- label = _('Private Chats')
++ label = self.make_wmname()
+ elif window_mode == MessageWindowMgr.ONE_MSG_WINDOW_ALWAYS_WITH_ROSTER:
+ label = None
+ elif self.get_num_controls() == 1: \ No newline at end of file
diff --git a/net-im/gajim/gajim-9999.ebuild b/net-im/gajim/gajim-9999.ebuild
new file mode 100644
index 0000000..8f245ec
--- /dev/null
+++ b/net-im/gajim/gajim-9999.ebuild
@@ -0,0 +1,109 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI="2"
+
+inherit eutils mercurial python multilib
+
+PYTHON_DEPEND="2"
+PYTHON_USE_WITH="sqlite xml"
+
+EHG_REPO_URI="http://hg.gajim.org/gajim"
+#EHG_REVISION="default"
+#EHG_BOOTSTRAP="./autogen.sh"
+
+DESCRIPTION="Jabber client written in PyGTK"
+HOMEPAGE="http://www.gajim.org/"
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE="avahi crypt dbus gnome idle jingle libnotify networkmanager nls spell srv X xhtml"
+
+COMMON_DEPEND="
+ x11-libs/gtk+:2
+ >=dev-python/pygtk-2.16.0"
+
+DEPEND="${COMMON_DEPEND}
+ >=sys-devel/gettext-0.17-r1
+ >=dev-util/intltool-0.40.1
+ dev-util/pkgconfig"
+
+RDEPEND="${COMMON_DEPEND}
+ dev-python/pyopenssl
+ dev-python/sexy-python
+ dev-python/pyxdg
+ crypt? (
+ app-crypt/gnupg
+ dev-python/pycrypto
+ )
+ dbus? (
+ dev-python/dbus-python
+ dev-libs/dbus-glib
+ libnotify? ( dev-python/notify-python )
+ avahi? ( net-dns/avahi[dbus,gtk,python] )
+ )
+ gnome? (
+ dev-python/libgnome-python
+ dev-python/gnome-keyring-python
+ dev-python/egg-python
+ )
+ idle? ( x11-libs/libXScrnSaver )
+ jingle? ( net-libs/farsight2[python] )
+ networkmanager? (
+ dev-python/dbus-python
+ || ( >=net-misc/networkmanager-0.7.1 net-misc/networkmanager[gnome] )
+ )
+ srv? (
+ || (
+ dev-python/libasyncns-python
+ net-dns/bind-tools )
+ )
+ spell? ( app-text/gtkspell )
+ xhtml? ( dev-python/docutils )"
+
+pkg_setup() {
+ if ! use dbus; then
+ if use libnotify; then
+ eerror "The dbus USE flag is required for libnotify support"
+ die "USE=\"dbus\" needed for libnotify support"
+ fi
+ if use avahi; then
+ eerror "The dbus USE flag is required for avahi support"
+ die "USE=\"dbus\" needed for avahi support"
+ fi
+ fi
+ python_pkg_setup
+ python_set_active_version 2
+}
+
+src_prepare() {
+ epatch \
+ "${FILESDIR}"/window_class.patch
+ ./autogen.sh || die "autogen.sh failed"
+ echo '#!/bin/sh' > config/py-compile
+}
+
+src_configure() {
+ econf \
+ $(use_enable nls) \
+ $(use_with X x) \
+ --docdir="/usr/share/doc/${PF}" \
+ --libdir="$(python_get_sitedir)" \
+ --enable-site-packages
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+
+ rm "${D}/usr/share/doc/${PF}/"{README.html,COPYING} || die
+ dohtml README.html || die
+}
+
+pkg_postinst() {
+ python_mod_optimize $(python_get_sitedir)/${PN}
+}
+
+pkg_postrm() {
+ python_mod_cleanup $(python_get_sitedir)/${PN}
+}
diff --git a/profiles/package.mask b/profiles/package.mask
index 7fad882..118e8e3 100644
--- a/profiles/package.mask
+++ b/profiles/package.mask
@@ -1,3 +1,3 @@
# Russell Harmon <russ@eatnumber1.com> (19 Jan 2010)
# Broken with assertion errors.
-=x11-plugins/pidgin-omegle-scm
+=x11-plugins/pidgin-omegle-9999
diff --git a/sys-libs/libhx/libhx-3.4.ebuild b/sys-libs/libhx/libhx-3.4.ebuild
index 0f96cda..b4b860f 100644
--- a/sys-libs/libhx/libhx-3.4.ebuild
+++ b/sys-libs/libhx/libhx-3.4.ebuild
@@ -9,15 +9,10 @@ LICENSE="GPL-3"
SLOT="0"
KEYWORDS="~amd64 ~ppc ~x86"
IUSE=""
-DEPEND="virtual/libc
- app-arch/xz-utils"
+DEPEND="virtual/libc"
RDEPEND="${DEPEND}"
S="${WORKDIR}/libHX-${PV}"
-src_unpack() {
- xz -dc -- "${DISTDIR%/}/$A" | tar --no-same-owner -xf - || die "unpack failed"
-}
-
src_compile() {
econf --docdir="/usr/share/doc/${PF}" || die "econf failed"
emake || die "emake failed"
diff --git a/x11-misc/dzen/Manifest b/x11-misc/dzen/Manifest
new file mode 100644
index 0000000..1e9e449
--- /dev/null
+++ b/x11-misc/dzen/Manifest
@@ -0,0 +1 @@
+EBUILD dzen-9999.ebuild 1165 RMD160 769a0521c48018f92dbe14942b0aed30f0c4b113 SHA1 3a1c5a5b4542957fdf997fee7d02efac83bbbe80 SHA256 cb24a2ba848759e759a306b8a816c887f21d5ff9a70ad7768011e92e888a3e68
diff --git a/x11-misc/dzen/dzen-9999.ebuild b/x11-misc/dzen/dzen-9999.ebuild
new file mode 100644
index 0000000..b128253
--- /dev/null
+++ b/x11-misc/dzen/dzen-9999.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+inherit subversion toolchain-funcs
+
+DESCRIPTION="a general purpose messaging, notification and menuing program for
+X11."
+HOMEPAGE="http://gotmor.googlepages.com/dzen"
+SRC_URI=""
+ESVN_REPO_URI="http://dzen.googlecode.com/svn/trunk/"
+
+LICENSE="MIT"
+SLOT="2"
+KEYWORDS=""
+IUSE="minimal xinerama xpm"
+
+DEPEND="x11-libs/libX11
+ xinerama? ( x11-libs/libXinerama )
+ xpm? ( x11-libs/libXpm )"
+RDEPEND="${DEPEND}"
+
+src_unpack() {
+ subversion_src_unpack
+
+ cd "${S}"
+ sed -e "s/\/usr\/local/\/usr/g" -e "s/-Os/${CFLAGS}/g" \
+ -e "s/CC =.*/CC = $(tc-getCC | sed -e 's/\//\\\//g')/g" \
+ -e "s/LD =.*/LD = $(tc-getCC | sed -e 's/\//\\\//g')/g" \
+ -i config.mk || die "sed failed"
+
+ if use xinerama ; then
+ sed -e "/^LIBS/s/$/\ -lXinerama/" \
+ -e "/^CFLAGS/s/$/\ -DDZEN_XINERAMA/" \
+ -i config.mk || die "sed failed"
+ fi
+ if use xpm ; then
+ sed -e "/^LIBS/s/$/\ -lXpm/" \
+ -e "/^CFLAGS/s/$/\ -DDZEN_XPM/" \
+ -i config.mk || die "sed failed"
+ fi
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+ dodoc README TODO
+}
diff --git a/x11-wm/wmname/Manifest b/x11-wm/wmname/Manifest
new file mode 100644
index 0000000..afd15c7
--- /dev/null
+++ b/x11-wm/wmname/Manifest
@@ -0,0 +1,2 @@
+DIST wmname-0.1.tar.gz 2512 RMD160 88e52d49576ae472a45bd40c79ec04071160bbce SHA1 7bce60306ccc9c9a5fc60d9874e81a013efa8871 SHA256 559ad188b2913167dcbb37ecfbb7ed474a7ec4bbcb0129d8d5d08cb9208d02c5
+EBUILD wmname-0.1.ebuild 393 RMD160 2af46fa922aee76442166175d7bd3d5ee32a30c2 SHA1 058bcae783e9c6f07515ba56fadba73f370a00be SHA256 5527fd699c04854daeea716d47e1ec77db6b14be875281f96a0d4561c202b4c9
diff --git a/x11-wm/wmname/wmname-0.1.ebuild b/x11-wm/wmname/wmname-0.1.ebuild
new file mode 100644
index 0000000..e46676b
--- /dev/null
+++ b/x11-wm/wmname/wmname-0.1.ebuild
@@ -0,0 +1,20 @@
+EAPI="2"
+
+DESCRIPTION="wmname prints/sets the window manager name property of the root
+window similar to how hostname(1) behaves."
+HOMEPAGE="http://tools.suckless.org/wmname"
+SRC_URI="http://dl.suckless.org/tools/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="x11-libs/libX11"
+RDEPEND="${DEPEND}"
+
+src_install() {
+ dodoc README
+ exeinto /usr/bin
+ doexe "${PN}"
+}