aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-libs/libx86/libx86-1.1-r4.ebuild')
-rw-r--r--dev-libs/libx86/libx86-1.1-r4.ebuild52
1 files changed, 52 insertions, 0 deletions
diff --git a/dev-libs/libx86/libx86-1.1-r4.ebuild b/dev-libs/libx86/libx86-1.1-r4.ebuild
new file mode 100644
index 0000000..78fdfc3
--- /dev/null
+++ b/dev-libs/libx86/libx86-1.1-r4.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2019 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit eutils toolchain-funcs flag-o-matic
+
+DESCRIPTION="A hardware-independent library for executing real-mode x86 code"
+HOMEPAGE="https://www.codon.org.uk/~mjg59/libx86/"
+SRC_URI="https://www.codon.org.uk/~mjg59/${PN}/downloads/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="amd64 ~arm x86"
+IUSE="static-libs"
+
+src_prepare() {
+ # fix compile failure with linux-headers-2.6.26, bug 235599
+ eapply -p0 "${FILESDIR}/${PN}-0.99-ifmask.patch"
+ # Patch for bugs #236888 and #456648
+ eapply -p0 "${FILESDIR}/${P}-makefile.patch"
+ # Wider arch compatibility, bug #579682
+ eapply -p2 "${FILESDIR}/${P}-x86emu.patch"
+ # Add support for pkgconfig (enables newer versions of vbetool to link against this)
+ eapply "${FILESDIR}"/${P}-add-pkgconfig.patch
+
+ eapply_user
+}
+
+src_configure() {
+ tc-export CC AR
+ append-flags -fno-delete-null-pointer-checks #523276
+}
+
+src_compile() {
+ local ARGS
+ use x86 || ARGS="BACKEND=x86emu"
+ emake ${ARGS} LIBRARY=shared shared
+ if use static-libs; then
+ emake ${ARGS} objclean
+ emake ${ARGS} LIBRARY=static static
+ fi
+}
+
+src_install() {
+ local install_static;
+ use static-libs && install_static='install-static'
+ emake \
+ LIBDIR="/usr/$(get_libdir)" \
+ DESTDIR="${D}" \
+ install-header install-shared install-pkgconfig ${install_static}
+}