summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authoreroen <eroen-overlay@occam.eroen.eu>2016-10-16 17:28:13 +0200
committereroen <eroen-overlay@occam.eroen.eu>2016-10-20 19:32:18 +0200
commit6db71629bcc820fa6d95d1f9a3a361dcfc9c00e9 (patch)
tree2ad3718a428427ffbfb48f679341f78b72ea312a
parentcleanup (diff)
downloaderoen-6db71629bcc820fa6d95d1f9a3a361dcfc9c00e9.tar.gz
eroen-6db71629bcc820fa6d95d1f9a3a361dcfc9c00e9.tar.bz2
eroen-6db71629bcc820fa6d95d1f9a3a361dcfc9c00e9.zip
covim-20160108 - bump
-rw-r--r--app-vim/covim/Manifest1
-rw-r--r--app-vim/covim/covim-20160108.ebuild42
-rw-r--r--app-vim/covim/covim-99999999.ebuild42
-rw-r--r--app-vim/covim/metadata.xml7
4 files changed, 70 insertions, 22 deletions
diff --git a/app-vim/covim/Manifest b/app-vim/covim/Manifest
new file mode 100644
index 00000000..9d647090
--- /dev/null
+++ b/app-vim/covim/Manifest
@@ -0,0 +1 @@
+DIST covim-20160108.tar.gz 8675 SHA256 cde06b8a61f8bb6662dc5134daa2ac0a377de4d44ce83467d58f765790791dc4 SHA512 b4b772ed5225b304fc085937e7cabdbc2341d50e2625daf465dd207a2283fd2e0d1fd12aedb5e3cee4320f04f59ddfce9b96ee18d70d773f09ffe50180f447dd WHIRLPOOL 67f2d1831aef04c72f2a9f6e8451d72b894dd3bb073916662ab2ac95d7f7738c838ed460f3be35c1493004a3c9791726136dcde27f18e36f684e08cae804cf73
diff --git a/app-vim/covim/covim-20160108.ebuild b/app-vim/covim/covim-20160108.ebuild
new file mode 100644
index 00000000..147fd9fc
--- /dev/null
+++ b/app-vim/covim/covim-20160108.ebuild
@@ -0,0 +1,42 @@
+# By eroen <eroen-overlay@occam.eroen.eu>, 2013 - 2016
+# Permission to use, copy, modify, and/or distribute this software for any
+# purpose with or without fee is hereby granted, provided that the above
+# copyright notice and this permission notice appear in all copies.
+
+EAPI=6
+PYTHON_COMPAT=(python2_7)
+
+inherit eutils python-r1 vim-plugin
+
+DESCRIPTION="Collaborative Editing for Vim"
+HOMEPAGE="https://github.com/FredKSchott/CoVim"
+LICENSE="MIT"
+IUSE=""
+
+if [[ ${PV} == 99999999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="git://github.com/FredKSchott/CoVim.git"
+else
+ KEYWORDS="~amd64"
+ #EGIT_COMMIT=
+ inherit vcs-snapshot
+ SRC_URI="https://github.com/FredKSchott/CoVim/archive/181ed37d6c2778f26d29775009d1e657c6c701a9.tar.gz -> $P.tar.gz"
+fi
+
+RDEPEND="${PYTHON_DEPS}
+ dev-python/twisted-core[${PYTHON_USEDEP}]
+ app-editors/vim[python,${PYTHON_USEDEP}]"
+
+VIM_PLUGIN_HELPFILES="CoVim"
+
+src_prepare() {
+ default
+ rm -f LICENSE || die
+}
+
+src_install() {
+ eshopts_push -u failglob
+ vim-plugin_src_install
+ eshopts_pop
+ python_replicate_script "${ED}"/usr/share/vim/vimfiles/plugin/CoVimServer.py
+}
diff --git a/app-vim/covim/covim-99999999.ebuild b/app-vim/covim/covim-99999999.ebuild
index 5520d758..147fd9fc 100644
--- a/app-vim/covim/covim-99999999.ebuild
+++ b/app-vim/covim/covim-99999999.ebuild
@@ -1,42 +1,42 @@
-# By eroen, 2013 - 2015
-# Distributed under the terms of the ISC licence
-# $Header: $
+# By eroen <eroen-overlay@occam.eroen.eu>, 2013 - 2016
+# Permission to use, copy, modify, and/or distribute this software for any
+# purpose with or without fee is hereby granted, provided that the above
+# copyright notice and this permission notice appear in all copies.
-EAPI=5
+EAPI=6
PYTHON_COMPAT=(python2_7)
-#VIM_PLUGIN_VIM_VERSION="7.0"
-inherit python-single-r1 vim-plugin git-2
+inherit eutils python-r1 vim-plugin
DESCRIPTION="Collaborative Editing for Vim"
HOMEPAGE="https://github.com/FredKSchott/CoVim"
LICENSE="MIT"
IUSE=""
-SRC_URI=
-EGIT_REPO_URI="git://github.com/FredKSchott/CoVim.git"
-if ! [[ ${PV} == 99999999 ]]; then
+if [[ ${PV} == 99999999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="git://github.com/FredKSchott/CoVim.git"
+else
KEYWORDS="~amd64"
#EGIT_COMMIT=
+ inherit vcs-snapshot
+ SRC_URI="https://github.com/FredKSchott/CoVim/archive/181ed37d6c2778f26d29775009d1e657c6c701a9.tar.gz -> $P.tar.gz"
fi
-VIM_PLUGIN_HELPFILES="CoVim"
-VIM_PLUGIN_HELPTEXT=""
-VIM_PLUGIN_HELPURI=""
-VIM_PLUGIN_MESSAGES=""
-
-LDEPEND="
- ${PYTHON_DEPS}
- dev-python/twisted-core
+RDEPEND="${PYTHON_DEPS}
+ dev-python/twisted-core[${PYTHON_USEDEP}]
app-editors/vim[python,${PYTHON_USEDEP}]"
-RDEPEND="${LDEPEND}"
+
+VIM_PLUGIN_HELPFILES="CoVim"
src_prepare() {
- python_fix_shebang plugin/CoVimServer.py
- rm LICENSE
+ default
+ rm -f LICENSE || die
}
src_install() {
+ eshopts_push -u failglob
vim-plugin_src_install
- chmod ugo+x "${D}"/usr/share/vim/vimfiles/plugin/CoVimServer.py || die
+ eshopts_pop
+ python_replicate_script "${ED}"/usr/share/vim/vimfiles/plugin/CoVimServer.py
}
diff --git a/app-vim/covim/metadata.xml b/app-vim/covim/metadata.xml
index 319d6c4b..243f7c9c 100644
--- a/app-vim/covim/metadata.xml
+++ b/app-vim/covim/metadata.xml
@@ -1,7 +1,12 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
+ <maintainer type="person">
+ <email>eroen-overlay@occam.eroen.eu</email>
+ <name>eroen</name>
+ </maintainer>
<longdescription lang="en">
-CoVim is a Vim Plugin that adds real-time collaboration to your favorite text editor. Think Google Docs for Vim.
+ CoVim is a Vim Plugin that adds real-time collaboration to your
+ favorite text editor. Think Google Docs for Vim.
</longdescription>
</pkgmetadata>