summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAaron Mavrinac <mavrinac@gmail.com>2014-01-26 12:58:38 -0800
committerAaron Mavrinac <mavrinac@gmail.com>2014-01-26 12:58:38 -0800
commitff8b9409d417453d4b15c6126f8be40a86840919 (patch)
treed2fccbc1161964acda3435b1b34bb59e940bed85
parentInitial import of dev-vcs/wstool. (diff)
downloadezod-ff8b9409d417453d4b15c6126f8be40a86840919.tar.gz
ezod-ff8b9409d417453d4b15c6126f8be40a86840919.tar.bz2
ezod-ff8b9409d417453d4b15c6126f8be40a86840919.zip
Add multiple ROS infrastructure packages.
-rw-r--r--sci-electronics/catkin_pkg/Manifest3
-rw-r--r--sci-electronics/catkin_pkg/catkin_pkg-0.1.25.ebuild19
-rw-r--r--sci-electronics/catkin_pkg/metadata.xml (renamed from sci-electronics/rosinstall/metadata.xml)0
-rw-r--r--sci-electronics/rosdep/Manifest3
-rw-r--r--sci-electronics/rosdep/metadata.xml8
-rw-r--r--sci-electronics/rosdep/rosdep-0.10.25.ebuild21
-rw-r--r--sci-electronics/rosdistro/Manifest3
-rw-r--r--sci-electronics/rosdistro/metadata.xml8
-rw-r--r--sci-electronics/rosdistro/rosdistro-0.3.0.ebuild19
-rw-r--r--sci-electronics/rosinstall/Manifest3
-rw-r--r--sci-electronics/rosinstall/rosinstall-0.5.30.ebuild39
-rw-r--r--sci-electronics/rosinstall_generator/Manifest3
-rw-r--r--sci-electronics/rosinstall_generator/metadata.xml8
-rw-r--r--sci-electronics/rosinstall_generator/rosinstall_generator-0.1.6.ebuild27
-rw-r--r--sci-electronics/rospkg/Manifest3
-rw-r--r--sci-electronics/rospkg/metadata.xml8
-rw-r--r--sci-electronics/rospkg/rospkg-1.0.26.ebuild19
17 files changed, 152 insertions, 42 deletions
diff --git a/sci-electronics/catkin_pkg/Manifest b/sci-electronics/catkin_pkg/Manifest
new file mode 100644
index 0000000..66110de
--- /dev/null
+++ b/sci-electronics/catkin_pkg/Manifest
@@ -0,0 +1,3 @@
+DIST 0.1.25.tar.gz 39708 SHA256 2d131d5304a96a192fe82948da55888c02213b3b219a2eb2f6e099552b9ef8db SHA512 b9245c1c268a6928bd8ee6c16b145acfc9d1bc9ba8990185d55c0e43d5c66f89390ece82e4085fbab67e87dbd529fd22605075e428f90789879934be4685ab22 WHIRLPOOL 0fafd02504f744702581f6fca70ab55ccb3faf0f858e93680bf6e89b75534fcc35ab9dbd1b84a1f687a34da9e84c83fe7f57b4271c14c70478d7f82e4e26d606
+EBUILD catkin_pkg-0.1.25.ebuild 402 SHA256 0ee87c6b0d9f48d1bb62865f496bf491f3ab69b58799ccfa049c3c96b0596b89 SHA512 c5433525f432a3f0e17f8a83fdb2e00eeba877f191a8bb40332db11cf58b9d1efcb0fb6b1cd2ec9ad794391975fe192f5600eca56a1a45d0ad83ab6f6ecf8412 WHIRLPOOL 49fa67825d84b43bb9442ecaa8076022a2ec6a96b7d137e55eaac0a715e68b1c5d8643a85cdc629cbb1be265df270294bad5c197de96a79c53fafb5c2cdeab90
+MISC metadata.xml 230 SHA256 0ef810189a3667f1a7527037968f2b88fae043d5efcaaaa27e33287da96783b6 SHA512 b9c898bc7cb011529f94da9422545612e75b433be28f432b226c6282571834c1d34c10027eb2f3a07fa5fd8629bebcc80bc3ab59d8050ab2042e949a7efca15d WHIRLPOOL 49d68dca67360d47398f1e5b16fae0d9df893bd30a9714c6e800261254bd93320fcf5884fd9eadbbe9cbb2a668d9256845778ae21a65e24d94bb98610596afb2
diff --git a/sci-electronics/catkin_pkg/catkin_pkg-0.1.25.ebuild b/sci-electronics/catkin_pkg/catkin_pkg-0.1.25.ebuild
new file mode 100644
index 0000000..8dddc22
--- /dev/null
+++ b/sci-electronics/catkin_pkg/catkin_pkg-0.1.25.ebuild
@@ -0,0 +1,19 @@
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="4-python"
+PYTHON_MULTIPLE_ABIS="1"
+
+inherit distutils
+
+DESCRIPTION="Standalone Python library for the catkin build system."
+HOMEPAGE="http://www.ros.org"
+SRC_URI="https://github.com/ros-infrastructure/${PN}/archive/${PV}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE=""
+
+DEPEND="dev-util/cmake"
+RDEPEND="${DEPEND}"
+
diff --git a/sci-electronics/rosinstall/metadata.xml b/sci-electronics/catkin_pkg/metadata.xml
index 3510201..3510201 100644
--- a/sci-electronics/rosinstall/metadata.xml
+++ b/sci-electronics/catkin_pkg/metadata.xml
diff --git a/sci-electronics/rosdep/Manifest b/sci-electronics/rosdep/Manifest
new file mode 100644
index 0000000..25a4899
--- /dev/null
+++ b/sci-electronics/rosdep/Manifest
@@ -0,0 +1,3 @@
+DIST 0.10.25.tar.gz 99732 SHA256 71d840b51ed25b225072dc3d7c0706408dea0cb15d2c3cd0aac5b78163368bb3 SHA512 8ea0322e2b75033dc86a180f4b2a81024620e6d16f49f4643849f0f537eaddd90cdc5943d58afebecd94c19f787dc7d1edda4980d64b1001816f92d65c5b9764 WHIRLPOOL 9f78483ce8a1b1db091d33ed57c2350fb9aeb056743e5371bfafd53ef21fc7ebb43b5b10ae1751a68f4877518632a886dc74b07e76ac4a39c16952c4dad89885
+EBUILD rosdep-0.10.25.ebuild 457 SHA256 b9c66111f4727cd2030ddd59c3d5ab4aac6cb5ec701207f0418a882543785439 SHA512 4bf07c28b8cdc6acbe99bd353b54b1e766baba2d8a72fca75045819470d63893b72c6da8d5d15956e9d04de1929c053bd65574a86cdd41a9ed3b4dcf829818f2 WHIRLPOOL a352193430bd64d6f6c120c26748807c5d3334e1a5857e59a7b6c11d7878e507d84e029331a3afcb0c9979a8c0413fcaa2c5e06d5a0c3dc0a0e073ee3cc47b97
+MISC metadata.xml 230 SHA256 0ef810189a3667f1a7527037968f2b88fae043d5efcaaaa27e33287da96783b6 SHA512 b9c898bc7cb011529f94da9422545612e75b433be28f432b226c6282571834c1d34c10027eb2f3a07fa5fd8629bebcc80bc3ab59d8050ab2042e949a7efca15d WHIRLPOOL 49d68dca67360d47398f1e5b16fae0d9df893bd30a9714c6e800261254bd93320fcf5884fd9eadbbe9cbb2a668d9256845778ae21a65e24d94bb98610596afb2
diff --git a/sci-electronics/rosdep/metadata.xml b/sci-electronics/rosdep/metadata.xml
new file mode 100644
index 0000000..3510201
--- /dev/null
+++ b/sci-electronics/rosdep/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer>
+ <email>mavrinac@gmail.com</email>
+ <name>Aaron Mavrinac</name>
+</maintainer>
+</pkgmetadata>
diff --git a/sci-electronics/rosdep/rosdep-0.10.25.ebuild b/sci-electronics/rosdep/rosdep-0.10.25.ebuild
new file mode 100644
index 0000000..d819076
--- /dev/null
+++ b/sci-electronics/rosdep/rosdep-0.10.25.ebuild
@@ -0,0 +1,21 @@
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="4-python"
+PYTHON_MULTIPLE_ABIS="1"
+
+inherit distutils
+
+DESCRIPTION="rosdep multi-package manager system dependency tool."
+HOMEPAGE="http://www.ros.org"
+SRC_URI="https://github.com/ros-infrastructure/${PN}/archive/${PV}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE=""
+
+DEPEND="sci-electronics/catkin_pkg
+ sci-electronics/rospkg
+ dev-python/pyyaml"
+RDEPEND="${DEPEND}"
+
diff --git a/sci-electronics/rosdistro/Manifest b/sci-electronics/rosdistro/Manifest
new file mode 100644
index 0000000..ce5a998
--- /dev/null
+++ b/sci-electronics/rosdistro/Manifest
@@ -0,0 +1,3 @@
+DIST 0.3.0.tar.gz 49164 SHA256 0d2dc349c56f389f5bf803f6462a4dba150117f8c319eec2a68cd6bd882c7621 SHA512 797e927a199da3d61104337aaf3d80312e3eca8a9c9d0e086c8ad57093732ff3bbc47d49c9cc3a332fbfbbb9e3fb41cce53f025e7c01363cf6bf463b8583f600 WHIRLPOOL 82f8045c6b2e74a98e0628fbc356744fa2992b7f1db6ac5e7c7736481ab0fed0c96d83c6503484b4a595c92cea51ba4589440fd30ce1f475f8cd969d58db415f
+EBUILD rosdistro-0.3.0.ebuild 397 SHA256 5a501d24680fabfd5d0c176a4962f87c749f958adab2a79782848488e14dc61c SHA512 51b34ac3833b3cad9bfc22a98218f98432ffcf6085baef4324c39c87a2df09da95fe0dbb8ea94252901f2320bc100decebca6fbee39960b7bdb2b6b9c408f8e5 WHIRLPOOL 660b1f6b613b60798327608664880520940fe2e9d983ae8c7ef284e8deabea9460d25632782c2f3d31a0a9910500fdb5aec30c77c2b9ca69af5309a10dfb9fd2
+MISC metadata.xml 230 SHA256 0ef810189a3667f1a7527037968f2b88fae043d5efcaaaa27e33287da96783b6 SHA512 b9c898bc7cb011529f94da9422545612e75b433be28f432b226c6282571834c1d34c10027eb2f3a07fa5fd8629bebcc80bc3ab59d8050ab2042e949a7efca15d WHIRLPOOL 49d68dca67360d47398f1e5b16fae0d9df893bd30a9714c6e800261254bd93320fcf5884fd9eadbbe9cbb2a668d9256845778ae21a65e24d94bb98610596afb2
diff --git a/sci-electronics/rosdistro/metadata.xml b/sci-electronics/rosdistro/metadata.xml
new file mode 100644
index 0000000..3510201
--- /dev/null
+++ b/sci-electronics/rosdistro/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer>
+ <email>mavrinac@gmail.com</email>
+ <name>Aaron Mavrinac</name>
+</maintainer>
+</pkgmetadata>
diff --git a/sci-electronics/rosdistro/rosdistro-0.3.0.ebuild b/sci-electronics/rosdistro/rosdistro-0.3.0.ebuild
new file mode 100644
index 0000000..dd9cb54
--- /dev/null
+++ b/sci-electronics/rosdistro/rosdistro-0.3.0.ebuild
@@ -0,0 +1,19 @@
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="4-python"
+PYTHON_MULTIPLE_ABIS="1"
+
+inherit distutils
+
+DESCRIPTION="Tools to work with catkinized rosdistro files."
+HOMEPAGE="http://www.ros.org"
+SRC_URI="https://github.com/ros-infrastructure/${PN}/archive/${PV}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE=""
+
+DEPEND="dev-python/pyyaml"
+RDEPEND="${DEPEND}"
+
diff --git a/sci-electronics/rosinstall/Manifest b/sci-electronics/rosinstall/Manifest
deleted file mode 100644
index 9dc2cde..0000000
--- a/sci-electronics/rosinstall/Manifest
+++ /dev/null
@@ -1,3 +0,0 @@
-DIST rosinstall-0.5.30.tar.gz 18029 RMD160 ab43c3044b17971f1132c5df87f79fc8ee89324c SHA1 867c2640da689afb1c5cf272c4fdd6424481ce6d SHA256 13fe4b97b785e5477c209eeb32f784c7bce9ae7ab8efcad61bbe85effbfe8396
-EBUILD rosinstall-0.5.30.ebuild 762 RMD160 9759d5e95c2d15b04fece2a9e31b85448af7c6c8 SHA1 d98febbc7cad7a576215b805ca4f43ed3347f07e SHA256 bde3c02eeb83764ce503b5370bfc893490614e746e96b6dd8416bd1a56b4212d
-MISC metadata.xml 230 RMD160 65b1879f0881b046ac536157a1b73ae8e08a8a23 SHA1 14b143872462f3e5df4ac14bb0e872f1dc762ef0 SHA256 0ef810189a3667f1a7527037968f2b88fae043d5efcaaaa27e33287da96783b6
diff --git a/sci-electronics/rosinstall/rosinstall-0.5.30.ebuild b/sci-electronics/rosinstall/rosinstall-0.5.30.ebuild
deleted file mode 100644
index b9f4865..0000000
--- a/sci-electronics/rosinstall/rosinstall-0.5.30.ebuild
+++ /dev/null
@@ -1,39 +0,0 @@
-# Copyright 2008-2012 Funtoo Technologies
-# Distributed under the terms of the GNU General Public License v2
-# $Header: $
-
-EAPI=4
-PYTHON_DEPEND="2"
-
-inherit distutils
-
-DESCRIPTION="The installer for ROS"
-HOMEPAGE="http://www.ros.org/wiki"
-SRC_URI="
- mirror://pypi/r/${PN}/${P}.tar.gz
- http://pr.willowgarage.com/downloads/${PN}/${P}.tar.gz
-"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="amd64 x86"
-IUSE=""
-
-DEPEND="
- dev-python/setuptools
-"
-RDEPEND="
- dev-python/pyyaml
- dev-python/vcstools
-"
-
-src_install () {
- distutils_src_install
-
- # fix for Funtoo users
- if [ `cut -f1 -d' ' < /etc/gentoo-release` == "Funtoo" ]; then
- version=`cut -f5 -d' ' < /etc/gentoo-release`
- echo "ROS_OS_OVERRIDE=\"gentoo:$version\"" > "${T}"/50rosinstall
- doenvd "${T}"/50rosinstall
- fi
-}
diff --git a/sci-electronics/rosinstall_generator/Manifest b/sci-electronics/rosinstall_generator/Manifest
new file mode 100644
index 0000000..c5ffba1
--- /dev/null
+++ b/sci-electronics/rosinstall_generator/Manifest
@@ -0,0 +1,3 @@
+DIST 0.1.6.tar.gz 8399 SHA256 9bc54cbef98c0e67332eefdc260efbd0647c6c1cb1edf8bdfe7e424af2ce3819 SHA512 302b675ef9d503793e834be2b2952bc4494f2b87324314cd0193f94c58fa391a92cea515d4d30109bc188d71e542cf67ba9d271ecc75c9bb194a7c461d6b9a65 WHIRLPOOL b3b3300048bf981e8684b6576551d043ad6773ff0d4e5c9ff9127f0ff3b8c4914478445f37c00892ab211c7cb6a61037a52751ec59f72fe1a081690ba82ab508
+EBUILD rosinstall_generator-0.1.6.ebuild 641 SHA256 de494738c5038b0a5aae7a8ba9ef6410caf7480a52f58d2420d56b75c648da6c SHA512 fa9f3a0d15496fc90acafe938ee41fc914bc810fa6367616d1b3ab32f54d16a3414cb8a3630f7b2d5f4b09302ff169d4a17e97e975e06a2853933341931c798b WHIRLPOOL 61c7b3543e9d05658db87debcc11fe7c47d708d3db54f1ef0381bb0c2c3fffa0d785c46b6ae4afc685043d39cc624aa4636b7c09cb9dbbf8aa3dcd558bbe1041
+MISC metadata.xml 230 SHA256 0ef810189a3667f1a7527037968f2b88fae043d5efcaaaa27e33287da96783b6 SHA512 b9c898bc7cb011529f94da9422545612e75b433be28f432b226c6282571834c1d34c10027eb2f3a07fa5fd8629bebcc80bc3ab59d8050ab2042e949a7efca15d WHIRLPOOL 49d68dca67360d47398f1e5b16fae0d9df893bd30a9714c6e800261254bd93320fcf5884fd9eadbbe9cbb2a668d9256845778ae21a65e24d94bb98610596afb2
diff --git a/sci-electronics/rosinstall_generator/metadata.xml b/sci-electronics/rosinstall_generator/metadata.xml
new file mode 100644
index 0000000..3510201
--- /dev/null
+++ b/sci-electronics/rosinstall_generator/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer>
+ <email>mavrinac@gmail.com</email>
+ <name>Aaron Mavrinac</name>
+</maintainer>
+</pkgmetadata>
diff --git a/sci-electronics/rosinstall_generator/rosinstall_generator-0.1.6.ebuild b/sci-electronics/rosinstall_generator/rosinstall_generator-0.1.6.ebuild
new file mode 100644
index 0000000..fc348bd
--- /dev/null
+++ b/sci-electronics/rosinstall_generator/rosinstall_generator-0.1.6.ebuild
@@ -0,0 +1,27 @@
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="4-python"
+PYTHON_MULTIPLE_ABIS="1"
+
+inherit distutils
+
+DESCRIPTION="Installer for ROS (robot operating system)."
+HOMEPAGE="http://ww.ros.org"
+SRC_URI="https://github.com/ros-infrastructure/${PN}/archive/${PV}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE="git mercurial subversion"
+
+DEPEND="sci-electronics/catkin_pkg
+ sci-electronics/rospkg
+ sci-electronics/rosdistro
+ dev-vcs/wstool
+ dev-python/setuptools
+ dev-python/pyyaml
+ git? ( dev-vcs/git )
+ mercurial? ( dev-vcs/mercurial )
+ subversion? ( dev-vcs/subversion )"
+RDEPEND="${DEPEND}"
+
diff --git a/sci-electronics/rospkg/Manifest b/sci-electronics/rospkg/Manifest
new file mode 100644
index 0000000..b597920
--- /dev/null
+++ b/sci-electronics/rospkg/Manifest
@@ -0,0 +1,3 @@
+DIST 1.0.26.tar.gz 88469 SHA256 c70aa68c5ff5e97245c9796a69f61465c507b32853e74fd0f4e15c30259bc1d0 SHA512 724cd85fa72bf154feb6ef02b7d86edd229f9f00b09c52a4c0778c57cffe3419527909b5400232305d0b855ac2cc2db8f4c2fa3e916f315317b1a31ad4034dae WHIRLPOOL abf62292c8cd37fcadbfeb120a279047ae916b76af66579d513b77c7de4acc165b423158dd08b067da404857105c8e9e588115012bbc761097db4144efaf63b7
+EBUILD rospkg-1.0.26.ebuild 381 SHA256 b6b0020ac52f79d465f1da5beded9a7221423333ef9d5d234f40d1f136542991 SHA512 4adf534d8b33aa999d32fc1130b9e28101777405ccbca9c09fdf828c23068931c7eca0d4e71ba6bb2cf6b4d787e96c465be818b98dc879496e1d933827e89567 WHIRLPOOL e7f4823236bcd0200569928efe41cfd4c5cabcc0db01de569df0e96375d0bb2a9c24e9234261425e1cbe7f2fde3125453d28467320b969ac98b424b0e2d669a3
+MISC metadata.xml 230 SHA256 0ef810189a3667f1a7527037968f2b88fae043d5efcaaaa27e33287da96783b6 SHA512 b9c898bc7cb011529f94da9422545612e75b433be28f432b226c6282571834c1d34c10027eb2f3a07fa5fd8629bebcc80bc3ab59d8050ab2042e949a7efca15d WHIRLPOOL 49d68dca67360d47398f1e5b16fae0d9df893bd30a9714c6e800261254bd93320fcf5884fd9eadbbe9cbb2a668d9256845778ae21a65e24d94bb98610596afb2
diff --git a/sci-electronics/rospkg/metadata.xml b/sci-electronics/rospkg/metadata.xml
new file mode 100644
index 0000000..3510201
--- /dev/null
+++ b/sci-electronics/rospkg/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer>
+ <email>mavrinac@gmail.com</email>
+ <name>Aaron Mavrinac</name>
+</maintainer>
+</pkgmetadata>
diff --git a/sci-electronics/rospkg/rospkg-1.0.26.ebuild b/sci-electronics/rospkg/rospkg-1.0.26.ebuild
new file mode 100644
index 0000000..3fb7a95
--- /dev/null
+++ b/sci-electronics/rospkg/rospkg-1.0.26.ebuild
@@ -0,0 +1,19 @@
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="4-python"
+PYTHON_MULTIPLE_ABIS="1"
+
+inherit distutils
+
+DESCRIPTION="rospkg Python library for ROS."
+HOMEPAGE="http://www.ros.org"
+SRC_URI="https://github.com/ros-infrastructure/${PN}/archive/${PV}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE=""
+
+DEPEND="dev-python/pyyaml"
+RDEPEND="${DEPEND}"
+