summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAaron Mavrinac <mavrinac@gmail.com>2008-10-08 12:10:56 -0400
committerAaron Mavrinac <mavrinac@gmail.com>2008-10-08 12:10:56 -0400
commit3f2f59cd22ab0161eca2e77b334fbdc6fa7711c5 (patch)
tree68864a7f572c1472cd8e621dfe361370164080b0 /sci-libs
parentFilled out metadata.xml for 2 ebuilds. (diff)
downloadezod-3f2f59cd22ab0161eca2e77b334fbdc6fa7711c5.tar.gz
ezod-3f2f59cd22ab0161eca2e77b334fbdc6fa7711c5.tar.bz2
ezod-3f2f59cd22ab0161eca2e77b334fbdc6fa7711c5.zip
Initial import of sci-libs/tina-libs ebuild.
Diffstat (limited to 'sci-libs')
-rw-r--r--sci-libs/tina-libs/ChangeLog8
-rw-r--r--sci-libs/tina-libs/Manifest4
-rw-r--r--sci-libs/tina-libs/metadata.xml13
-rw-r--r--sci-libs/tina-libs/tina-libs-20081008.ebuild35
4 files changed, 60 insertions, 0 deletions
diff --git a/sci-libs/tina-libs/ChangeLog b/sci-libs/tina-libs/ChangeLog
new file mode 100644
index 0000000..f8b61aa
--- /dev/null
+++ b/sci-libs/tina-libs/ChangeLog
@@ -0,0 +1,8 @@
+# ChangeLog for sci-libs/tina-libs
+# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
+# $Header: $
+
+*tina-libs-20081008 (08 Oct 2008)
+
+ 08 Oct 2008; Aaron Mavrinac <mavrinac@gmail.com> tina-libs-20081008.ebuild:
+ Initial import
diff --git a/sci-libs/tina-libs/Manifest b/sci-libs/tina-libs/Manifest
new file mode 100644
index 0000000..4b8842d
--- /dev/null
+++ b/sci-libs/tina-libs/Manifest
@@ -0,0 +1,4 @@
+DIST tina_libs_v5_devel_2008-10-08.tar.gz 1211618 RMD160 3a1fd8fd5599382df6191c6e2a41e034cb0ead0a SHA1 fd5c9e19aadc54e472ab6797f14e2f7476ebf149 SHA256 80115bb8aa32ce710756a0c8faece60e5b98e6661f3feef02f66858b60edc4e8
+EBUILD tina-libs-20081008.ebuild 696 RMD160 8e09cee689878fcec7afe5b905a9b7433df7e99e SHA1 8d7cb76d899f495657d7c9c733d00cb6bd8dd564 SHA256 a837510d5c9fc3dc181b33fca392268b926433511621ca411d92aca13ddd7847
+MISC ChangeLog 250 RMD160 2c6d0edab16e47b16aba239ce782b233c9a7b597 SHA1 4a32bf1e5da055a36df719fab14703e74410eecb SHA256 72a3dab8e2a218f71ff4305bae129b0bf4a35c2e4a6dd049baae066b42c2786c
+MISC metadata.xml 907 RMD160 99737ae177bf892569bb0aa4df6e75e36539876c SHA1 b0f3195c19f7ea83a6d902e349d0b4f8f16061b1 SHA256 0c32b490b76530b496aa8ef4b5be017157166de92743f5c1f5d2c49c839e7f04
diff --git a/sci-libs/tina-libs/metadata.xml b/sci-libs/tina-libs/metadata.xml
new file mode 100644
index 0000000..12251d0
--- /dev/null
+++ b/sci-libs/tina-libs/metadata.xml
@@ -0,0 +1,13 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>sci</herd>
+<maintainer>
+ <name>Aaron Mavrinac</name>
+ <email>mavrinac@gmail.com</email>
+</maintainer>
+<longdescription lang="en">
+TINA (TINA Is No Acronym) is an open source environment developed to accelerate the process of image analysis research. TINA provides functionality to assist in all areas of image analysis including handling of image, image feature and geometrical data; statistical and numerical analysis of data; GUI development as well as transmission and containment of data. TINA also provides a range of high-level analysis techniques for both machine vision (3D object location, 2D object recognition, temporal-stereo depth estimation, etc) and medical image analysis (MR tissue segmentation, blood flow analysis, etc).
+</longdescription>
+</pkgmetadata>
+
diff --git a/sci-libs/tina-libs/tina-libs-20081008.ebuild b/sci-libs/tina-libs/tina-libs-20081008.ebuild
new file mode 100644
index 0000000..6eb5274
--- /dev/null
+++ b/sci-libs/tina-libs/tina-libs-20081008.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+inherit autotools
+
+DESCRIPTION="TINA - Open Source Image Analysis Environment"
+HOMEPAGE="http://www.tina-vision.net/"
+SRC_URI="http://www.tina-vision.net/tarballs/tina_libs_v5_devel_2008-10-08.tar.gz"
+
+LICENSE="LGPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND=""
+RDEPEND=""
+
+S="${WORKDIR}/${PN}"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ eautoreconf
+}
+
+src_compile() {
+ econf || die "econf failed"
+ emake || die "emake failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+ dodoc AUTHORS COPYING ChangeLog INSTALL LICENSE NEWS README
+}