summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-electronics/rosdep/rosdep-0.10.25.ebuild')
-rw-r--r--sci-electronics/rosdep/rosdep-0.10.25.ebuild21
1 files changed, 21 insertions, 0 deletions
diff --git a/sci-electronics/rosdep/rosdep-0.10.25.ebuild b/sci-electronics/rosdep/rosdep-0.10.25.ebuild
new file mode 100644
index 0000000..d819076
--- /dev/null
+++ b/sci-electronics/rosdep/rosdep-0.10.25.ebuild
@@ -0,0 +1,21 @@
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="4-python"
+PYTHON_MULTIPLE_ABIS="1"
+
+inherit distutils
+
+DESCRIPTION="rosdep multi-package manager system dependency tool."
+HOMEPAGE="http://www.ros.org"
+SRC_URI="https://github.com/ros-infrastructure/${PN}/archive/${PV}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE=""
+
+DEPEND="sci-electronics/catkin_pkg
+ sci-electronics/rospkg
+ dev-python/pyyaml"
+RDEPEND="${DEPEND}"
+