summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorhaarp <main.haarp@gmail.com>2016-08-31 14:00:19 +0200
committerhaarp <main.haarp@gmail.com>2016-08-31 14:00:19 +0200
commit24cdb2e567172dbf16dc3ae9dd3193151769bf3b (patch)
treeb30c37b7dc7a03da0142326d861ee0bfdf1e0f18
parentFix mozjpeg to work with whitespaces in filename (diff)
downloadhaarp-24cdb2e567172dbf16dc3ae9dd3193151769bf3b.tar.gz
haarp-24cdb2e567172dbf16dc3ae9dd3193151769bf3b.tar.bz2
haarp-24cdb2e567172dbf16dc3ae9dd3193151769bf3b.zip
Add multiload-ng applet
-rw-r--r--x11-plugins/multiload-ng/Manifest2
-rw-r--r--x11-plugins/multiload-ng/multiload-ng-1.2.0.ebuild55
2 files changed, 57 insertions, 0 deletions
diff --git a/x11-plugins/multiload-ng/Manifest b/x11-plugins/multiload-ng/Manifest
new file mode 100644
index 0000000..fe527ec
--- /dev/null
+++ b/x11-plugins/multiload-ng/Manifest
@@ -0,0 +1,2 @@
+DIST multiload-ng-1.2.0.tar.gz 84127 SHA256 7a9034d087476556dc936a2ffde223efbb35d42f7aa7d81ba09f8628f7a4cc47 SHA512 a82907346cc8fad35ab664c927c2c90616cd2f2bea635abef7d4210c5bfa57cc07d08286de8ca5add01ec41959a96f412c2e7eeff9257b6cd5307b223560e4d7 WHIRLPOOL bb72618e081e10094694b35561231974b804d3056245e044ffa8f244edf9e6d7eaa9bbb9df94862b97f724863a2faad583c686833e2951e3d83fafa1d32f74a7
+EBUILD multiload-ng-1.2.0.ebuild 1210 SHA256 1e71bae904dbfa089cc92ae285fc41e13e08e609c5a0e8915c91d6d565e16ce7 SHA512 14275c7805e93f88d0d0610b97e650407a1b70cbef73a1494f95331d1e953d40728024dc06a3d6455858e31759c17352f3a0e91a2c8ac7379b9aad19b77ee99d WHIRLPOOL 88880eb64c0e6548a3355bf674514556754c7f82ba0228d81d5cbbf0493fc45ca0fe49cfe070291fe3ee295d520b7871f69387f7382c82fe03d285bedb951889
diff --git a/x11-plugins/multiload-ng/multiload-ng-1.2.0.ebuild b/x11-plugins/multiload-ng/multiload-ng-1.2.0.ebuild
new file mode 100644
index 0000000..2845c56
--- /dev/null
+++ b/x11-plugins/multiload-ng/multiload-ng-1.2.0.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit autotools eutils
+
+DESCRIPTION="A port of the GNOME multiload applet for the Xfce and LXDE panels"
+HOMEPAGE="https://github.com/udda/multiload-ng"
+SRC_URI="https://github.com/udda/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="indicator lxpanel mate standalone +xfce_plugins_multiload-ng"
+
+RDEPEND=">=x11-libs/gtk+-2.14:2
+ x11-libs/cairo
+ >=gnome-base/libgtop-2.11.92
+ lxpanel? ( lxde-base/lxpanel )
+ xfce_plugins_multiload-ng? (
+ >=xfce-base/libxfce4ui-4.10
+ >=xfce-base/libxfce4util-4.10
+ >=xfce-base/xfce4-panel-4.10
+ )"
+DEPEND="${RDEPEND}
+ dev-util/intltool
+ sys-devel/gettext
+ virtual/pkgconfig"
+
+REQUIRED_USE="|| ( xfce_plugins_multiload-ng lxpanel )"
+
+DOCS="AUTHORS README.md"
+
+S=${WORKDIR}/${P}
+
+src_prepare() {
+ eautoreconf
+}
+
+src_configure() {
+ # FIXME: currently builds with gtk2 only
+ econf \
+ --with-gtk=2.0 \
+ $(use_with indicator) \
+ $(use_with lxpanel) \
+ $(use_with mate) \
+ $(use_with standalone) \
+ $(use_with xfce_plugins_multiload-ng xfce4)
+}
+
+src_install() {
+ default
+ prune_libtool_files --all
+}