summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--app-editors/gedit-plugins/Manifest3
-rw-r--r--app-editors/gedit-plugins/gedit-plugins-3.10.1.ebuild71
-rw-r--r--app-editors/gedit-plugins/metadata.xml14
-rw-r--r--app-editors/gedit/Manifest3
-rw-r--r--app-editors/gedit/gedit-3.10.4.ebuild84
-rw-r--r--app-editors/gedit/metadata.xml8
-rw-r--r--x11-terms/roxterm/Manifest4
-rw-r--r--x11-terms/roxterm/files/gtk+-3.19.5+-geometry-fix.patch316
-rw-r--r--x11-terms/roxterm/metadata.xml7
-rw-r--r--x11-terms/roxterm/roxterm-3.3.2-r1.ebuild73
10 files changed, 0 insertions, 583 deletions
diff --git a/app-editors/gedit-plugins/Manifest b/app-editors/gedit-plugins/Manifest
deleted file mode 100644
index edc17f4..0000000
--- a/app-editors/gedit-plugins/Manifest
+++ /dev/null
@@ -1,3 +0,0 @@
-DIST gedit-plugins-3.10.1.tar.xz 1253800 BLAKE2B 7a5b81598d11321b1aaba3c1024d5f45e0a5de9568118e5df48add60931f4a6112e30203a5691cd5a49fe92048605b78a5268701c14b24037e31f011956c2628 SHA512 bb63986c1a2c431443191bf1855a54125c9c1b500a4764bf13f597cb8ea09e588ee101d2856938ee229bc9bbba9bd107c60c643fb09f001afa26f0ef90baa2fa
-EBUILD gedit-plugins-3.10.1.ebuild 1979 BLAKE2B 59bcc7889597b3deb3be290feee3e68d9ed0a45d1df2a9dd964f15cbce0c4aa94ffca0df27f41f6c5a3a549a03ecfe65a9ebfef65bf76180dc90128228a1812c SHA512 c26910ad0085bdfaab3cb26291111c8e0a724ac086af3887cf1f362af017353f60c0ba49c18317435f499d39ef32c8018053db39e1c14e7bbe7c0af223f07b32
-MISC metadata.xml 542 BLAKE2B e5e84a72caf85900ae88b4e76b45c3a2ea276cadfbdd2d79296baa41307abe82725a2e1fc69160cb7ef6597607c9484082de966693580efdcd2e8f98949c76ce SHA512 293f3de34d5c3307e018cb01312502574eb78c7d18de7c711422bb1398a2b73187e47d500c11b777655f57486eecb9dba3be1e055979b18fa77d6f23655d2d5f
diff --git a/app-editors/gedit-plugins/gedit-plugins-3.10.1.ebuild b/app-editors/gedit-plugins/gedit-plugins-3.10.1.ebuild
deleted file mode 100644
index 77b8c1c..0000000
--- a/app-editors/gedit-plugins/gedit-plugins-3.10.1.ebuild
+++ /dev/null
@@ -1,71 +0,0 @@
-# Copyright 1999-2014 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI="5"
-GCONF_DEBUG="no"
-GNOME2_LA_PUNT="yes" # plugins are dlopened
-PYTHON_COMPAT=( python3_{5,6} )
-PYTHON_REQ_USE="xml"
-
-inherit eutils gnome2 multilib python-single-r1
-
-DESCRIPTION="Official plugins for gedit"
-HOMEPAGE="https://wiki.gnome.org/Apps/Gedit/ShippedPlugins"
-
-LICENSE="GPL-2+"
-KEYWORDS="amd64 x86"
-SLOT="0"
-
-IUSE_plugins="charmap git terminal"
-IUSE="+python ${IUSE_plugins}"
-REQUIRED_USE="
- charmap? ( python )
- git? ( python )
- terminal? ( python )
-"
-
-RDEPEND="
- >=app-editors/gedit-3.9[python?]
- >=dev-libs/glib-2.32:2
- >=dev-libs/libpeas-1.7.0[gtk,python?]
- >=x11-libs/gtk+-3.9:3
- >=x11-libs/gtksourceview-3.9.2:3.0
- python? (
- ${PYTHON_DEPS}
- >=app-editors/gedit-3[introspection,${PYTHON_USEDEP}]
- dev-libs/libpeas[${PYTHON_USEDEP}]
- dev-python/dbus-python[${PYTHON_USEDEP}]
- dev-python/pycairo
- dev-python/pygobject:3[cairo,${PYTHON_USEDEP}]
- >=x11-libs/gtk+-3.9:3[introspection]
- >=x11-libs/gtksourceview-3.9.2:3.0[introspection]
- x11-libs/pango[introspection]
- x11-libs/gdk-pixbuf:2[introspection]
- )
- charmap? ( >=gnome-extra/gucharmap-3:2.90[introspection] )
- git? ( >=dev-libs/libgit2-glib-0.0.6 )
- terminal? ( x11-libs/vte:2.90[introspection] )
-"
-DEPEND="${RDEPEND}
- >=dev-util/intltool-0.40.0
- sys-devel/gettext
- virtual/pkgconfig
-"
-
-src_configure() {
- # DEFAULT_PLUGINS from configure.ac
- local myplugins="bookmarks,drawspaces,wordcompletion"
-
- # python plugins with no extra dependencies beyond what USE=python brings
- use python && myplugins="${myplugins},bracketcompletion,codecomment,colorpicker,colorschemer,commander,dashboard,joinlines,multiedit,textsize,smartspaces,synctex"
-
- # python plugins with extra dependencies
- for plugin in ${IUSE_plugins/+}; do
- use ${plugin} && myplugins="${myplugins},${plugin}"
- done
-
- gnome2_src_configure \
- --with-plugins=${myplugins} \
- $(use_enable python) \
- ITSTOOL=$(type -P true)
-}
diff --git a/app-editors/gedit-plugins/metadata.xml b/app-editors/gedit-plugins/metadata.xml
deleted file mode 100644
index 6c8601d..0000000
--- a/app-editors/gedit-plugins/metadata.xml
+++ /dev/null
@@ -1,14 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
-<pkgmetadata>
-<herd>gnome</herd>
-<longdescription>Official plugins for gedit</longdescription>
-<use>
- <flag name='charmap'>Insert special characters just by clicking on
- them</flag>
- <flag name='git'>Shows document changes related to git's HEAD</flag>
- <flag name='synctex'>Synchronize between LaTeX and PDF with gedit and
- evince</flag>
- <flag name='terminal'>Embed a terminal in the bottom pane</flag>
-</use>
-</pkgmetadata>
diff --git a/app-editors/gedit/Manifest b/app-editors/gedit/Manifest
deleted file mode 100644
index 883a559..0000000
--- a/app-editors/gedit/Manifest
+++ /dev/null
@@ -1,3 +0,0 @@
-DIST gedit-3.10.4.tar.xz 3086320 BLAKE2B 7e712f2f690de3f1edef3b3e9302acdf0ce9d6292c160a7d8fba4ae0985b252ed8cbdc9a904963ebefb0848b40a42f86f39b5e8a49a51062f527f5d7ae9e18ac SHA512 36fe1a309594338e6b0f8285eb8789386724e0a9c9f5f3ff898d138c0949c04ce693896f4e4766666e3afe795dea46caf0403ff82570dfd60e6dc5ccb99642d4
-EBUILD gedit-3.10.4.ebuild 2274 BLAKE2B d77688f3e397316b71ed0b45b2d1e52877c5d0c9569759b755744a71290d02e2506de43407f0134940f6fbb2852d4a778a4b323216805e125d5dbdf9708df3f9 SHA512 f6d6fbd022d00ff4a515102f42f010c33dbb221d55396a4300b09672d610d84e11370bab47a767d4b15b164dadac3bd2c664035ac5b711e8772744d0240d4baa
-MISC metadata.xml 276 BLAKE2B a935b20ac0afde0176624c041393cf392cbe684f5df40e26ebfa9e93271044b73eca52e49e2d48abd9b9353140d92e503fc0064759e72ea05ffb24006e90993f SHA512 9c1f48389dedc905b448e4085b9fec8f37ef777aacf14e18541e39680ccf83a968c7ee8fea8b9ede61704ac174380c7cc56858182fb6f59a589ab1d70b8eea7d
diff --git a/app-editors/gedit/gedit-3.10.4.ebuild b/app-editors/gedit/gedit-3.10.4.ebuild
deleted file mode 100644
index d1c142c..0000000
--- a/app-editors/gedit/gedit-3.10.4.ebuild
+++ /dev/null
@@ -1,84 +0,0 @@
-# Copyright 1999-2014 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI="5"
-GCONF_DEBUG="no"
-GNOME2_LA_PUNT="yes" # plugins are dlopened
-PYTHON_COMPAT=( python3_{5,6} )
-
-inherit eutils gnome2 multilib python-single-r1 virtualx
-
-DESCRIPTION="A text editor for the GNOME desktop"
-HOMEPAGE="http://live.gnome.org/Gedit"
-
-LICENSE="GPL-2+ CC-BY-SA-3.0"
-SLOT="0"
-
-IUSE="+introspection +python spell zeitgeist"
-REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
-
-KEYWORDS="~alpha amd64 ~arm ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc x86 ~amd64-fbsd ~x86-fbsd ~x86-freebsd ~x86-interix ~amd64-linux ~ia64-linux ~x86-linux"
-
-# X libs are not needed for OSX (aqua)
-COMMON_DEPEND="
- >=dev-libs/libxml2-2.5.0:2
- >=dev-libs/glib-2.37.5:2
- >=x11-libs/gtk+-3.9.9:3[introspection?]
- >=x11-libs/gtksourceview-3.9.91:3.0[introspection?]
- >=dev-libs/libpeas-1.7.0[gtk]
-
- gnome-base/dconf
- gnome-base/gsettings-desktop-schemas
- gnome-base/gvfs
-
- x11-libs/libX11
-
- net-libs/libsoup:2.4
-
- introspection? ( >=dev-libs/gobject-introspection-0.9.3 )
- python? (
- ${PYTHON_DEPS}
- >=dev-libs/gobject-introspection-0.9.3
- >=x11-libs/gtk+-3:3[introspection]
- >=x11-libs/gtksourceview-3.6:3.0[introspection]
- dev-python/pycairo[${PYTHON_USEDEP}]
- >=dev-python/pygobject-3:3[cairo,${PYTHON_USEDEP}] )
- spell? (
- >=app-text/enchant-1.2:=
- >=app-text/iso-codes-0.35 )
- zeitgeist? ( >=gnome-extra/zeitgeist-0.9.12 )
-"
-RDEPEND="${COMMON_DEPEND}
- x11-themes/gnome-icon-theme-symbolic
-"
-DEPEND="${COMMON_DEPEND}
- app-text/docbook-xml-dtd:4.1.2
- >=app-text/scrollkeeper-0.3.11
- dev-libs/libxml2:2
- >=dev-util/gtk-doc-am-1
- >=dev-util/intltool-0.50.1
- >=sys-devel/gettext-0.18
- virtual/pkgconfig
-"
-# yelp-tools, gnome-common needed to eautoreconf
-
-src_configure() {
- DOCS="AUTHORS BUGS ChangeLog MAINTAINERS NEWS README"
- gnome2_src_configure \
- --disable-deprecations \
- --enable-updater \
- --enable-gvfs-metadata \
- $(use_enable introspection) \
- $(use_enable python) \
- $(use_enable spell) \
- $(use_enable zeitgeist) \
- ITSTOOL=$(type -P true)
-}
-
-src_test() {
- # FIXME: this should be handled at eclass level
- "${EROOT}${GLIB_COMPILE_SCHEMAS}" --allow-any-name "${S}/data" || die
-
- unset DBUS_SESSION_BUS_ADDRESS
- GSETTINGS_SCHEMA_DIR="${S}/data" Xemake check
-}
diff --git a/app-editors/gedit/metadata.xml b/app-editors/gedit/metadata.xml
deleted file mode 100644
index be668a1..0000000
--- a/app-editors/gedit/metadata.xml
+++ /dev/null
@@ -1,8 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
-<pkgmetadata>
- <herd>gnome</herd>
- <use>
- <flag name="zeitgeist">Build the plugin to inject events to <pkg>gnome-extra/zeitgeist</pkg></flag>
- </use>
-</pkgmetadata>
diff --git a/x11-terms/roxterm/Manifest b/x11-terms/roxterm/Manifest
deleted file mode 100644
index 8474457..0000000
--- a/x11-terms/roxterm/Manifest
+++ /dev/null
@@ -1,4 +0,0 @@
-AUX gtk+-3.19.5+-geometry-fix.patch 12097 SHA256 ccc1e00028b456e7d0a5e2fd759c21c41aeea2dd0fe4ed0b94c0c7476bca17eb SHA512 bc5c65558c9416d4c113b1dda6505d0fed2e33dcc782cac7d7af9abdfd1710b50c2b191883f2a89295eb092b8ae227e5903ebf19346b12f9688a26f8bccadb3b WHIRLPOOL 66c266916bbbf3c22cf998b33f04ed38f05f65c5acbf76f5195c4588746e619dd0619198aef32a8a469309e831ee8391ee73d5a387da8309a2339d2ca4810023
-DIST roxterm-3.3.2.tar.xz 309948 SHA256 33501d698971fe80e2756104ffa5541aff23f0ae2b718464006d912ac93c506e SHA512 6489d8c736d38d624967cf779820414c106a15b423cfc3c8ceed57093e3ff9bd66bf9979eee4361f331766807e17993ce4b4dfd71381aeae5f9d20462ff9ed5e WHIRLPOOL b3909db2af619e1324bdd6f5ea12b03070bc91f0b553eadabf5a9e7ee60ee30ae6fa0798043611ea1f2b5a0441e4e618c6011fe3f0630bc56b8fc0f9f6c5bfeb
-EBUILD roxterm-3.3.2-r1.ebuild 1473 SHA256 94a50a97ef560f87834a592ec4eb91e44e0c99d65f556ab2d4418d6ff4f31ec8 SHA512 e7e104819a38870fc7a278ffe42e81bfc85150c1314d45c593771e8e1874c2dae83c61c713d89db9c531b810a7fd2025ae77f692ba621401a773962b0fb70cea WHIRLPOOL c78500aadf1c29a92325e1824836e990be2784e9226ee844f45dac038f92325627039087aa33cad6f44c57e8a94aa44fbd8ba5c384d30c81c9cf1afc0b61507a
-MISC metadata.xml 216 SHA256 1aaa8dec91053006a273d502fefb8ea87c3101a34dd12c698ddb38594a8f1e25 SHA512 dd0c6e3184abeacf6c303aaf3e452e239e595c5c380c07e747fb8b8eaddfa4854e1cfcfd617e618c224efc6f0618e5aa40932cf05c231f0c31dbc776397f7e81 WHIRLPOOL 14b629692b21dae7582d38edb405d6124b57574664a0e0be328451bb10804844ec432a7ad33eb6cd4391ea29115f92217fb9c51a557f8be2cb54b1d184e82a44
diff --git a/x11-terms/roxterm/files/gtk+-3.19.5+-geometry-fix.patch b/x11-terms/roxterm/files/gtk+-3.19.5+-geometry-fix.patch
deleted file mode 100644
index 6820e7e..0000000
--- a/x11-terms/roxterm/files/gtk+-3.19.5+-geometry-fix.patch
+++ /dev/null
@@ -1,316 +0,0 @@
-https://sourceforge.net/p/roxterm/bugs/125/
-
---- a/src/multitab.c 2017-05-25 16:40:38.743116691 +0200
-+++ b/src/multitab.c 2017-05-25 17:01:03.589777394 +0200
-@@ -246,6 +246,9 @@ MultiTab *multi_tab_new(MultiWin * paren
- multi_win_add_tab(parent, tab, pos, FALSE);
- multi_win_select_tab(parent, tab);
-
-+ g_warning("call roxterm_force_resize_now from line %d", __LINE__);
-+ roxterm_force_resize_now(parent);
-+
- return tab;
- }
-
-@@ -322,8 +325,39 @@ static gboolean multi_win_clear_geometry
- void multi_win_set_geometry_hints(MultiWin *win, GtkWidget *child,
- GdkGeometry *geometry, GdkWindowHints geom_mask)
- {
-+#if GTK_CHECK_VERSION (3, 19, 5)
-+ GtkAllocation child_alloc, toplevel_alloc;
-+ gint chrome_width, chrome_height;
-+ gint decorator_width, decorator_height;
-+
-+ void roxterm_get_current_chrome_dimensions(MultiWin *win,
-+ int *chrome_width, int *chrome_height);
-+ roxterm_get_current_chrome_dimensions(win, &chrome_width, &chrome_height);
-+
-+ gtk_widget_get_allocation(child, &child_alloc);
-+ gtk_widget_get_allocation(GTK_WIDGET(win->gtkwin), &toplevel_alloc);
-+ decorator_width = toplevel_alloc.width - child_alloc.width;
-+ decorator_height = toplevel_alloc.height - child_alloc.height;
-+
-+ g_warning(_("allocated to top level: %d x %d"), toplevel_alloc.width, toplevel_alloc.height);
-+ g_warning(_("allocated to child: %d x %d"), child_alloc.width, child_alloc.height);
-+ g_warning(_("base geometry is %d x %d"), geometry->base_width, geometry->base_height);
-+ g_warning(_("min geometry is %d x %d"), geometry->min_width, geometry->min_height);
-+ g_warning(_("decorator size is %d x %d"), decorator_width, decorator_height);
-+ g_warning(_("chrome geometry is %d x %d"), chrome_width, chrome_height);
-+
-+ geometry->base_width = decorator_width + chrome_width;
-+ geometry->base_height = decorator_height + chrome_height;
-+
-+ g_warning(_("requesting %d x %d"), geometry->base_width, geometry->base_height);
-+
-+ gtk_window_set_geometry_hints(GTK_WINDOW(win->gtkwin), NULL,
-+ geometry, geom_mask);
-+#else // GTK 2 and GTK 3 earlier than 3.19.5
- gtk_window_set_geometry_hints(GTK_WINDOW(win->gtkwin), child,
- geometry, geom_mask);
-+#endif
-+
- if (global_options_lookup_int_with_default("no-geometry", FALSE))
- g_idle_add((GSourceFunc) multi_win_clear_geometry_hints, win->gtkwin);
- }
-@@ -1768,6 +1802,9 @@ void multi_win_show(MultiWin *win)
- gtk_widget_show(win->gtkwin);
- g_object_set_data(G_OBJECT(gtk_widget_get_window(win->gtkwin)),
- "ROXTermWin", win);
-+
-+ //g_warning("call roxterm_force_resize_now from line %d", __LINE__);
-+ //roxterm_force_resize_now(win);
- }
-
- void multi_win_set_colormap(MultiWin *win)
---- a/src/roxterm.c 2017-05-25 16:40:38.743116691 +0200
-+++ b/src/roxterm.c 2017-05-25 17:13:18.353107150 +0200
-@@ -31,6 +31,10 @@
-
- #include <gdk/gdkx.h>
-
-+#if GTK_CHECK_VERSION (3, 19, 5)
-+#include <gtk/gtkwidget.h>
-+#endif
-+
- #include "about.h"
- #include "boxcompat.h"
- #include "colourscheme.h"
-@@ -1171,6 +1175,16 @@ static const GdkRGBA *extrapolate_colour
- return &ext;
- }
-
-+#if GTK_CHECK_VERSION(3, 19, 5)
-+static void roxterm_get_vte_padding(VteTerminal *vte, int *w, int *h)
-+{
-+ *w = 0;
-+ *h = 0;
-+
-+ // *w = 20;
-+ // *h = 20;
-+}
-+#else
- static void roxterm_get_vte_padding(ROXTermData *roxterm,
- int *pad_w, int *pad_h)
- {
-@@ -1207,6 +1221,7 @@ static void roxterm_get_vte_padding(ROXT
- if (pad_h)
- *pad_h = roxterm->padding_h;
- }
-+#endif
-
- static const GdkRGBA *roxterm_get_background_colour_with_transparency(
- ROXTermData * roxterm)
-@@ -1266,6 +1281,8 @@ static void
- roxterm_set_vte_size(ROXTermData *roxterm, VteTerminal *vte,
- int columns, int rows)
- {
-+ g_warning(_("calling roxterm_set_vte_size, cols=%d, rows=%d..."), columns, rows);
-+
- /* First get current size of vte and parent window so we know difference */
- int cw, ch, ww, wh;
- GtkWidget *vw = GTK_WIDGET(vte);
-@@ -1273,6 +1290,7 @@ roxterm_set_vte_size(ROXTermData *roxter
- MultiWin *win = roxterm_get_win(roxterm);
- GtkWidget *pw = win ? multi_win_get_widget(win) : NULL;
- GdkWindow *pd = pw ? gtk_widget_get_window(pw) : NULL;
-+ GtkWindow *top = roxterm_get_toplevel(roxterm);
-
- if (drbl && pd)
- {
-@@ -1284,14 +1302,28 @@ roxterm_set_vte_size(ROXTermData *roxter
- /* If we're in a realized window, resize it as required, otherwise the
- * vte's size request won't be honoured.
- */
-- if (drbl && pd)
-+ if (0 && drbl && pd)
- {
- int px, py;
- int req_w, req_h;
-+ int win_w, win_h;
-+ int top_w, top_h;
-
- roxterm_get_vte_padding(roxterm, &px, &py);
- req_w = vte_terminal_get_char_width(vte) * columns + px;
- req_h = vte_terminal_get_char_height(vte) * rows + py;
-+
-+ gtk_window_get_size(GTK_WINDOW(pw), &win_w, &win_h);
-+ gtk_window_get_size(top, &top_w, &top_h);
-+
-+ g_warning(_("resize..."));
-+ g_warning(_("reported window size is %d x %d"), ww, wh);
-+ //g_warning(_("2nd reported window size is %d x %d"), win_w, win_h);
-+ //g_warning(_("3rd reported window size is %d x %d"), top_w, top_h);
-+ g_warning(_("reported drawable size is %d x %d"), cw, ch);
-+ g_warning(_("reported request size is %d x %d"), req_w, req_h);
-+ g_warning(_("overall size is %d x %d"), req_w + ww - cw, req_h + wh - ch);
-+
- /*
- g_debug("Child was %dx%d, window bigger by %dx%d; "
- "resizing for child calc %dx%d",
-@@ -1306,12 +1338,27 @@ static void roxterm_geometry_func(ROXTer
- {
- VteTerminal *vte = VTE_TERMINAL(roxterm->widget);
-
-+/*#if GTK_CHECK_VERSION (3, 19, 5)
-+ roxterm_terminal_get_geometry_hints (vte, geom, 4, 4);
-+#else*/
- roxterm_get_vte_padding(roxterm, &geom->base_width, &geom->base_height);
- geom->width_inc = vte_terminal_get_char_width(vte);
- geom->height_inc = vte_terminal_get_char_height(vte);
-- geom->min_width = geom->base_width + 4 * geom->width_inc;
-- geom->min_height = geom->base_height + 4 * geom->height_inc;
-- *hints = GDK_HINT_RESIZE_INC | GDK_HINT_BASE_SIZE | GDK_HINT_MIN_SIZE;
-+ //geom->min_width = geom->base_width + 4 * geom->width_inc;
-+ //geom->min_height = geom->base_height + 4 * geom->height_inc;
-+ geom->min_width = 0;
-+ geom->min_height = 0;
-+ //geom->base_width = vte_terminal_get_column_count(vte) * geom->width_inc;
-+ //geom->base_height = vte_terminal_get_row_count(vte) * geom->height_inc;
-+ //geom->base_width = roxterm->columns * geom->width_inc;
-+ //geom->base_height = roxterm->rows * geom->height_inc;
-+ geom->base_width = 0;
-+ geom->base_height = 0;
-+ g_warning(_("roxterm_geometry_func sets base to %d x %d"),
-+ geom->base_width, geom->base_height);
-+//#endif
-+ // *hints = GDK_HINT_RESIZE_INC | GDK_HINT_BASE_SIZE | GDK_HINT_MIN_SIZE;
-+ *hints = GDK_HINT_RESIZE_INC | GDK_HINT_BASE_SIZE;
- }
-
- static void roxterm_size_func(ROXTermData *roxterm, gboolean pixels,
-@@ -1340,17 +1387,6 @@ static void roxterm_default_size_func(RO
- *pheight = options_lookup_int_with_default(roxterm->profile, "height", 24);
- }
-
--static void roxterm_update_size(ROXTermData * roxterm, VteTerminal * vte)
--{
-- if (multi_win_get_current_tab(roxterm_get_win(roxterm)) == roxterm->tab)
-- {
-- int w, h;
--
-- roxterm_default_size_func(roxterm, &w, &h);
-- roxterm_set_vte_size(roxterm, vte, w, h);
-- }
--}
--
- static void roxterm_update_geometry(ROXTermData * roxterm, VteTerminal * vte)
- {
- (void) vte;
-@@ -1365,6 +1401,20 @@ static void roxterm_update_geometry(ROXT
- }
- }
-
-+static void roxterm_update_size(ROXTermData * roxterm, VteTerminal * vte)
-+{
-+ if (multi_win_get_current_tab(roxterm_get_win(roxterm)) == roxterm->tab)
-+ {
-+ int w, h;
-+
-+ roxterm_default_size_func(roxterm, &w, &h);
-+ g_warning("call roxterm_set_vte_size from line %d", __LINE__);
-+ roxterm_set_vte_size(roxterm, vte, w, h);
-+
-+ //roxterm_update_geometry(roxterm, vte);
-+ }
-+}
-+
- static void resize_pango_for_zoom(PangoFontDescription *pango_desc,
- double zf)
- {
-@@ -1432,6 +1482,7 @@ roxterm_apply_profile_font(ROXTermData *
- roxterm->current_zoom_factor = roxterm->target_zoom_factor;
- if (update_geometry)
- {
-+ g_warning("call roxterm_set_vte_size from line %d", __LINE__);
- roxterm_set_vte_size(roxterm, vte, w, h);
- roxterm_update_geometry(roxterm, vte);
- }
-@@ -1461,6 +1512,7 @@ roxterm_update_font(ROXTermData *roxterm
- roxterm->current_zoom_factor = roxterm->target_zoom_factor;
- if (update_geometry)
- {
-+ g_warning("call roxterm_set_vte_size from line %d", __LINE__);
- roxterm_set_vte_size(roxterm, vte, w, h);
- roxterm_update_geometry(roxterm, vte);
- }
-@@ -1500,6 +1552,7 @@ static void roxterm_match_text_size(ROXT
- if (vte_terminal_get_column_count(vte) != width ||
- vte_terminal_get_row_count(vte) != height)
- {
-+ g_warning("call roxterm_set_vte_size from line %d", __LINE__);
- roxterm_set_vte_size(roxterm, VTE_TERMINAL(roxterm->widget),
- width, height);
- }
-@@ -2589,8 +2642,10 @@ static void roxterm_resize_window_handle
- // return;
-
- /* Only resize window now if this is current tab */
-- if (roxterm->tab == multi_win_get_current_tab(win))
-+ if (roxterm->tab == multi_win_get_current_tab(win)) {
-+ g_warning("call roxterm_set_vte_size from line %d", __LINE__);
- roxterm_set_vte_size(roxterm, vte, columns, rows);
-+ }
- else
- vte_terminal_set_size(vte, columns, rows);
- }
-@@ -3326,6 +3381,7 @@ static GtkWidget *roxterm_multi_tab_fill
- title_orig = vte_terminal_get_window_title(vte);
- multi_tab_set_window_title(tab, title_orig ? title_orig : _("ROXTerm"));
-
-+ g_warning("call roxterm_set_vte_size from line %d", __LINE__);
- roxterm_set_vte_size(roxterm, vte, roxterm->columns, roxterm->rows);
-
- roxterm_connect_misc_signals(roxterm);
-@@ -3343,6 +3399,42 @@ static GtkWidget *roxterm_multi_tab_fill
- return scrollbar_pos ? roxterm->hbox : roxterm->widget;
- }
-
-+VteTerminal *roxterm_get_current_vte_ptr(MultiWin *win) {
-+ ROXTermData *roxterm = multi_win_get_user_data_for_current_tab(win);
-+ VteTerminal *vte = VTE_TERMINAL(roxterm->widget);
-+ return vte;
-+}
-+
-+void roxterm_get_current_chrome_dimensions(MultiWin *win,
-+ int *chrome_width, int *chrome_height) {
-+
-+#if GTK_CHECK_VERSION(3, 0, 0)
-+ ROXTermData *roxterm = multi_win_get_user_data_for_current_tab(win);
-+ VteTerminal *vte = roxterm_get_current_vte_ptr(win);
-+ int w = roxterm->columns;//vte_terminal_get_column_count(vte);
-+ int h = roxterm->rows;//vte_terminal_get_row_count(vte);
-+ GtkRequisition vte_request;
-+
-+ gtk_widget_get_preferred_size(
-+ multi_win_get_widget(win), NULL, &vte_request);
-+ *chrome_width = vte_request.width - (vte_terminal_get_char_width(vte) * w);
-+ *chrome_height = vte_request.height - (vte_terminal_get_char_height(vte) * h);
-+#else
-+ *chrome_width = 0;
-+ *chrome_height = 0;
-+#endif
-+}
-+
-+void roxterm_force_resize_now(MultiWin *win) {
-+ ROXTermData *roxterm = multi_win_get_user_data_for_current_tab(win);
-+ VteTerminal *vte = VTE_TERMINAL(roxterm->widget);
-+
-+ int w = roxterm->columns;//vte_terminal_get_column_count(vte);
-+ int h = roxterm->rows;//vte_terminal_get_row_count(vte);
-+ roxterm_set_vte_size(roxterm, vte, w, h);
-+ roxterm_update_geometry(roxterm, vte);
-+}
-+
- static void roxterm_multi_tab_destructor(ROXTermData * roxterm)
- {
- roxterm_terms = g_list_remove(roxterm_terms, roxterm);
-@@ -4349,6 +4441,9 @@ void roxterm_launch(const char *display_
- g_free(shortcut_scheme);
- g_free(colour_scheme_name);
- g_free(profile_name);
-+
-+ g_warning("call roxterm_force_resize_now from %s:%d", __FILE__, __LINE__);
-+ roxterm_force_resize_now(win);
- }
-
- static void roxterm_tab_to_new_window(MultiWin *win, MultiTab *tab,
diff --git a/x11-terms/roxterm/metadata.xml b/x11-terms/roxterm/metadata.xml
deleted file mode 100644
index 1877d1b..0000000
--- a/x11-terms/roxterm/metadata.xml
+++ /dev/null
@@ -1,7 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
-<pkgmetadata>
- <upstream>
- <remote-id type="sourceforge">roxterm</remote-id>
- </upstream>
-</pkgmetadata>
diff --git a/x11-terms/roxterm/roxterm-3.3.2-r1.ebuild b/x11-terms/roxterm/roxterm-3.3.2-r1.ebuild
deleted file mode 100644
index 94019b1..0000000
--- a/x11-terms/roxterm/roxterm-3.3.2-r1.ebuild
+++ /dev/null
@@ -1,73 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-PYTHON_COMPAT=( python3_{4,5,6} )
-inherit gnome2-utils python-any-r1 toolchain-funcs multiprocessing
-
-DESCRIPTION="A terminal emulator designed to integrate with the ROX environment"
-HOMEPAGE="http://roxterm.sourceforge.net/"
-SRC_URI="mirror://sourceforge/roxterm/${P}.tar.xz"
-
-LICENSE="GPL-2 LGPL-3"
-SLOT="1"
-KEYWORDS="~amd64 ~x86"
-IUSE="nls"
-
-RDEPEND=">=dev-libs/dbus-glib-0.100
- dev-libs/glib:2
- x11-libs/gtk+:3
- x11-libs/libICE
- x11-libs/libSM
- x11-libs/vte:2.91
- !x11-terms/roxterm:0"
-# slotted versions of roxterm need block one another due to file collisions. #565288
-DEPEND="${RDEPEND}
- ${PYTHON_DEPS}
- dev-libs/libxslt
- dev-python/lockfile
- virtual/pkgconfig
- virtual/imagemagick-tools
- nls? ( app-text/po4a sys-devel/gettext )"
-
-src_prepare(){
- epatch "${FILESDIR}/gtk+-3.19.5+-geometry-fix.patch"
-
- eapply_user
-}
-
-src_configure() {
- local myconf=(
- CC="$(tc-getCC)"
- CFLAGS="${CFLAGS}"
- LDFLAGS="${LDFLAGS}"
- PARALLEL="$(makeopts_jobs)"
- --prefix=/usr
- --docdir="/usr/share/doc/${PN}"
- --destdir="${D}"
- )
-
- use nls || myconf+=( --disable-gettext --disable-po4a --disable-translations )
- ./mscript.py configure "${myconf[@]}"
-}
-
-src_compile() {
- ./mscript.py build
-}
-
-src_install() {
- ./mscript.py install
-}
-
-pkg_preinst() {
- gnome2_icon_savelist
-}
-
-pkg_postinst() {
- gnome2_icon_cache_update
-}
-
-pkg_postrm() {
- gnome2_icon_cache_update
-}