summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'x11-misc/xsecurelock')
-rw-r--r--x11-misc/xsecurelock/Manifest2
-rw-r--r--x11-misc/xsecurelock/xsecurelock-1.7.0-r1.ebuild72
2 files changed, 74 insertions, 0 deletions
diff --git a/x11-misc/xsecurelock/Manifest b/x11-misc/xsecurelock/Manifest
new file mode 100644
index 0000000..ef77753
--- /dev/null
+++ b/x11-misc/xsecurelock/Manifest
@@ -0,0 +1,2 @@
+DIST xsecurelock-1.7.0.tar.gz 219377 BLAKE2B 0f8db60fcb3efab101f026142b72687d61a084b000e9978d159f3d9a9d22be539591ca2a80b01ae3419315cc09dac1cb6d0002884f3c854f02882952e901ff6d SHA512 b3b5404199bed7f0470072c9341227536f8ebe593f288b4ffdb5f4e90e3854952bae150d449cca6628e255c05640b625b56f10266362c119d46d21d51e8880a6
+EBUILD xsecurelock-1.7.0-r1.ebuild 1475 BLAKE2B 9fa0646c8e1c11ea2f464f2a8469f9ce2c7a0e160c58f8b35ba21b64eee09f3c4e01db8c41edafe178abe1ea304d432ca38ef5c1d080e0022eb902c84efb3f6d SHA512 aa9f782e9e1413dc5d64e3886e4aaceb7eeaec4c1238f0fa0dc021eafe934a5faf1dfda8190d15119bef2533344e218293b54dcbec8553d6408146b463ba5fba
diff --git a/x11-misc/xsecurelock/xsecurelock-1.7.0-r1.ebuild b/x11-misc/xsecurelock/xsecurelock-1.7.0-r1.ebuild
new file mode 100644
index 0000000..778c3fe
--- /dev/null
+++ b/x11-misc/xsecurelock/xsecurelock-1.7.0-r1.ebuild
@@ -0,0 +1,72 @@
+# Copyright 2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools
+
+DESCRIPTION="X11 screen lock utility with security in mind"
+HOMEPAGE="https://github.com/google/xsecurelock"
+SRC_URI="https://github.com/google/${PN}/releases/download/v${PV}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="mpv xscreensaver"
+
+RDEPEND="
+ dev-libs/libbsd
+ media-libs/fontconfig
+ media-libs/freetype
+ sys-apps/util-linux
+ sys-libs/pam
+ x11-libs/libX11
+ x11-libs/libXcomposite
+ x11-libs/libXext
+ x11-libs/libXfixes
+ x11-libs/libXft
+ x11-libs/libXmu
+ x11-libs/libXrandr
+ x11-libs/libXScrnSaver
+ xscreensaver? ( x11-misc/xscreensaver )
+ mpv? ( media-video/mpv )
+"
+DEPEND="${RDEPEND}
+ x11-base/xorg-proto
+"
+BDEPEND="virtual/pkgconfig"
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ local myeconfargs=(
+ --prefix="${EPREFIX}"/usr
+ --with-default-auth-module=auth_x11
+ --with-default-authproto-module=authproto_pam
+ --without-htpasswd
+ --without-mplayer
+ --without-pamtester
+ --without-pandoc
+ --with-pam-service-name=system-auth
+ )
+ if ! use mpv; then
+ myeconfargs+=(
+ --without-mpv
+ )
+ fi
+ if use xscreensaver; then
+ myeconfargs+=(
+ --with-default-saver-module=saver_xscreensaver
+ --with-xscreensaver="${EPREFIX}"/usr/$(get_libdir)/misc/xscreensaver
+ )
+ else
+ myeconfargs+=(
+ --with-default-saver-module=saver_blank
+ --without-xscreensaver
+ )
+ fi
+ econf "${myeconfargs[@]}"
+}