summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'x11-plugins/multiload-ng/multiload-ng-9999.ebuild')
-rw-r--r--x11-plugins/multiload-ng/multiload-ng-9999.ebuild70
1 files changed, 17 insertions, 53 deletions
diff --git a/x11-plugins/multiload-ng/multiload-ng-9999.ebuild b/x11-plugins/multiload-ng/multiload-ng-9999.ebuild
index 33e1c2c..fb1b90c 100644
--- a/x11-plugins/multiload-ng/multiload-ng-9999.ebuild
+++ b/x11-plugins/multiload-ng/multiload-ng-9999.ebuild
@@ -1,57 +1,30 @@
-# Copyright 1999-2020 Gentoo authors
+# Copyright 1999-2022 Gentoo authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
-inherit autotools eutils
+EAPI=8
+inherit autotools git-r3
-DESCRIPTION="Modern graphical system monitor for XFCE/MATE/LXDE (GNOME applet fork)"
+DESCRIPTION="Modern graphical system monitor for any panel"
HOMEPAGE="https://udda.github.io/multiload-ng/"
-
-if [[ ${PV} == 9999 ]]; then
- inherit git-r3
- EGIT_REPO_URI="https://github.com/udda/multiload-ng.git"
- KEYWORDS=""
-else
- SRC_URI="https://github.com/udda/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
- KEYWORDS="~amd64 ~x86"
-fi
+EGIT_REPO_URI="https://github.com/udda/multiload-ng.git"
+KEYWORDS="~amd64 ~x86"
LICENSE="GPL-2"
SLOT="0"
-IUSE="autostart awn debug gtk2 +gtk3 indicator lxde mate +standalone systray xfce"
+IUSE="autostart awn debug indicator lxde mate +standalone systray xfce"
-LANGS=" de es fr it lt ru zh_CN"
+LANGS="de es fr it lt ru zh_CN"
IUSE="${IUSE} ${LANGS// / linguas_}"
RDEPEND="
- gtk2? ( >=x11-libs/gtk+-2.20:2 )
- gtk3? ( x11-libs/gtk+:3 )
+ x11-libs/gtk+:3
x11-libs/cairo:=
- awn? (
- >=gnome-extra/avant-window-navigator-0.3.9
- >=dev-cpp/glibmm-2.16.0:2
- >=dev-cpp/gtkmm-2.20:2.4
- )
- indicator? (
- gtk2? ( >=dev-libs/libappindicator-0.4.92:2 )
- gtk3? ( >=dev-libs/libappindicator-0.4.92:3 )
- )
- lxde? (
- >=lxde-base/lxpanel-0.5.8
- )
- mate? (
- gtk2? ( >=mate-base/mate-panel-1.7.0 )
- gtk3? ( >=mate-base/mate-panel-1.7.0[gtk3(-)] )
- )
+ indicator? ( >=dev-libs/libappindicator-0.4.92:3 )
+ lxde? ( >=lxde-base/lxpanel-0.5.8 )
+ mate? ( >=mate-base/mate-panel-1.7.0 )
xfce? (
- gtk2? (
- >=xfce-base/libxfce4util-4.6.0
- >=xfce-base/xfce4-panel-4.6.0
- )
- gtk3? (
- >=xfce-base/libxfce4util-4.12.0
- >=xfce-base/xfce4-panel-4.12.0
- )
+ >=xfce-base/libxfce4util-4.12.0
+ >=xfce-base/xfce4-panel-4.12.0
)"
DEPEND="${RDEPEND}
@@ -59,35 +32,26 @@ DEPEND="${RDEPEND}
sys-devel/gettext
virtual/pkgconfig"
-REQUIRED_USE="
- ^^ ( gtk2 gtk3 )
- || ( awn indicator lxde mate standalone systray xfce )
- awn? ( gtk2 )"
+REQUIRED_USE="|| ( indicator lxde mate standalone systray xfce )"
DOCS=( AUTHORS Changelog.md CONTRIBUTING.md README.md )
src_prepare() {
eapply "${FILESDIR}/fix-sysfs-nvme-dm.patch"
eapply_user
-
eautoreconf
}
src_configure() {
- if use gtk2; then
- GTK_CONF="--with-gtk=2.0"
- else
- GTK_CONF="--with-gtk=3.0 --disable-deprecations"
- fi
econf \
$(use_enable debug) \
$(use_enable autostart) \
$GTK_CONF \
$(use_with standalone) \
- $(use_with awn) \
$(use_with indicator) \
$(use_with lxde lxpanel) \
$(use_with mate) \
$(use_with systray) \
- $(use_with xfce xfce4)
+ $(use_with xfce xfce4)\
+ --with-gtk=3.0 --disable-deprecations
}