aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Delaney <della5@iinet.com.au>2012-05-21 03:47:23 +0800
committerIan Delaney <della5@iinet.com.au>2012-05-21 03:47:23 +0800
commitcc0a58ca7045791c2a8049409d73118e3c352510 (patch)
treebc1f968b3dd5c9f9a7b7485c991f6b07a3545511
parent[dev-python/starcluster] new ebuild review (diff)
downloadimprovise-cc0a58ca7045791c2a8049409d73118e3c352510.tar.gz
improvise-cc0a58ca7045791c2a8049409d73118e3c352510.tar.bz2
improvise-cc0a58ca7045791c2a8049409d73118e3c352510.zip
[dev-python/starcluster] using bash-completion-r1, removed testfixtures
-rw-r--r--dev-python/starcluster/starcluster-0.93.3.ebuild8
-rw-r--r--dev-python/testfixtures/Manifest1
-rw-r--r--dev-python/testfixtures/files/testfixtures-2.3.4-adjust_tests.patch130
-rw-r--r--dev-python/testfixtures/metadata.xml10
-rw-r--r--dev-python/testfixtures/testfixtures-2.3.4.ebuild50
5 files changed, 5 insertions, 194 deletions
diff --git a/dev-python/starcluster/starcluster-0.93.3.ebuild b/dev-python/starcluster/starcluster-0.93.3.ebuild
index c081e3d..2abd375 100644
--- a/dev-python/starcluster/starcluster-0.93.3.ebuild
+++ b/dev-python/starcluster/starcluster-0.93.3.ebuild
@@ -11,7 +11,6 @@ RESTRICT_PYTHON_ABIS="3.*"
DISTUTILS_SRC_TEST="nosetests"
inherit distutils bash-completion-r1
-
MY_PN="StarCluster"
MY_P="${MY_PN}-${PV}"
@@ -65,12 +64,14 @@ src_compile() {
src_install() {
distutils_src_install
# --install-scripts="/usr/bin" is taken care of by distutils anyway
- dobashcompletion completion/${PN}-completion.sh ${PN}
+ # the updated eclass uses a different name for dobashcompletion,
+ dobashcomp completion/${PN}-completion.sh ${PN}
# code in initial copy
# dohtml -A txt -r docs/sphinx/_build/html/* prefer mine but the results differ
use doc && dohtml -r docs/sphinx/_build/html/
if use epydoc; then
+ docompress -x usr/share/doc/${P}/apidocs/api-objects.txt
insinto usr/share/doc/${P}/
doins -r docs/apidocs/
fi
@@ -81,6 +82,7 @@ src_test() {
}
pkg_postinst() {
- bash-completion_pkg_postinst
+ # bash-completion-r1.eclass appears not to have this phase
+ #dobashcomp_pkg_postinst
distutils_pkg_postinst
}
diff --git a/dev-python/testfixtures/Manifest b/dev-python/testfixtures/Manifest
deleted file mode 100644
index 9da2eac..0000000
--- a/dev-python/testfixtures/Manifest
+++ /dev/null
@@ -1 +0,0 @@
-DIST testfixtures-2.3.4.tar.gz 73214 SHA256 376530e6608f072f6655d6a6de495a717040d47db5b04f2afac95ea7041af851 SHA512 858ebe20c0a2d682c2652a14a3e2fceea2e148f1e50d658f20237f3b15a84cf67ad61ff1d6b4a4b6c0a27981b337cf634b6b33fa7f717b7b9a5ceb289b396e47 WHIRLPOOL 4e6d7a8fd1fbac9d2f1c6b769ee810619b8a1db2d24469e7ac14867f19e92b7d0bc9596c09df3c80888dbf71350ddd80134b28564985de144cb3cfab2572d934
diff --git a/dev-python/testfixtures/files/testfixtures-2.3.4-adjust_tests.patch b/dev-python/testfixtures/files/testfixtures-2.3.4-adjust_tests.patch
deleted file mode 100644
index 590bb79..0000000
--- a/dev-python/testfixtures/files/testfixtures-2.3.4-adjust_tests.patch
+++ /dev/null
@@ -1,130 +0,0 @@
-diff -ur testfixtures-2.3.4.orig/testfixtures/tests/test_comparison.py testfixtures-2.3.4/testfixtures/tests/test_comparison.py
---- testfixtures/tests/test_comparison.py 2012-01-26 18:00:05.000000000 +0800
-+++ testfixtures/tests/test_comparison.py 2012-04-13 19:00:15.856224293 +0800
-@@ -5,7 +5,7 @@
- from testfixtures.tests.sample1 import TestClassA,a_function
- from unittest import TestCase,TestSuite,makeSuite
-
--from .compat import py_27_plus
-+from compat import py_27_plus
-
- class AClass:
-
-diff -ur testfixtures-2.3.4.orig/tests/test_components.py testfixtures-2.3.4/testfixtures/tests/test_components.py
---- testfixtures/tests/test_components.py 2012-01-27 02:41:51.000000000 +0800
-+++ testfixtures/tests/test_components.py 2012-04-13 19:08:44.434220585 +0800
-@@ -14,7 +14,7 @@
- from testfixtures import compare
- from unittest import TestCase
-
--from .compat import catch_warnings
-+from compat import catch_warnings
-
- class ComponentsTests(TestCase):
-
-diff -ur testfixtures-2.3.4.orig/testfixtures/tests/test_docs.py testfixtures-2.3.4/testfixtures/tests/test_docs.py
---- testfixtures/tests/test_docs.py 2012-01-28 16:07:57.000000000 +0800
-+++ testfixtures/tests/test_docs.py 2012-04-13 19:03:36.649223003 +0800
-@@ -11,7 +11,7 @@
-
- import os
-
--from . import compat
-+import compat
-
- workspace = os.environ.get('WORKSPACE', join(dirname(__file__), pardir, pardir))
- tests = glob(join(workspace,'docs', '*.txt'))
-diff -ur testfixtures-2.3.4.orig/testfixtures/tests/test_logcapture.py testfixtures-2.3.4/testfixtures/tests/test_logcapture.py
---- testfixtures/tests/test_logcapture.py 2012-01-27 02:41:26.000000000 +0800
-+++ testfixtures/tests/test_logcapture.py 2012-04-13 19:09:02.930220838 +0800
-@@ -10,7 +10,7 @@
-
- from logging import getLogger
-
--from .compat import catch_warnings
-+from compat import catch_warnings
-
- root = getLogger()
- one = getLogger('one')
-diff -ur testfixtures-2.3.4.orig/testfixtures/tests/test_replace.py testfixtures-2.3.4/testfixtures/tests/test_replace.py
---- testfixtures/tests/test_replace.py 2012-01-27 02:34:12.000000000 +0800
-+++ testfixtures/tests/test_replace.py 2012-04-13 19:09:18.842220416 +0800
-@@ -17,7 +17,7 @@
- import sample1
- import sample2
-
--from .compat import catch_warnings
-+from compat import catch_warnings
-
- class TestReplace(TestCase):
-
-diff -ur testfixtures-2.3.4.orig/testfixtures/tests/test_should_raise.py testfixtures-2.3.4/testfixtures/tests/test_should_raise.py
---- testfixtures/tests/test_should_raise.py 2012-01-27 02:43:51.000000000 +0800
-+++ testfixtures/tests/test_should_raise.py 2012-04-13 19:09:36.235220628 +0800
-@@ -5,7 +5,7 @@
- from testfixtures import should_raise,ShouldRaise,Comparison as C
- from unittest import TestCase,TestSuite,makeSuite
-
--from .compat import py_27_plus
-+from compat import py_27_plus
-
- class TestShouldRaise(TestCase):
-
-diff -ur testfixtures-2.3.4.orig/testfixtures/tests/test_tempdirectory.py testfixtures-2.3.4/testfixtures/tests/test_tempdirectory.py
---- testfixtures/tests/test_tempdirectory.py 2012-01-27 02:25:43.000000000 +0800
-+++ testfixtures/tests/test_tempdirectory.py 2012-04-13 19:09:54.971220623 +0800
-@@ -13,7 +13,7 @@
-
- from logging import getLogger
-
--from .compat import catch_warnings
-+from compat import catch_warnings
-
- class DemoTempDirectory:
-
-diff -ur testfixtures-2.3.4.orig/testfixtures/tests/test_manuel_examples.py testfixtures-2.3.4/testfixtures/tests/test_manuel_examples.py
---- testfixtures/tests/test_manuel_examples.py 2012-01-26 04:31:12.000000000 +0800
-+++ testfixtures/tests/test_manuel_examples.py 2012-04-13 21:14:05.390172684 +0800
-@@ -11,7 +11,7 @@
- from testfixtures import TempDirectory
- from testfixtures.manuel import Files
-
--from . import compat
-+import compat
-
- def setUp(test):
- test.globs['tempdir']=TempDirectory()
-diff -ur testfixtures-2.3.4.orig/testfixtures/components.py testfixtures-2.3.4/testfixtures/components.py
---- testfixtures/components.py 2011-10-12 00:21:45.000000000 +0800
-+++ testfixtures/components.py 2012-04-29 18:12:41.891588669 +0800
-@@ -4,8 +4,8 @@
- import atexit
- import warnings
-
--from zope.component import getSiteManager
--from zope.component.registry import Components
-+#from zope.component import getSiteManager
-+#from zope.component.registry import Components
-
- class TestComponents:
- """
-@@ -20,11 +20,8 @@
- atexit_setup = False
-
- def __init__(self):
-- self.registry = Components('Testing')
-- self.old = getSiteManager.sethook(lambda:self.registry)
- self.instances.add(self)
- if not self.__class__.atexit_setup:
-- atexit.register(self.atexit)
- self.__class__.atexit_setup = True
-
- def uninstall(self):
-@@ -33,7 +30,6 @@
- was in place before this :class:`TestComponents` was
- instantiated.
- """
-- getSiteManager.sethook(self.old)
- self.instances.remove(self)
-
- @classmethod
diff --git a/dev-python/testfixtures/metadata.xml b/dev-python/testfixtures/metadata.xml
deleted file mode 100644
index d02cc23..0000000
--- a/dev-python/testfixtures/metadata.xml
+++ /dev/null
@@ -1,10 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
-<pkgmetadata>
- <herd>python</herd>
- <maintainer><email>tampakrap@gentoo.org</email></maintainer>
- <maintainer>
- <email>della5@iinet.com.au</email>
- <name>Ian Delaney aka idella4 proxy maintainer</name>
- </maintainer>
-</pkgmetadata>
diff --git a/dev-python/testfixtures/testfixtures-2.3.4.ebuild b/dev-python/testfixtures/testfixtures-2.3.4.ebuild
deleted file mode 100644
index 77b8caf..0000000
--- a/dev-python/testfixtures/testfixtures-2.3.4.ebuild
+++ /dev/null
@@ -1,50 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: $
-
-EAPI=4
-PYTHON_DEPEND="2"
-SUPPORT_PYTHON_ABIS=1
-RESTRICT_PYTHON_ABIS="3.* *-pypy-* *-jython"
-DISTUTILS_SRC_TEST="py.test"
-inherit distutils eutils
-
-DESCRIPTION="A collection of helpers and mock objects for unit tests and doc tests"
-HOMEPAGE="http://pypi.python.org/pypi/testfixtures/"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-LICENSE="MIT"
-SLOT="0"
-
-KEYWORDS="~amd64 ~x86"
-IUSE="doc test"
-
-RDEPEND=""
-DEPEND="${RDEPEND}
- doc? ( dev-python/sphinx )"
-# test? ( net-zope/zope-component )"
-
-src_prepare() {
- sed -e s':../bin/sphinx-build:/usr/bin/sphinx-build:' \
- -i docs/Makefile || die
- epatch "${FILESDIR}"/${P}-adjust_tests.patch
-
- # remove test that tests the stripped zope-component test_components.ComponentsTests
- rm -f testfixtures/tests/test_components.py || die
- distutils_src_prepare
-}
-src_compile() {
- distutils_src_compile
-
- use doc && emake -C docs html
-}
-
-src_test() {
- distutils_src_test ${PN}/tests/
-}
-
-src_install() {
- distutils_src_install
- if use doc; then
- dohtml -r docs/_build/html/
- fi
-}