summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJens Pranaitis <jens@chaox.net>2013-04-28 19:38:20 +0200
committerJens Pranaitis <jens@chaox.net>2013-04-28 19:38:20 +0200
commitbd7aa53852c284b129d5bec9151ff3076cebd76b (patch)
treeb2c7827c8172137d56595fe3061922ff1d8173ef
parentjenkernel: install dropbear tarball (diff)
downloadjensp-bd7aa53852c284b129d5bec9151ff3076cebd76b.tar.gz
jensp-bd7aa53852c284b129d5bec9151ff3076cebd76b.tar.bz2
jensp-bd7aa53852c284b129d5bec9151ff3076cebd76b.zip
added mozilla_password_dump
-rw-r--r--app-admin/mozilla_password_dump/Manifest1
-rw-r--r--app-admin/mozilla_password_dump/mozilla_password_dump-9999.ebuild38
2 files changed, 39 insertions, 0 deletions
diff --git a/app-admin/mozilla_password_dump/Manifest b/app-admin/mozilla_password_dump/Manifest
new file mode 100644
index 0000000..abe5a2e
--- /dev/null
+++ b/app-admin/mozilla_password_dump/Manifest
@@ -0,0 +1 @@
+EBUILD mozilla_password_dump-9999.ebuild 804 SHA256 1747925e3c587fc1f5d1e310573227271dce6baeed154284f1498154b36aead4 SHA512 9c08d18002bc8005bf8c8e0758bfe774babf436304878fc7f4548c5ce340d2e43e6f73f88df766054ad48dfe55f64c8e8b0572abe712d204a84a5a58b7c9a059 WHIRLPOOL f30caf9baffb4deb5ac1e00396683411dc3ba14bae39694e0953d31f0ea779d26340b72ddb448581a4df860265baebc597b28351fc11e48d04f93368d710571e
diff --git a/app-admin/mozilla_password_dump/mozilla_password_dump-9999.ebuild b/app-admin/mozilla_password_dump/mozilla_password_dump-9999.ebuild
new file mode 100644
index 0000000..6db9a25
--- /dev/null
+++ b/app-admin/mozilla_password_dump/mozilla_password_dump-9999.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=4
+
+inherit git-2 eutils
+
+DESCRIPTION="Dump Firefox, SeaMonkey and Thunderbird passwords from profile"
+HOMEPAGE="https://github.com/kholia/mozilla_password_dump"
+SRC_URI=""
+EGIT_REPO_URI="git://github.com/kholia/mozilla_password_dump.git"
+
+LICENSE=""
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+DEPEND="dev-libs/nspr
+ dev-libs/nss
+ dev-libs/iniparser
+ dev-libs/sqlite:3"
+RDEPEND="${DEPEND}"
+
+src_compile() {
+ $(tc-getCC) \
+ ${CFLAGS} \
+ -I/usr/include/nss -I/usr/include/nspr -c mozilla_password_dump.c || die
+ $(tc-getCC) \
+ ${LDFLAGS} \
+ -o mozilla_password_dump mozilla_password_dump.o \
+ -lnspr4 -lnss3 -lsqlite3 -liniparser || die
+}
+
+src_install() {
+ dobin ${PN}
+ dodoc README
+}